No recursive search with the simple engine

Bug #1077415 reported by Doug McMahon on 2012-11-10
148
This bug affects 28 people
Affects Status Importance Assigned to Milestone
Nautilus
Unknown
Unknown
nautilus (Ubuntu)
Low
Unassigned
Declined for Raring by Sebastien Bacher

Bug Description

Currently nautilus (1:3.6.2-0ubuntu2 in raring only searches current dir. The recursive search was re-enabled in git shortly after 3.6.1 was released & could be added to the current nautilus build in raring
(i've been using 3.6.2-0ubuntu2 patched with all 4 commits mentioned here & seen no issues.
http://bazaar.launchpad.net/~vcs-imports/nautilus/master-git/revision/16734
I'd also look @ 16733 & 16732 plus possibly 16768

ProblemType: Bug
DistroRelease: Ubuntu 13.04
Package: nautilus 1:3.6.2-0ubuntu2
ProcVersionSignature: Ubuntu 3.5.0-17.28-generic 3.5.5
Uname: Linux 3.5.0-17-generic x86_64
ApportVersion: 2.6.2-0ubuntu3
Architecture: amd64
Date: Sat Nov 10 12:26:52 2012
GsettingsChanges:
 b'org.gnome.nautilus.window-state' b'geometry' b"'1043x520+236+24'"
 b'org.gnome.nautilus.window-state' b'sidebar-width' b'164'
InstallationDate: Installed on 2012-10-23 (18 days ago)
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Release amd64 (20121017)
MarkForUpload: True
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: nautilus
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Doug McMahon (mc3man) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nautilus (Ubuntu):
status: New → Confirmed
Changed in nautilus (Ubuntu):
importance: Undecided → Low
komputes (komputes) wrote :

Hi Seb,

Cosimo reported in October that recursive search was turned back on in git master. Any chance we can sync this change for 13.04?

https://bugzilla.gnome.org/show_bug.cgi?id=325146#c10

Cheers,

David

Changed in nautilus (Ubuntu):
milestone: none → ubuntu-13.04-beta-1
milestone: ubuntu-13.04-beta-1 → none
alecive (alecive) wrote :

Gnome 3.6 is the worst gnome ever, and recursive search removal played a pivotal role on this. Do we really need to get stuck with gnome devs that mess up their DE and remove this functionality (and many other) from the upcoming ubuntu release?

theghost (theghost) wrote :

This is the worst regression ever. I tend to search very often.
How can we help to get this fixed in Raring ?

Sebastien Bacher (seb128) wrote :

over exageration will not get you anywhere, quite the contrary, that missing feature can be annoying but it's not a very important bug either...

Rainer Rohde (rainer-rohde) wrote :

Well, in my humble opinion this is a very important feature that's currently not available to users. For example, I have to look for documents all the time for work, and Nautilus doesn't descent into subdirs, and the Unity Dash doesn't find them because I haven't used those docs in a few days. My workaround for now is to use the "find" command from the CLI, which is rather cumbersome....

So yes, a quick fix is highly appreciated.

Thanks.

MC (guillaume-mc) wrote :

In my opinion this is a major issue as a Desktop OS must offer the possibility to search a file !

mahikeulbody (mahikeulbody) wrote :

I can't imagine to explain to my former Windows users converted to Ubuntu that they will not be able to search a file with 13.04. They will be able to automatically search Amazon products but not a file in their PC ?! It would be ridiculous.

Claudio (claudio-fischer) wrote :

I tried Fedora 18. It includes nautilus 3.6.3. Here the recursive search is working fine.
Does Fedora 18 use an other nautilus 3.6.3 as ubuntu raring nautilus 3.6.3.
The version numbers of nautilus are the same, but not the functionality?

Changed in nautilus (Ubuntu):
status: Confirmed → Fix Committed
Rainer Rohde (rainer-rohde) wrote :

Thanks Sebastien for the update. Is there an outlook as to when this fixed might become available?

Thank you.

Sebastien Bacher (seb128) wrote :

@Rainer: I changed to "fix committed" while uploading, so a bit before you asked ;-) see https://launchpad.net/ubuntu/+source/nautilus/1:3.6.3-0ubuntu12

Rainer Rohde (rainer-rohde) wrote :

Fantastic news. Thank you, Sebastien. :)

Rainer Rohde (rainer-rohde) wrote :

Sebastien -- I just upgraded and tested the recursive search and it works like a charm. I found the desired files that were nested in various sub-directories. Thanks again for the great effort!

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nautilus - 1:3.6.3-0ubuntu12

---------------
nautilus (1:3.6.3-0ubuntu12) raring; urgency=low

  * debian/patches/git_enable_simple_search_engine.patch,
    debian/patches/git_search_dir_incremental_load.patch,
    debian/patches/git_search_recursive_dir.patch:
    - backport some patches to fix recursive directory search (lp: #1077415)
 -- Sebastien Bacher <email address hidden> Fri, 22 Mar 2013 18:45:04 +0100

Changed in nautilus (Ubuntu):
status: Fix Committed → Fix Released
theghost (theghost) wrote :

Great news. Thank you for the fix Sebastien :)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.