Build with tracker support

Bug #1076232 reported by aaron-bru on 2012-11-08
48
This bug affects 9 people
Affects Status Importance Assigned to Milestone
nautilus (Ubuntu)
Wishlist
Unassigned

Bug Description

Searching for files on the activities overview does not work.
According to this bug: https://bugzilla.gnome.org/show_bug.cgi?id=687565
it is because
"Nautilus is built with "--enable-tracker=no" on Ubuntu."

It would be appreciated if this could be fixed so that file search on the overview would work.

I have Nautilus 3.6.2 (from http://ppa.launchpad.net/gnome3-team/gnome3/) on Ubuntu 12.10 with tracker installed.
thanks

Related branches

aaron-bru (aaron-bru) on 2012-11-08
description: updated
affects: gnome-documents (Ubuntu) → nautilus
description: updated
aaron-bru (aaron-bru) wrote :

How to do this manually:

 apt-get source --download-only nautilus
extract both archives into the same folder
if you do not have unity installed, comment out the unity files from debian/patches/series
in the folder, run the following:
./debian/rules
aclocal
autoconf
automake --add-missing
UNITY_CFLAGS=-I/usr/include/libdbusmenu-glib-0.4 UNITY_LIBS=-llibdbusmenu-glib-0.4 ./configure --enable-tracker=yes --disable-unity
make
sudo make install

This did the trick for me, files search is now working great from the activities overview as well as from nautilus. I am now able to get rid of gnome-documents.

Also as a simpler workaround you can try https://extensions.gnome.org/extension/284/tracker-search/

mangelasakis (mangelasakis) wrote :

This problem has existed for 8 months and it is solved in nautilus 3.7. Why you don't upgrade nautilus?

aaron-bru (aaron-bru) wrote :

I guess there used to be only version 3.6 for Ubuntu available. I guess I will upgrade next release or something. Thanks for the tip incase anyone else has this problem.

Changed in nautilus:
status: New → Fix Committed
Jeremy Bicha (jbicha) wrote :

This is blocked because tracker is not in main. Previously, the Ubuntu Desktop team was reluctant to enable tracker for the default Unity desktop.

affects: nautilus → nautilus (Ubuntu)
Changed in nautilus (Ubuntu):
status: Fix Committed → Confirmed
importance: Undecided → Wishlist
summary: - nautilus 3.6 tracker disabled
+ Build with tracker support
Kirill Kabardin (kkabardin) wrote :

Err... Does that mean that all gnome-shell users must rebuild nautilus from source to get gnome-shell file search working?

Kirill Kabardin (kkabardin) wrote :

Maybe gnome3-team should build nautilus replacement packages in their PPA, like nautilus-with-tracker or nautilus-gnome or something?

aaron-bru (aaron-bru) wrote :

wait...does that mean that mangelasakis' comment is incorrect? My impression from his comment is that this is fixed in newer versions. I tried switching to >3.6 but it was to much of a pain on 12.10. I'm gonna upgrade soon anyways, for now I will stick to my custom build.

If the issue does still exist in gnome3-team's PPA then I definately agree that it should be fixed in nautilus, ideally with a runtime config option I think.

Kirill Kabardin (kkabardin) wrote :

This is not a nautilus problem, nautilus is ok. This is Ubuntu packagers that turns tracker support off to minimize dependencies and to reduce live-cd size, I suppose. The problem is that gnome3-team packagers doen't enable tracker support when packaging nautilus to their PPA in spite of that breaks gnome-shell search badly.

aaron-bru (aaron-bru) wrote :

If this is desired to be a compile-time option that is fine with me. I think its pretty obvious that the gnome3-team PPA should build nautilus with tracker enabled. I'm surprised more people haven't complained yet.

petersaints (petersaints) wrote :

I thinks this is a major user experience problem, that should somehow be fixed before 13.10 is releases (yes it also happens on Saucy Salamander).

petersaints (petersaints) wrote :

Also, I understand that you don't want to have to keep a Nautilus version always slightly ahead (in version number) with tracker support enabled. But what about on the GNOME 3 Next PPA (or whichever PPA that has a newer GNOME version than the current Ubuntu release) you build nautilus with tracker support. For example, on the upcoming Ubuntu 13.10, nautilus will always be at version 3.8.x WITHOUT tracker support. But whoever uses the GNOME 3 Next PPA will have nautilus 3.10.x. That 3.10.x version could be built with tracker support without the "fear" of the main Ubuntu nautilus version (3.8.x WITHOUT tracker support) replacing it. The new nautilus is from a newer version of GNOME so it will always be kept instead of the default one.

Just think about it... at least whoever wants to be on the latest GNOME stable release will have Nautilus and the Activities overview with all of its goodies enabled.

Dawid Lorenz (adlorenz) wrote :

The issue with files not being searchable in the Activities Overview (unless they are placed directly in Home folder) is present in 13.10. Upgrading packages from gnome3-ppa doesn't help either, despite enabling "Files" search provider in the Search Settings applet. However, recursive searching files across folders is perfectly possible in the Nautilus window itself. Just not in the Activities Overview.

Compiling Nautilus by hand (as per instruction in the comment #1 above) fails. My current version of Nautilus is 1:3.8.2-0ubuntu2.

Since the tracker-search 3rd party extension (https://extensions.gnome.org/extension/284/tracker-search/) is not compatible with 3.8 and aforementioned bug is still in place, I reckon being unable to search for files quickly straight in the Activities Overview is a major regression.

Steve O (stratus-ss) wrote :

I can confirm this still exists in Ubuntu Gnome 14.04

Tim Lunn (darkxst) wrote :

we can't fix this in 14.04, however nautilus 3.12 in gnome3-staging should be built with tracker support

for Utopic there is a MIR awaiting approval for tracker (LP: #1313996), provided this gets accepted then we can build nautilus with tracker support in 14.10

Tim Lunn (darkxst) wrote :

tracker MIR has been approved now, attaching nautilus patch to build with (run-time conditionally) tracker support

Tim Lunn (darkxst) wrote :

tracker MIR has been approved by didrocks, this builds nautilus with tracker support, indexing will only run on GNOME sessions

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nautilus - 1:3.10.1-0ubuntu13

---------------
nautilus (1:3.10.1-0ubuntu13) utopic; urgency=medium

  * debian/control.in: Add build-dep on libtracker-sparql-1.0-dev
  * debian/rules: enable tracker backend (LP: #1076232)
  * debian/patches:
    - ubuntu_tracker_only_on_GNOME.patch: only start the tracker
      index on GNOME sessions
    - git_also_tracker-1.0.patch, look for tracker-1.0
 -- Tim Lunn <email address hidden> Wed, 13 Aug 2014 23:22:44 +1000

Changed in nautilus (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers