Nautilus pass wrong position index values in icon and list view

Bug #1061550 reported by Attila Hammer on 2012-10-04
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
nautilus (Ubuntu)
Low
Unassigned

Bug Description

Dear Developers,

Unfortunately this issue is not possible to report with upstream level the Nautilus package I think, because I experienced this issue under Quantal awailable Nautilus latest package.
Few days ago some upstream awailable a11y related fixes are committed the Quantal awailable Nautilus package. File rename operation related the accessible for rename text entry markup with editable fix works right.
When I trying latest modifyed Nautilus version in Ubuntu Quantal, I experienced Nautilus pass Orca Screen Reader wrong icon position index values (index number). Orca have a speak child position feature, with allows to user known what the current selected position of an object, and how many objects possible selecting (file or icon in a folder or the desktop, actual selected menu item position index value, etc).
For example if you have a folder five files, and you land the second file the folder, ydeal situation Orca need spokening 2 of 5 position index value (2 meaning you land the second file, and 5 meaning 5 files awailable the folder).
In Nautilus modifyed version some time this passed values are inwalid, a test case with easy to reproducable:
1. Launch Orca Screen Reader, and goto preferences dialog. If you click preferences button, will be opening Orca preferences dialog.
2. In speech page check the speak child position check box, and click ok button.
3. Run following commands to have some icons in the desktop: gsettings set org.gnome.nautilus.desktop computer-icon-visible true, gsettings set org.gnome.nautilus.desktop network-icon-visible, gsettings set org.gnome.nautilus.desktop trash-icon-visible, gsettings set org.gnome.nautilus.desktop home-icon-visible true commands.
4. Goto the desktop, and move between icons. If I for example choose sort by name, icon order is following in the desktop: Computer, Home Folder, Network Servers, Trash.
If I moving between icons, Orca spokening following informations:
Computer Icon. 4 of 4." (1 of 4 the right position index value).
"Home Folder icon. 2 of 4." (this position index value is right).
"Network Servers icon. 3 of 4." (This position index value is right).
"Trash icon. 1 of 4." (This position index value is invalid, 4 of 4 the right value).

Another testcase after you check Orca speech preferences the speak child position index feature:
1. Open Terminal.
2. Run sudo Nautilus / command, and moving between folders. Some time all position index values are right, some time not. For example if I closing Nautilus, moving desktop icons in the desktop and repeat the test, I not always hear right position index values.

I will be searching prewious what upstream level committed fix producing this error.

Attila

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: nautilus 1:3.5.90.really.3.4.2-0ubuntu3
ProcVersionSignature: Ubuntu 3.5.0-13.14-generic 3.5.3
Uname: Linux 3.5.0-13-generic i686
ApportVersion: 2.6.1-0ubuntu1
Architecture: i386
Date: Thu Oct 4 13:15:00 2012
GsettingsChanges:
 b'org.gnome.nautilus.window-state' b'geometry' b"'800x550+0+24'"
 b'org.gnome.nautilus.window-state' b'start-with-sidebar' b'false'
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=hu_HU.UTF-8
 SHELL=/bin/bash
SourcePackage: nautilus
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Attila Hammer (hammera) wrote :
Attila Hammer (hammera) wrote :

Ok, I found possible what applied commit working wrong with need fixing:
Original, GNOME developers the bug 677509 report related doed a fix after Nautilus 3.4.2 maintenance release. This fix working partialy wrong I think.
Now original Nautilus version I think use different vidget (I think can was), not icon view, so impossible to report this problem with upstream level the Nautilus application.

Orca level I reported this issue with following upstream report prewious:
https://bugzilla.gnome.org/show_bug.cgi?id=681523

Attila

Sebastien Bacher (seb128) wrote :

Thanks, the fixes backported are basically the ones from http://git.gnome.org/browse/nautilus/log/?h=gnome-3-4 (see the commits with a11y in the name)

I guess the problematic one is http://git.gnome.org/browse/nautilus/commit/?h=gnome-3-4&id=3b73a3f460a4dbbe73d9942127a9e050b5807b91

Was the situation better before that upload? Should maybe that fix be reverted? (though it would be good to tell upstream if they created a regression in their gnome-3-4 serie)

Changed in nautilus (Ubuntu):
importance: Undecided → Low

Sebastien, I don't no GNOME developers will be fixing this commit
related error in 3.4 series, because after official 3.4.2 release
committed the fix into gnome-3-4 branch of Nautilus and master branch.
I think end of the 2.4 series maintenance cicle already.
Original upstream master branch existing this commit and Nautilus 3.6.0
original version containing this commit?
The situation is little better if this commit reverted, because this
situation Orca not spokening the position index values (not spokening
wrong values some situation because now this fix is broken).
Possible keeping other added important a11y related commits into
Nautilus 3.5.90.really.3.4.2-0ubuntu3 version, and rewerting only the
you wrote commit until anybody not fixing this issue this commit related
(upstream Nautilus developers or Ubuntu developers)?

Attila

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nautilus - 1:3.5.90.really.3.4.2-0ubuntu4

---------------
nautilus (1:3.5.90.really.3.4.2-0ubuntu4) quantal; urgency=low

  * debian/patches/git_a11y_prototype.patch,
    debian/patches/git_icons_a11y.patch:
    - revert those commits added in the previous reverision,
      the spoke indexes are wrong (lp: #1061550)
 -- Sebastien Bacher <email address hidden> Fri, 05 Oct 2012 18:57:29 +0200

Changed in nautilus (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.