[Precise only] accessible for rename text entry isn't marked "editable"

Bug #1060852 reported by Attila Hammer on 2012-10-03
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
nautilus (Ubuntu)
Low
Unassigned
Precise
Low
Unassigned

Bug Description

[Impact]
In Nautilus 3.4 version accessible for rename text entry isn't marked editable. This bug resulting a11y tools (for example Onboard, Orca Screen Reader) doesn't get accessibility related informations if the user want renaming a file, creating a new document or a new folder. If the user try moving arrow keys for example the entry fields between characters, Orca Screen Reader doesn't spokening or presenting braille the highlighted character. If the user want deleting a character, in the braille display the change is not wisible, and Orca doesn't have possibility to spokening the deleted character.

Because worldwide lot of people using a11y products, and Ubuntu 12.04 is an LTS release, please fix this issue in Precise too if release related rules awailable this. We have lucky, because already have upstream level created safe fix for 3.4 series.

This is fixed in upstream 3.4.x trunk (not released yet, but that's where this patch comes from) and 3.5.x. Also fixed in quantal.

[Test Case]
1) Open orca, having it read UI elements aloud
2) Open nautilus
3) Start renaming a file
4) Move cursor between characters

You should hear orca read each character as you move past it (c.f. doing the same in gedit).

[Regression Potential]
This patch only deals with accessibility code, so I would expect any problems to be there.

Attila Hammer (hammera) wrote :
Attila Hammer (hammera) wrote :

Sebastien, I created a debdiff based with Precise awailable Nautilus 3.4.2-0ubuntu4 version.
Possible need modifying the debian/changelog file and debian/control file, but the patch working right if I downloading again original Nautilus source package with apt-get source command and apply the deb diff with patch -p0 <deb diff name command.
If I doing any step wrong the debdiff, I regenerating welcome the deb diff. I builded modified source package with following command:
debuild -S -us -uc

I not want signing now this package, because I have permissions now only uploading packages my PPA repositories.
If need generating testing source package with debuild -S command, I welcome doing this.

Attila

The attachment "Debdiff to add upstream level doed fix for Nautilus 3.4.2 series" of this bug report has been identified as being a patch in the form of a debdiff. The ubuntu-sponsors team has been subscribed to the bug report so that they can review and hopefully sponsor the debdiff. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-sponsors team please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch
Michael Terry (mterry) wrote :

Marking Fix Released for quantal. I opened a precise task to track this SRU request.

Changed in nautilus (Ubuntu):
status: New → Fix Released
Michael Terry (mterry) on 2012-10-03
description: updated
Michael Terry (mterry) wrote :

I uploaded to precise-proposed. It's waiting to be accepted.

Changed in nautilus (Ubuntu):
importance: Undecided → Low
Changed in nautilus (Ubuntu Precise):
importance: Undecided → Low
status: New → In Progress

Hello Attila, or anyone else affected,

Accepted nautilus into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/nautilus/1:3.4.2-0ubuntu5 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in nautilus (Ubuntu Precise):
status: In Progress → Fix Committed
tags: added: verification-needed

Brian, the package is not awailable yet the Proposed repository, I now
doed a sudo apt-get update and sudo apt-get dist-upgrade command.
If this upgraded version are awailable, short time later I will be doing
the verification and change the you wrote tag with proper value.

Many thanks the notification,

Attila

Attila Hammer (hammera) on 2012-10-19
tags: added: verification-done
removed: verification-needed
Attila Hammer (hammera) wrote :

Brian, now I upgraded the Nautilus 1:3.4.2-0ubuntu5 package version from the proposed repository.
The reported bug me resolved this package version after logout and login back, I don't see any negative effect after upgrade.
Please upload this version into precise-updates repository any time if this is possible.

Attila

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nautilus - 1:3.4.2-0ubuntu5

---------------
nautilus (1:3.4.2-0ubuntu5) precise-proposed; urgency=low

  * debian/patches/22_fix_rename_editbox_a11y_problem.patch:
    - Fix rename editbox accessibility related problem (LP: #1060852)
 -- Attila Hammer <email address hidden> Wed, 03 Oct 2012 12:34:12 +0200

Changed in nautilus (Ubuntu Precise):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers