Nautilus '~/Templates' folder does not exist

Bug #10435 reported by Omer on 2004-11-18
36
This bug affects 1 person
Affects Status Importance Assigned to Milestone
nautilus (Ubuntu)
Wishlist
Ubuntu Desktop Bugs

Bug Description

Whereas this folder should be auto created during a gnome installation, it is
not. thus, new users can't figure out how to add file templates when using the
right click context menu.
Also, adding empty file types to this folder (e.g. txt, xcf, openoffice
documents), could ease the use of templates for new users.

Sebastien Bacher (seb128) wrote :

Perhaps the dir should be created right, but not sure that's nautilus' job ...

BTW there is no default templates on purpose but admins/users are free to
make changes at this level.

Colin Watson (cjwatson) wrote :

(assigning to nautilus for now since that's better than UNKNOWN, feel free to
reassign wherever's appropriate)

Colin Watson (cjwatson) wrote :

OK, some reasons why I think adding this directory to /etc/skel would be bad,
since Jeff asked on IRC:

  * it pollutes the default home directories of non-desktop users; non-dotfiles
are particularly annoying for this in heterogeneous environments, and create an
unpolished impression in my experience
  * it's the wrong place; if it's useful for GNOME then GNOME should be creating
it on demand, not relying on adduser or whatever to do it
  * there exist plenty of user-addition tools that don't honour /etc/skel;
sysadmins don't all use the Official Distro Method, particularly when they're
taking care of networks featuring many different flavours of Unix
  * remotely-created home directories are a reality; consider NFS-mounted /home,
which is very common in corporate environments; the home directory may have been
created long before the distro was installed

I feel that if a solution is both ugly for people who don't need it and
inadequate for people who do, then it's a pretty good sign that other solutions
should be considered instead.

Omer (omeraloni) wrote :

Maybe creating the dir in ~/.gnome2 could be a better solution than ~. Also,
adding a 'Go To Templates Folder' in the 'Create Document' sub-menu, is more
user-oriented approach, new and advanced.

Sebastien Bacher (seb128) wrote :

reassigning to the right person

George Bills (u2564793) wrote :

I would definitely like to add that having a load of default templates in there
(especially "new text document.txt") would be very nice.

Dennis Kaarsemaker (dennis) wrote :

I agree that there should be templates installed, would be a nice addition for
the ExampleContent spec

This feature request is relevant -> confirmed. (but feel free to WONTFIX it ;-)

I really like Omer's suggestion of a dot templates folder with a "go to template folder" button somewhere.

Changed in nautilus:
status: Unconfirmed → Confirmed
desrt (desrt) wrote :

crikey! please no more directories in my ~. even if they are hidden.

Omer (omeraloni) wrote :

Well, after re-thinking, it came to my mind that a new user is not familiar with the way of creating templates.
So the best solution is to provide a few common templates, located in /usr/share/gnome/templates (/usr/share/templates is already taken), deprecating the need for ~/Templates.
Users who wish to create new templates, and follow nautilus>Go>Templates, will be redirected to ~/.gnome2/Templates, where they can create custom templates.

Bryan Quigley (bryanquigley) wrote :

For a transition from Windows, some people will expect to immediately be able to right click and create documents. I know I was expecting it.

I don't know the specifics but after reading this, I was able to get templates working immediately. I also don't know enough to understand why this is a default behavior, but having this work is an important tool for making the GUI worth using.

For example. Bob is a new user of ubuntu, he copied some folders over from Windows. The folders are complicated to the say the least. Three folders copied, A, B, C. In each of them is folders 1, 2, 3. Bob can use Nautilus to view the files fine. But since he creates new files after viewing similar ones he is somewhat annoyed. He had to start up <program here> and navigate to the folder he is currently in, again. Then save the file.

In windows, he just right clicked went to New -> Text Document.
He could easily do it in ubuntu but he has been working around software his whole life and just uses the default.

We need a more powerful default.

Can we have default templates of at least Text Document, Spreadsheet, Presentation, Drawing?

By the way, is the a "All Users" Replacement is Linux/Gnome/Ubuntu/ basically you would through it in there and all users would get it.

Stefan Nuxoll (snuxoll) wrote :

Sorry gQuigs, but no, there is no "All Users" replacement that I am aware of, you should try searching around and see.

lucasvo (lucasvo) wrote :

I think one should implement the standard for all users. (it's the same in windows :) Using /usr/share/gnome/templates for it would be very good.

I brought up this issue before in Fedora, and I've been told that it's
because of the translations problems.

On 5/20/06, lucasvo <email address hidden> wrote:
>
> I think one should implement the standard for all users. (it's the same
> in windows :) Using /usr/share/gnome/templates for it would be very
> good.
>
> --
> Nautilus '~/Templates' folder does not exist
> https://launchpad.net/bugs/10435
>

--
Linux is a gun that you point to Microsoft.
- Joel Juliano

Joel Bryan Juliano (joelbryan) wrote :

I'm willing to make a simple script to fix the issue of translating them and
copy them to the respective $HOME/.Templates directory, based on locale,
which I think is very easy to fix. The create document feature is rarely
used because it's empty.

On 5/21/06, Joel Bryan Juliano <email address hidden> wrote:
>
> I brought up this issue before in Fedora, and I've been told that it's
> because of the translations problems.
>
>
> On 5/20/06, lucasvo < <email address hidden>> wrote:
> >
> > I think one should implement the standard for all users. (it's the same
> > in windows :) Using /usr/share/gnome/templates for it would be very
> > good.
> >
> > --
> > Nautilus '~/Templates' folder does not exist
> > https://launchpad.net/bugs/10435
> >
>
>
>
> --
> Linux is a gun that you point to Microsoft.
> - Joel Juliano
>

--
Linux is a gun that you point to Microsoft.
- Joel Juliano

Sebastian Heinlein (glatzor) wrote :

Creating translated links is not the perfect solution to this. Has upstream already made a decision on this? It was discussed some monthes ago but I lost the track.

Changed in nautilus:
assignee: jdub → desktop-bugs
Vincenzo Ciancia (vincenzo-ml) wrote :

Sebastien, you said that there are no default templates on purpose, may I ask why? Wouldn't it be better if major applications like openoffice and gimp created default templates in a shared directory when installed? Or is it the gnome idea that one should instead open, say, the gimp and create a new document?

Sebastien Bacher (seb128) wrote :

Vincenzo, if every application installed was adding a template the menu would have many items and not be easy to use. The administrator or the user can create entries for what he's interested easily enough

Bryan Quigley (bryanquigley) wrote :

How about we provide a useful default first and then let the user/admin
customize it?

On 5/18/07, Sebastien Bacher <email address hidden> wrote:
>
> Vincenzo, if every application installed was adding a template the menu
> would have many items and not be easy to use. The administrator or the
> user can create entries for what he's interested easily enough
>
> --
> Nautilus '~/Templates' folder does not exist
> https://bugs.launchpad.net/bugs/10435
> You received this bug notification because you are a direct subscriber
> of the bug.
>

towsonu2003 (towsonu2003) wrote :

at least a writer, calc, and impress template (with Ubuntu / Canonical branding) and a txt template would be nice

I totally agree that a few, maybe two or three, default templates would be good. And then a 'Create Template' button somewhere so that the system is discoverable

I agree with comments above about the dotfiles - Templates should be .templates

Agree equally with non-desktop users - but if Nautilus is set to create it on startup if it doesn't exist then non-desktop users won't be affected.

As far as I am aware (may be wrong!) Templates is only used by Nautilus. Therefore it should be Nautilus that maintains it.

Unless of course there is an applet in System...Preferences to manage templates. Newly installed applications can register with template manager and user can pick/choose from a list of templates. (That's off the top of the head so feel free to shoot it down).

I've just read this thread through again and think that there's a point being missed here by the names I see frequently in launchpad - so I assume they're experienced users of Gnome. That point is that although the current system is good and works well, few new users are ever finding it - so it's no use to them! The fact that 'Right click > 'Create Document' is there suggests that a template system exists but doesn't help a user new to gnome to find out how to use it. I believe the buzz word is discoverable. (sorry for reposting my arguments)

TimH (biotim) wrote :

I agree. I was using Ubuntu for about year before I decided to investigate the possibility of creating templates. Particularly handy ones are ones like skeleton HMTL pages and Perl scripts, since those actually save you some typing effort in addition to creating the file with the right extension.

I think xdg-user-dirs now creates a templates directory and this bug can be closed?

Sebastien Bacher (seb128) wrote :

correct, the directory is created now, closing the bug

Changed in nautilus:
status: Confirmed → Fix Released
Mio (m10) wrote :

but there are still no default templates

Mio (immmmanuel-merged) on 2008-05-11
Changed in nautilus:
status: Fix Released → Confirmed
Sebastien Bacher (seb128) wrote :

that's not what the bug was about, don't reopen a closed bug only because you have a similar issue

Changed in nautilus:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.