[Precise] Accessible for rename text entry isn't marked "editable"

Bug #1035273 reported by Attila Hammer on 2012-08-10
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Nautilus
Fix Released
Medium
nautilus (Ubuntu)
Low
Unassigned

Bug Description

Dear Developers,

In Nautilus 3.4.2 if an Orca or onboard user want creating a new document, creating a new folder or renaming a file, Accessible for rename text entry isn't marked "editable".
Orca users for example unable to follow up braille display the typed text, unable to listen speech output the deleted characters, general arrow keys operations Orca unable to spokening the actual character. So, if a visual impaired screen reader user want creating a new document, renaming a file or creating a new directory, unable to verify the typed text is correct or not.
I think this problem affecting with Onboard users too, but I am not full sure this.

Upstream level this problem are reported since 2012 march 20TH in bug 672498, and fixed the bug after Nautilus 3.4.2 maintenance release both gnome-3-4 branch and master development branches. I think the upstream bug reported with Onboard related first, but this bug affected Orca users too before this bug upstream level not fixed.
Unfortunately Nautilus 3.4.3 maintenance release not released yet (I am not full sure will be have Nautilus 3.4.3 maintenance release or not), so I followed back the need commits and doed a quilt patch with absolute sure resolve this bug with Orca users.

My local machine downloaded latest awailable nautilus source package, apply the created quilt patch and recompile Nautilus package. After all builded packages are installed, I logged out and logged in, and try renaming operation, create new document operation and create new folder operation. Both three operations Orca I possible to use the presenting entry widgets.
If this is possible, please apply this upstream patch in Nautilus source package until Nautilus 3.4.3 maintenance release not releasing GNOME developers.

Attila

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: nautilus 1:3.4.2-0ubuntu4
ProcVersionSignature: Ubuntu 3.2.0-29.46-generic-pae 3.2.24
Uname: Linux 3.2.0-29-generic-pae i686
ApportVersion: 2.0.1-0ubuntu12
Architecture: i386
Date: Fri Aug 10 13:29:59 2012
GsettingsChanges:
 org.gnome.nautilus.window-state geometry '800x550+0+24'
 org.gnome.nautilus.window-state maximized true
 org.gnome.nautilus.window-state start-with-sidebar false
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Beta i386 (20120327)
SourcePackage: nautilus
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Attila Hammer (hammera) wrote :
Attila Hammer (hammera) wrote :

I forgot copy the upstream bugreport link:
https://bugzilla.gnome.org/show_bug.cgi?id=672498

Attila

The attachment "Patch from upstream gnome-3-4 branch with resolve this bug" of this bug report has been identified as being a patch. The ubuntu-reviewers team has been subscribed to the bug report so that they can review the patch. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-reviewers team please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nautilus (Ubuntu):
status: New → Confirmed
marmuta (marmuta) wrote :

Confirming that this bug affects Onboard in Ubuntu 12.04 too. When auto-show is enabled, Onboard doesn't pop up when renaming files in nautilus.

This seems fixed in Ubuntu 12.10 with nautilus 1:3.5.4-0ubuntu3, though, at least for Onboard.

Changed in nautilus (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Triaged
Changed in nautilus (Ubuntu Precise):
importance: Undecided → Low
no longer affects: nautilus (Ubuntu Precise)
Changed in nautilus (Ubuntu):
importance: Medium → Low
status: Triaged → Fix Committed
Changed in nautilus:
importance: Unknown → Medium
status: Unknown → Fix Released

Sebastien, when will be releasing in Precise repository the updated
Nautilus version with containing the committed a11y related fix?
If I remember right the fix was committed august 28th.
In precise-updates repository have following Nautilus version:
   nautilus | 1:3.4.2-0ubuntu4
This version yet doesn't containing the committed fix.

Attila

Attila Hammer (hammera) wrote :

Sebastien, unfortunately I have very bad news:
I morning looked with Ubuntu 12.10 current daily live CD, and possible
the Quantal awailable Ubuntu level modified Nautilus version not
containing this very important a11y fix. So now Ubuntu 12.04 and Ubuntu
12.10 awailable Nautilus versions not containing yet this fix.
In Ubuntu Quantal following modified nautilus version are awailable:
nautilus | 1:3.5.90.really.3.4.2-0ubuntu2

Reproducation steps in Quantal to you verify this:
1. Launch Orca.
2. Goto your home folder, and press F2 key. Try moving with arrow keys
the edit box. Orca will not spokening any character the edit box if you
using for example left or right arrow keys.

I ofcourse known why need Ubuntu level modifying the Nautilus package,
because GNOME developers upstream level removed some users important
functions (changing desktop background into desktop the context menu, etc).

Attila

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nautilus - 1:3.5.90.really.3.4.2-0ubuntu3

---------------
nautilus (1:3.5.90.really.3.4.2-0ubuntu3) quantal; urgency=low

  * Backported some upstream a11y fixes (lp: #1035273)
 -- Sebastien Bacher <email address hidden> Tue, 02 Oct 2012 20:34:29 +0200

Changed in nautilus (Ubuntu):
status: Fix Committed → Fix Released
Attila Hammer (hammera) wrote :

Sebastien, will be land the rename editbox related a11y fix in Precise
repository?

Attila

Sebastien Bacher (seb128) wrote :

@Attila: it might if somebody works on it, you are welcome to submit a debdiff for a precise SRU if you want

Attila Hammer (hammera) wrote :

Hy Sebastien,

Unfortunately I newer doed a deb diff, but very would like learning the
method. If you tell me how can possible doing this, I welcome doing this
work to help fixing this bug in Precise.
Need attaching this debdiff with this report?
Enough to compare the original debian folder and new debian folder with
diff -u command after I added the quilt patch?

Attila

Sebastien Bacher (seb128) wrote :

Thanks for wanting to work on that, yes the debdiff is basically a diff between the unpacked source before and after the change, you have details on https://wiki.ubuntu.com/PackagingGuide/Recipes/Debdiff#Creating_A_Debdiff

Could you also open a new bug against nautilus? Due to a launchpad bug this one can't be used to track a precise upload (it was edited to track and quantal one but the precise line got deleted on the way and can't be added back)

I will review,sponsor the update once it's available

Attila Hammer (hammera) wrote :

Many thanks the link Sebastien. I promise this day I will be doing the
require debdiff and opening a new bug for Precise.

Attila

Attila Hammer (hammera) wrote :

Sebastien, Precise based deb diff awailable for bug 1060852, thank you
your help.

Attila

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.