nautilus segfaults in icon_set_selected()

Bug #1034548 reported by Anthony Huben on 2012-08-08
94
This bug affects 11 people
Affects Status Importance Assigned to Milestone
Nautilus
Invalid
Medium
nautilus (Ubuntu)
High
Unassigned

Bug Description

When trying to search for a file, nautilus crashed without warning.

ProblemType: Crash
DistroRelease: Ubuntu 12.10
Package: nautilus 1:3.5.5-0ubuntu1
ProcVersionSignature: Ubuntu 3.5.0-8.8-generic 3.5.0
Uname: Linux 3.5.0-8-generic x86_64
ApportVersion: 2.4-0ubuntu6
Architecture: amd64
Date: Wed Aug 8 13:33:45 2012
ExecutablePath: /usr/bin/nautilus
GsettingsChanges:
 b'org.gnome.nautilus.window-state' b'geometry' b"'657x716+52+24'"
 b'org.gnome.nautilus.window-state' b'maximized' b'true'
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Alpha amd64 (20120724.2)
ProcCmdline: nautilus -n
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SegvAnalysis:
 Segfault happened at: 0x492390: movzbl 0x30(%rsi),%eax
 PC (0x00492390) ok
 source "0x30(%rsi)" (0x00000030) not located in a known VMA region (needed readable region)!
 destination "%eax" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: nautilus
StacktraceTop:
 ?? ()
 ?? ()
 ?? ()
 ?? ()
 ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
Title: nautilus crashed with SIGSEGV
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
XsessionErrors: (compiz:1617): GConf-CRITICAL **: gconf_client_add_dir: assertion `gconf_valid_key (dirname, NULL)' failed

Related branches

Anthony Huben (harp37) wrote :

StacktraceTop:
 icon_set_selected (container=0x1ed7400, icon=0x0, select=1) at nautilus-canvas-container.c:479
 nautilus_canvas_container_select_first (container=0x1ed7400) at nautilus-canvas-container.c:6798
 nautilus_view_select_first (view=0x2086300) at nautilus-view.c:406
 done_loading (view=view@entry=0x2086300, all_files_seen=all_files_seen@entry=1) at nautilus-view.c:3153
 display_pending_files (view=0x2086300) at nautilus-view.c:3610

Changed in nautilus (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nautilus (Ubuntu):
status: New → Confirmed
Iain Lane (laney) on 2012-08-09
visibility: private → public
summary: - nautilus crashed with SIGSEGV
+ nautilus segfaults in icon_set_selected()
Changed in nautilus (Ubuntu):
importance: Medium → High
status: Confirmed → Triaged
Changed in nautilus:
importance: Unknown → Medium
status: Unknown → Invalid
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nautilus - 1:3.5.5-0ubuntu2

---------------
nautilus (1:3.5.5-0ubuntu2) quantal; urgency=low

  * debian/patches/git_no_empty_search_segfault.patch:
    - don't segfault when a search returns no result (lp: #1034548)
 -- Sebastien Bacher <email address hidden> Thu, 09 Aug 2012 13:47:01 +0200

Changed in nautilus (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.