Ubuntu

no About menu item

Reported by Adam Dingle on 2012-08-07
30
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Nautilus
Fix Released
Medium
nautilus (Ubuntu)
Low
Unassigned

Bug Description

In Quantal, there is no About item in the Nautilus menu, so it's hard to tell what version of Nautilus I'm running.

In upstream Nautilus from GNOME there is an About menu item, which appears in the app menu. Ubuntu does not display this menu, so I have no way to get to this command.

Sebastien Bacher (seb128) wrote :

Thanks Adam, we are looking at going back to nautilus 3.4 for quantal but it's good to have a good view of the issues with the new version

Changed in nautilus (Ubuntu):
importance: Undecided → Low
status: New → Triaged
Adam Dingle (adam-yorba) wrote :

That's interesting to hear. If Quantal goes back to Nautilus 3.4, will Ubuntu plan to update to later versions of Nautilus in the future, or will it just stay at 3.4 indefinitely (which would be a fork, essentially)?

Changed in nautilus:
importance: Unknown → Medium
status: Unknown → Fix Released
Sebastien Bacher (seb128) wrote :

I'm not sure yet, I'm leaning toward shipping both version in the archive for quantal with 3.4 on the CD and discussing at UDS the way forward based on the feedback nautilus 3.6 and other filemanagers got.

Looking around us "elementary os" has its own filemanager (marlin, written in vala), "mint" just started their own project "nemo" which is a fork of nautilus 3.4 ... we might decide to follow GNOME, try joining efforts with the marlin or nemo team to maintain a full featured file manager or maintain our own filemanager (less likely at this point, that's not a topic which was raised before)

Sebastien Bacher (seb128) wrote :

setting to fix commited since it was fixed in upstream git, it will land with the next update in Ubuntu

Changed in nautilus (Ubuntu):
status: Triaged → Fix Committed
Adam Dingle (adam-yorba) wrote :

Sebastien: that's interesting - all good to know.

For the record, Marlin is actually written mostly in C, not Vala. (I just looked at the source and counted 57K lines of C and 9K of Vala.)

Nate Wiebe (natew) wrote :

I for one would go with joining the Marlin team. Solid looking file manager with great features.

Just to correct things. Marlin is no longer developed by the Elementary team. The maintainer had some issues with the Elementary project and they decided to continue the development under the name pantheon-files instead. Pantheon-files is now a much better product than Marlin due to a much more rapid development pace and strong leadership. So don't consider Marlin, consider Pantheon-files.

https://launchpad.net/pantheon-files

Sebastien Bacher (seb128) wrote :

The issue is fixed with 3.5.5 in quantal

Changed in nautilus (Ubuntu):
status: Fix Committed → Fix Released
ammonkey (am-monkeyd) wrote :

Hello, can a moderator remove the comment #7 please? last time i checked this was a buglist and not a forum for troll.

I am Marlin's creator and actual maintainer, this project was created from the ground up 2 years ago. I think i kinda know my repository and i can't remember any significant commit made in the name of Elementary. So no, Elementary never actually developed Marlin. Nevertheless Elementary has been a very supportive community arround this project until i left them one year ago. Since then nothing has really changed on Marlin's side, the project is still being actively developed by the same people. It appears that things have changed recently on Elementary side and they decided to fork the project and adopt their HIG. Marlin never was destined to a particular OS/distribution, it's a filemanager built for gtk environnement, it has a good Unity integration and will have a good gnome integration (if possible).
The actual elementary developers at the origin of this fork were never actively involved in Marlin's development. Most of them never actually committed a single line of code for Marlin. It's a bit a shame than after all theses years when finally elementary wake up about some serious filemanager coding it's to generate a fork. But i guess we don't loose anything 0 - 0 = 0.

It's not the first time elementary fork a project, they have already forked Beatbox into Noise now Marlin into Pantheon-files, adding a new fork to an already long list while core developers move away. It's not the first time a project is forked either so there's no need to add some drama. This how life goes for open-sources projects. Anybody can judge what a fork bring on the table and everybody got differents needs. In some ways Marlin is a fork of Nautilus, Thunar and nautilus-elementary (and even got some Dolphin's inspirations) :)
All of thoses are magnificient projects and a great source of inspiration.

I'd be happy to talk about Marlin's development and internals but it wouldn't be appropriated to do it on the Nautilus buglist. You know where to find me if you want to know more or if you have questions.

KP Stolk (kp-stolk) wrote :

I really hope Ubuntu will cooperate with the creators of Marlin and use it as default file manager, since this file manager is a way faster and has a better look then Nautilus has.

But in that case the desktop should be handled also I think (https://bugs.launchpad.net/marlin/+bug/898201)

Karma Dorje (taaroa) wrote :

@KP Stolk
do you want to talk about it? ☺
If you need support or help, please fill out a new bug/issue.

Amr Ibrahim (amribrahim1987) wrote :

I think Ubuntu should keep Nautilus to the latest version and fix or add what's missing instead of choosing another file manager. Nautilus is very familiar and well integrated into GNOME. The Ubuntu developers should focus on fixing Nautilus and improve the user experience of Ubuntu as a whole, and not to waste effort and time on adopting another file manager.

Sam_ (and-sam) wrote :

There is already a smart Nemo. bug 403176

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.