nautilus crashed with SIGSEGV in recent_is_supported()

Bug #1032303 reported by Silas Arn on 2012-08-02
42
This bug affects 6 people
Affects Status Importance Assigned to Milestone
nautilus (Ubuntu)
Medium
Unassigned

Bug Description

Ubuntu 12.10 Alpha-3
Nautilus 1:3.5.4-0ubuntu2

I can't start Nautilus. It immedeately closes after start.

Error Message on Terminal:
'silas@silas-UX31A:~$ nautilus
org.gtk.vfs.MountTracker.listMountableInfo call failed: GDBus.Error:org.freedesktop.DBus.Error.UnknownMethod: Method "ListMountableInfo" with signature "" on interface "org.gtk.vfs.MountTracker" doesn't exist
 (g-dbus-error-quark, 19)
Speicherzugriffsfehler (Speicherabzug geschrieben)'

The last Line is german and means something like "Memory access error".

ProblemType: Crash
DistroRelease: Ubuntu 12.10
Package: nautilus 1:3.5.4-0ubuntu2
ProcVersionSignature: Ubuntu 3.5.0-7.7-generic 3.5.0
Uname: Linux 3.5.0-7-generic x86_64
ApportVersion: 2.4-0ubuntu6
Architecture: amd64
Date: Thu Aug 2 19:14:11 2012
ExecutablePath: /usr/bin/nautilus
GsettingsChanges: b'org.gnome.nautilus.window-state' b'geometry' b"'1164x837+108+209'"
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Alpha amd64 (20120729.1)
ProcCmdline: nautilus
SegvAnalysis:
 Segfault happened at: 0x4523b4: mov (%rax),%rdi
 PC (0x004523b4) ok
 source "(%rax)" (0x00000000) not located in a known VMA region (needed readable region)!
 destination "%rdi" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: nautilus
StacktraceTop:
 ?? ()
 ?? ()
 ?? ()
 ?? ()
 g_closure_invoke () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
Title: nautilus crashed with SIGSEGV in g_closure_invoke()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

Silas Arn (silas89) wrote :
visibility: private → public

StacktraceTop:
 recent_is_supported () at nautilus-places-sidebar.c:435
 update_places (sidebar=sidebar@entry=0x17f4000) at nautilus-places-sidebar.c:494
 nautilus_places_sidebar_set_parent_window (window=0x162a190, sidebar=0x17f4000) at nautilus-places-sidebar.c:3436
 nautilus_places_sidebar_new (window=window@entry=0x162a190) at nautilus-places-sidebar.c:3456
 nautilus_window_set_up_sidebar (window=0x162a190) at nautilus-window.c:599

Changed in nautilus (Ubuntu):
importance: Undecided → Medium
summary: - nautilus crashed with SIGSEGV in g_closure_invoke()
+ nautilus crashed with SIGSEGV in recent_is_supported()
tags: removed: need-amd64-retrace
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nautilus (Ubuntu):
status: New → Confirmed
Silas Arn (silas89) wrote :

Reboot solved the error

dino99 (9d9) wrote :

On Quantal i386 logged as gnome-classic, i also get that message logged into xsession-errors:

org.gtk.vfs.MountTracker.listMountableInfo call failed: GDBus.Error: org.freedesktop.DBus.Error.UnknownMethod: interface "org.gtk.vfs.MountTracker" does not exist for the object to the location / org / gtk / vfs / mounttracker (g-dbus-error-quark, 19)

this is the first message logged. Then nautilus also crash due to "unknown vma "

tags: added: running-unity
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nautilus - 1:3.5.4-0ubuntu3

---------------
nautilus (1:3.5.4-0ubuntu3) quantal; urgency=low

  * debian/patches/git_guard_for_no_supported_vfs_schemas.patch:
    - "places-sidebar: guard for NULL supported VFS schemes array". Resolves
       segfault on launch. (LP: #1032303)
 -- Iain Lane <email address hidden> Mon, 06 Aug 2012 13:02:57 +0100

Changed in nautilus (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers