nautilus crashed with SIGABRT in raise()

Bug #1028028 reported by Sravan Aleti on 2012-07-23
70
This bug affects 14 people
Affects Status Importance Assigned to Milestone
Nautilus
Fix Released
Medium
nautilus (Ubuntu)
High
Unassigned

Bug Description

this happened when switching between folders

ProblemType: Crash
DistroRelease: Ubuntu 12.10
Package: nautilus 1:3.5.4-0ubuntu1
ProcVersionSignature: User Name 3.5.0-5.5-generic 3.5.0-rc7
Uname: Linux 3.5.0-5-generic i686
ApportVersion: 2.4-0ubuntu5
Architecture: i386
Date: Mon Jul 23 21:46:15 2012
ExecutablePath: /usr/bin/nautilus
GsettingsChanges:
 b'org.gnome.nautilus.window-state' b'geometry' b"'800x540+0+30'"
 b'org.gnome.nautilus.window-state' b'maximized' b'true'
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Alpha i386 (20120627)
ProcCmdline: nautilus -n
ProcEnviron:
 LANGUAGE=en_IN:en
 PATH=(custom, no user)
 LANG=en_IN
 SHELL=/bin/bash
Signal: 6
SourcePackage: nautilus
StacktraceTop:
 raise () from /lib/i386-linux-gnu/libc.so.6
 abort () from /lib/i386-linux-gnu/libc.so.6
 g_assertion_message () from /lib/i386-linux-gnu/libglib-2.0.so.0
 g_assertion_message_expr () from /lib/i386-linux-gnu/libglib-2.0.so.0
 ?? ()
Title: nautilus crashed with SIGABRT in raise()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

Sravan Aleti (sravan-aleti) wrote :

Thank you for taking the time to report this crash and helping to make this software better. This particular crash has already been reported and is a duplicate of bug #1026537, so is being marked as such. Please look at the other bug report to see if there is any missing information that you can provide, or to see if there is a workaround for the bug. Additionally, any further discussion regarding the bug should occur in the other report. Please continue to report any other bugs you may find.

visibility: private → public
tags: removed: need-i386-retrace
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nautilus (Ubuntu):
status: New → Confirmed
Changed in nautilus (Ubuntu):
importance: Undecided → High
status: Confirmed → Fix Committed
Changed in nautilus:
importance: Unknown → Medium
status: Unknown → Fix Released
Omer Akram (om26er) wrote :

this happens for me when I press super+d while desktop is in focus.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nautilus - 1:3.5.4-0ubuntu2

---------------
nautilus (1:3.5.4-0ubuntu2) quantal-proposed; urgency=low

  * debian/patches/git_handle_space.patch:
    - "query-editor: make sure not to handle space if we're invisible"
  * debian/patches/git_dont_grab_entry_focus.patch:
    - "Don't grab focus away from the search entry box"
  * debian/patches/git_entry_grab_keys.patch:
    - "This fixes the search entry grabbing pasted URLs." (lp: #1026659)
  * debian/patches/git_focus_on_down_key.patch:
    - "Change focus to the view on down arrow"
  * debian/patches/git_desktop_dont_search_on_type.patch:
    - "Don't handle search for desktop windows" (lp: #1028028)
 -- Sebastien Bacher <email address hidden> Tue, 24 Jul 2012 13:00:13 +0200

Changed in nautilus (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.