nautilus segfaults in nautilus_window_menus_set_visibility_for_app_menu()

Bug #1003771 reported by Anders Kaseorg on 2012-05-24
84
This bug affects 12 people
Affects Status Importance Assigned to Milestone
Nautilus
Fix Released
Medium
nautilus (Ubuntu)
High
Unassigned

Bug Description

This happened while taking today’s updates.

ProblemType: Crash
DistroRelease: Ubuntu 12.10
Package: nautilus 1:3.5.1-0ubuntu2
ProcVersionSignature: Ubuntu 3.4.0-3.7-generic 3.4.0
Uname: Linux 3.4.0-3-generic x86_64
NonfreeKernelModules: openafs
ApportVersion: 2.1-0ubuntu1
Architecture: amd64
Date: Thu May 24 00:47:50 2012
EcryptfsInUse: Yes
ExecutablePath: /usr/bin/nautilus
GsettingsChanges: org.gnome.nautilus.window-state geometry '1365x869+388+184'
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha amd64 (20101202)
ProcCmdline: nautilus -n
SegvAnalysis:
 Segfault happened at: 0x48204f: mov 0x18(%rax),%rdi
 PC (0x0048204f) ok
 source "0x18(%rax)" (0xaaaaaaaaaaaaaac2) not located in a known VMA region (needed readable region)!
 destination "%rdi" ok
SegvReason: reading unknown VMA
Signal: 11
SourcePackage: nautilus
StacktraceTop:
 ?? ()
 g_closure_invoke (closure=0x159c820, return_value=0x0, n_param_values=2, param_values=0x7fff032babc0, invocation_hint=0x7fff032bab60) at /build/buildd/glib2.0-2.33.1/./gobject/gclosure.c:777
 signal_emit_unlocked_R (node=node@entry=0xc6c530, detail=detail@entry=674, instance=instance@entry=0xcc9ed0, emission_return=emission_return@entry=0x0, instance_and_params=instance_and_params@entry=0x7fff032babc0) at /build/buildd/glib2.0-2.33.1/./gobject/gsignal.c:3547
 g_signal_emit_valist (instance=0xcc9ed0, signal_id=<optimized out>, detail=674, var_args=var_args@entry=0x7fff032bae18) at /build/buildd/glib2.0-2.33.1/./gobject/gsignal.c:3296
 g_signal_emit (instance=<optimized out>, signal_id=<optimized out>, detail=<optimized out>) at /build/buildd/glib2.0-2.33.1/./gobject/gsignal.c:3352
Title: nautilus crashed with SIGSEGV in g_closure_invoke()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm admin cdrom dialout fuse libvirtd lpadmin plugdev sambashare

Related branches

Anders Kaseorg (andersk) wrote :

StacktraceTop:
 nautilus_window_menus_set_visibility_for_app_menu (window=0x159a020) at nautilus-window-menus.c:1118
 g_closure_invoke (closure=0x159c820, return_value=0x0, n_param_values=2, param_values=0x7fff032babc0, invocation_hint=0x7fff032bab60) at /build/buildd/glib2.0-2.33.1/./gobject/gclosure.c:777
 signal_emit_unlocked_R (node=node@entry=0xc6c530, detail=detail@entry=674, instance=instance@entry=0xcc9ed0, emission_return=emission_return@entry=0x0, instance_and_params=instance_and_params@entry=0x7fff032babc0) at /build/buildd/glib2.0-2.33.1/./gobject/gsignal.c:3547
 g_signal_emit_valist (instance=0xcc9ed0, signal_id=<optimized out>, detail=674, var_args=var_args@entry=0x7fff032bae18) at /build/buildd/glib2.0-2.33.1/./gobject/gsignal.c:3296
 g_signal_emit (instance=<optimized out>, signal_id=<optimized out>, detail=<optimized out>) at /build/buildd/glib2.0-2.33.1/./gobject/gsignal.c:3352

Changed in nautilus (Ubuntu):
importance: Undecided → Medium
summary: - nautilus crashed with SIGSEGV in g_closure_invoke()
+ nautilus crashed with SIGSEGV in
+ nautilus_window_menus_set_visibility_for_app_menu()
tags: removed: need-amd64-retrace
visibility: private → public
tags: added: running-unity

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nautilus (Ubuntu):
status: New → Confirmed

oddly this happened for me while trying to take a screenshot to report a different bug. screenshot crashed out and I ended up here... Doesn't seem relevant unless it's because I was in the process of selecting an area to grab and that intersected nautilus/appmenu.

summary: - nautilus crashed with SIGSEGV in
+ nautilus segfaults in
nautilus_window_menus_set_visibility_for_app_menu()
Changed in nautilus (Ubuntu):
importance: Medium → High
status: Confirmed → Triaged
Changed in nautilus:
importance: Unknown → Medium
status: Unknown → New
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nautilus - 1:3.5.1-0ubuntu6

---------------
nautilus (1:3.5.1-0ubuntu6) quantal; urgency=low

  * debian/patches/git_no_assert_on_double_mount.patch: lp: #1007593
    "sidebar: don't forget to NULL slot pointer after volume is mounted"
  * debian/patches/git_bookmark_place_dnd.patch: lp: #874386, #920691
    "places-sidebar: allow dropping of files to bookmarks"
  * debian/patches/git_no_menubars_segfault.patch: lp: #1003771
    "window-menus: disconnect from GtkSettings notifications on finalize"
 -- Sebastien Bacher <email address hidden> Tue, 12 Jun 2012 21:28:08 +0200

Changed in nautilus (Ubuntu):
status: Triaged → Fix Released
Changed in nautilus:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.