dbus unity launcherentry.updates aren't getting dismissed

Bug #1003286 reported by Rico Tzschichholz on 2012-05-23
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Files
Fix Released
Medium
Mario Guerriero
nautilus (Ubuntu)
Low
Didier Roche
Precise
Low
Unassigned

Bug Description

[Test Case]
1. install the version from -proposed
2. launch a copy of a big file
3. look at the dbus traffic and see that it's not sending the updates signal once the copy is finished

[Regression Potential]
No regression at stake, the signal can just be still sent if the return FALSE fails, which is unlikely.

After first triggering launcherentry.updates a added urgency timeout never gets dismissed and continuously firing updates from now on.

g_timeout_add_seconds (2, (GSourceFunc)
                progress_ui_handler_disable_unity_urgency,
         entry);

static void
progress_ui_handler_disable_unity_urgency (UnityLauncherEntry *entry)
{
 g_return_if_fail (entry);

 unity_launcher_entry_set_urgent (entry, FALSE);
}

Didier Roche (didrocks) on 2012-05-23
Changed in nautilus (Ubuntu):
assignee: nobody → Didier Roche (didrocks)
Changed in pantheon-files:
status: New → Confirmed
importance: Undecided → Medium
assignee: nobody → Mario Guerriero (mefrio-g)
Cody Garver (codygarver) on 2012-05-23
Changed in pantheon-files:
status: Confirmed → Fix Committed
Daniel Fore (danrabbit) on 2012-05-27
Changed in pantheon-files:
milestone: none → 0.1
Daniel Fore (danrabbit) on 2012-05-27
Changed in pantheon-files:
milestone: 0.1 → luna-beta1
Didier Roche (didrocks) on 2012-05-31
description: updated
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nautilus - 1:3.5.1-0ubuntu3

---------------
nautilus (1:3.5.1-0ubuntu3) quantal; urgency=low

  * debian/patches/12_unity_launcher_support.patch:
    - Fix dbus launcherentry.updates dbus signal sent regurlarly after
      a copy (LP: #1003286)
 -- Didier Roche <email address hidden> Thu, 31 May 2012 17:31:35 +0200

Changed in nautilus (Ubuntu):
status: New → Fix Released
Rico Tzschichholz (ricotz) wrote :

@Didier: This fix isn't working. The return type of the "progress_ui_handler_disable_unity_urgency" is still void and should be bool.

Sebastien Bacher (seb128) wrote :

nautilus (1:3.5.1-0ubuntu4) quantal; urgency=low

  * debian/patches/12_unity_launcher_support.patch:
    - return a gboolean

Changed in nautilus (Ubuntu):
importance: Undecided → Low
Changed in nautilus (Ubuntu Precise):
importance: Undecided → Low
status: New → Fix Committed
Brian Murray (brian-murray) wrote :

I don't feel like this test case is detailed enough for someone to really recreate this. How should one go about inspecting dbus traffic and what would one look for to ensure that the copy was finished?

I'll approve the upload anyway but would like to see that step detailed further.

Hello Rico, or anyone else affected,

Accepted nautilus into precise-proposed. The package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Sebastien Bacher (seb128) wrote :

@Rico: could you try the SRU and confirm if it works since you seem to know how to test that?

Sebastien Bacher (seb128) wrote :

Ok, Rico seems to have got missing but the update seems to run fine without regression so I'm marking it verification done

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nautilus - 1:3.4.2-0ubuntu2

---------------
nautilus (1:3.4.2-0ubuntu2) precise-proposed; urgency=low

  * debian/patches/12_unity_launcher_support.patch:
    - Fix folders with underscore in name shown incorrectly in Home Launcher
      quicklist (LP: #961170)
    - Fix dbus launcherentry.updates dbus signal sent regurlarly after
      a copy (LP: #1003286)
 -- Didier Roche <email address hidden> Tue, 22 May 2012 12:41:05 +0200

Changed in nautilus (Ubuntu Precise):
status: Fix Committed → Fix Released
Changed in pantheon-files:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers