Ubuntu

nautilus-wallpaper menu item doesn't show up

Reported by Daniel Centore on 2011-10-16
64
This bug affects 14 people
Affects Status Importance Assigned to Milestone
nautilus-wallpaper (Ubuntu)
Undecided
Unassigned

Bug Description

After installing nautilus-wallpaper in Ubuntu 11.10, it just doesn't show the "Set as wallpaper" item when right clicking on an image. Works fine in 11.04.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: nautilus-wallpaper 0.1-0ubuntu4
ProcVersionSignature: Ubuntu 3.0.0-12.20-generic 3.0.4
Uname: Linux 3.0.0-12-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 1.23-0ubuntu3
Architecture: amd64
Date: Sun Oct 16 13:07:12 2011
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111012)
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: nautilus-wallpaper
UpgradeStatus: No upgrade log present (probably fresh install)

Daniel Centore (dcentore) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nautilus-wallpaper (Ubuntu):
status: New → Confirmed
Eric Carvalho (eric-carvalho) wrote :

libnautilus-wallpaper.so is installed in /usr/lib/nautilus/extensions-2.0/. It should be installed in /usr/lib/nautilus/extensions-3.0/.

Eric Carvalho (eric-carvalho) wrote :

sudo ln -s /usr/lib/nautilus/extensions-2.0/libnautilus-wallpaper.so /usr/lib/nautilus/extensions-3.0/libnautilus-wallpaper.so. The menu item now appears, but it doesn't work.

HsH (hsh) wrote :

>The menu item now appears, but it doesn't work.

Because it changes the GConf settings, but not DConf...

cometdog (ericctharley) wrote :

Continues to be a problem in 12.04

cometdog (ericctharley) wrote :

workaround:
install nautilus actions, then add an action "Set as Wallpaper"

Path: gsettings
Parameters: set org.gnome.desktop.background picture-uri %u

Linux Lover (obake) wrote :

The context menu doesn't show-up in Ubuntu 12.04. And I tried installing the script using Ubuntu-Tweak, but that one didn't work either.

Ubuntu Tweak does install the context menu to set the wallpaper, but it does not wallpaper does not change.

Mykro (mykro76) wrote :

I can confirm this is still not working in 12.10 (Unity).

sudo apt-get install nautilus-wallpaper
nautilus -q

No entry in context menu.

Because other nautilus-* extensions work as expected, perhaps this one should be removed from the repositories or fixed.

Damir Butmir (d4m1r2) wrote :

2 years later and still unassigned?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers