Comma from "Lastname, Firstname" in Evolution addressbook leads to failure to send mail (address separation)

Bug #210917 reported by Bernhard Gehl on 2008-04-02
36
This bug affects 1 person
Affects Status Importance Assigned to Milestone
nautilus-sendto
Fix Released
Medium
evolution (Ubuntu)
Low
Unassigned
Hardy
Low
Unassigned
nautilus-sendto (Ubuntu)
Low
Unassigned
Hardy
Low
Ubuntu Desktop Bugs

Bug Description

Binary package hint: nautilus-sendto

My Evolution addressbook has its contents sorted in the "Lastname, Firstname"-scheme. When I select contacts from the addressbook as recipients for mail, Evolution simply writes a comma-separated list of "Firstname Lastname". So far everything is fine. However, when I try to send a file via nautilus-sendto, the intended recipient's name (of course even if it is just one person) appears as "Lastname, Firstname" in the "to" field. If not corrected manually, this leads to Evolution considering "Lastname" and "Firstname" separate addresses - which results in a failure to send the mail.

TESTCASE:
* right click on a file in nautilus
* select the sendto option
* select evolution in the nautilus-sendto combo
* start typing a name which is in your evolution addressbook and use the "One, Two <email>" format
* click on send

using the buggy version the "to:" contains "One, Two <email>", using the correct version that's "One Two <email>"

description: updated
Daniel James (daniel-netbreeze) wrote :

This is still an issue in hardy release. Perhaps the name should have quotes added around it. At the moment evolution treats the comma as a separator between email addresses and so will try to send two emails: one to 'Lastname' and one to 'Firstname <email@address>'.

Sebastien Bacher (seb128) wrote :

doesn't seem to be an evolution issue, could you describe easy steps to trigger the bug?

Changed in evolution:
importance: Undecided → Low
status: New → Invalid
Bernhard Gehl (bernhard-gehl) wrote :

To trigger this bug on my hardy system, I simply have to do the following:
- in nautilusselect a file I want to send by mail
- right-click and select "send-to"
- choose "evolution mail" in the dropdown menu
- enter a few letters in the address field and select an entry from the list like "Gehl, Bernhard <email address hidden>"
- hit the "send" button in the message dialogue

The message is put in "outgoing" in Evolution but will not be sent, since the recipients field contains "Gehl, Bernhard <email address hidden>" and Evo tries to send the message to "Gehl" which it obviously can't.

In my opinion, this is also not an evolution problem but a bug in nautilus-sendto.

Daniel James (daniel-netbreeze) wrote :

Agreed, this does seem to be a bug in nautilus-sendto - If I run:

evolution 'mailto:"Gehl, Bernhard" <email address hidden>'

evolution composer opens with the correct name in the 'to' field. If I select a file, hit send to, select evolution, start selecting an address from my address book, and then click send - it fills the field in wrong..

Pedro Villavicencio (pedro) wrote :

it should be send upstream by someone experiencing the issue, for forwarding instructions please have a look to https://wiki.ubuntu.com/Bugs/Upstream/GNOME ; leaving as incomplete until that, thanks.

Changed in nautilus-sendto:
importance: Undecided → Low
status: New → Incomplete
Daniel James (daniel-netbreeze) wrote :

According to upstream, this is fixed in svn... are we able to get a patched sendto?

Changed in nautilus-sendto:
status: Incomplete → Fix Committed
Changed in nautilus-sendto:
status: Unknown → Fix Released
Sebastien Bacher (seb128) wrote :

the new version has been uploaded to intrepid now

Changed in nautilus-sendto:
status: Fix Committed → Fix Released

Can we have this fix backported to Hardy?

Can we *please* get this backported? I've been checking bugs in ubuntu 8.04 against fedora 9 and this one (unfortunately this is typical) is fixed in fedora.

Sebastien Bacher (seb128) wrote :

what about trying to be constructive and work on the backport rather than adding useless comments about what is is typical or not? there is just a small team really overworked to work on those stable updates and such comments don't make me want to work for such users

Sebastien,

I don't mean to be discouraging. Can you outline the steps required to get the package source and create a patch?

Changed in nautilus-sendto:
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: New → Confirmed
Changed in evolution:
importance: Undecided → Low
status: New → Invalid
description: updated
Sebastien Bacher (seb128) wrote :

I've uploaded the change now

Martin Pitt (pitti) wrote :

Accepted into -proposed, please test and give feedback here. Please see https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in nautilus-sendto:
status: Confirmed → Fix Committed

I can verify the proposed package fixes the problem.

Åskar (olskar) wrote :

I can also verify

Martin Pitt (pitti) wrote :

Copied to hardy-updates.

Changed in nautilus-sendto:
status: Fix Committed → Fix Released
Martin Pitt (pitti) wrote :

Sorry, copying failed, hppa still didn't build it.

Changed in nautilus-sendto:
status: Fix Released → Fix Committed
Martin Pitt (pitti) wrote :

Copied to hardy-updates.

Changed in nautilus-sendto:
status: Fix Committed → Fix Released
Changed in nautilus-sendto:
importance: Unknown → Medium
Namasteji (namasteji) wrote :

I had the similar problem. I just went to Edit -> Preferences -> Contacts and then removed the tick mark from the 'Always Show the Address of autocompleted contact'. It seems that the problem has been solved for now.
Please see if it works.
Namasteji.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.