Nautilus-sendto always uses first entry in the combo-box

Bug #195580 reported by Dani Alonso on 2008-02-25
36
Affects Status Importance Assigned to Milestone
nautilus-sendto
Fix Released
Medium
nautilus-sendto (Ubuntu)
Low
Unassigned
Hardy
Low
Ubuntu Desktop Bugs

Bug Description

Binary package hint: nautilus-sendto

Detected in hardy with last available version (0.13.2-0ubuntu1)

Please follow this steps in order to reproduce:

1. Select a file from a windows
2. Choose "send to..." from context menu
3. Select "send as e-mail with evolution"
4. Type any text in order to search among evolution contacts. In order to reproduce the bug you need to type a text returning more than one entry in the selection combo box.
5. Select any entry but the first one, the "send to" text field is going to default to the first entry with independence of the entry selected by the user in teh combo.
6. Try to type the full email, different from the first entry: no way, the evolution window is going to default to the first entry in the combo.

I expect two things:

1. The "send to" text entry should track the selection in the combo box.
2. The evolution window should inherit the contact previousy selected.

Marek Vančo (marek.vanco) wrote :

I confirm this in Ubuntu Hardy heron. Only first email is used in combo.

sc00ter (gosdenj) wrote :

Workaround: Leave the field empty and enter recipients later when the composer has started.

Pedro Villavicencio (pedro) wrote :

Thanks for your bug report. This bug has been reported to the developers of the software. You can track it and make comments here: http://bugzilla.gnome.org/show_bug.cgi?id=538189

Changed in nautilus-sendto:
importance: Undecided → Low
status: New → Triaged
Changed in nautilus-sendto:
status: Unknown → Incomplete
Mark Garrow (scunizi) wrote :

The thread in Bugzilla mentioned above has the developer suggesting the user try version 1.0.0 to which the user wanted to know where to find an Ubuntu package.. The reply was to talk to Ubuntu. Ping to Bugzilla.Gnome... pong to ubuntu.. Now what?

My current version of Nautilus-SendTo in Hardy is
nautilus-sendto:
  Installed: 0.13.2-0ubuntu1
  Candidate: 0.13.2-0ubuntu1
  Version table:
 *** 0.13.2-0ubuntu1 0
        500 http://archive.ubuntu.com hardy/main Packages
        100 /var/lib/dpkg/status

I'm not overly familiar with the versoning numbers in ubuntu, but at first glance it appears the Nautilus-sendto in Hardy is WAY behind.

Although not a total show stopper, this bug is very irritating and slows workflow.

Sebastien Bacher (seb128) wrote :

not a constructive comment, no the ubuntu package is no way behind, the 1 version was not available before hardy and has been uploaded to intrepid weeks ago

Maybe someone with Intrepid alpha can test this then and report back.

Mark Garrow (scunizi) wrote :

Sorry Sebastien, didn't mean to be negative. It's just to someone outside the development loop entirely, version numbers don't always make sense. 0.13.2-0ubuntu1 appears to be a number much smaller than 1.0.0. With that in mind it brings visions of several other releases between 0.13.2 and 1.0.0....

Any chance there will be a backport fix for this one to Hardy LTS?

Sebastien Bacher (seb128) wrote :

the change can be backported yes, but it would make easier if somebody was looking at what change is required and testing the backport to hardy

This update was just now installed on my system.

$ apt-cache policy nautilus-sendto
nautilus-sendto:
  Installed: 0.13.2-0ubuntu2
  Candidate: 0.13.2-0ubuntu2
  Version table:
 *** 0.13.2-0ubuntu2 0
        500 http://se.archive.ubuntu.com hardy-updates/main Packages
        100 /var/lib/dpkg/status
     0.13.2-0ubuntu1 0
        500 http://se.archive.ubuntu.com hardy/main Packages
nautilus-sendto (0.13.2-0ubuntu2) hardy-proposed; urgency=low

$ aptitude changelog nautilus-sendto

  * debian/patches/90_from_svn_use_correct_email.patch:
    - change from svn to use the correct email addresses (lp: #210917)

 -- Sebastien Bacher <email address hidden> Thu, 31 Jul 2008 17:09:10 +0200

There is one problem still there though but I guess we need to create a new report for that, if you have a contact with two or more addresses and select any one but the first, the first will still be the one used.

sc00ter (gosdenj) wrote :

I can also confirm that this is not fixed since last update:

$ apt-cache policy nautilus-sendto

nautilus-sendto:
  Installed: 0.13.2-0ubuntu2
  Candidate: 0.13.2-0ubuntu2
  Version table:
 *** 0.13.2-0ubuntu2 0
        500 http://gb.archive.ubuntu.com hardy-updates/main Packages
        500 http://gb.archive.ubuntu.com hardy-proposed/main Packages
        100 /var/lib/dpkg/status
     0.13.2-0ubuntu1 0
        500 http://gb.archive.ubuntu.com hardy/main Packages

This changelog entry:

* debian/patches/90_from_svn_use_correct_email.patch:
    - change from svn to use the correct email addresses (lp: #210917)

Is still ineffective. The first email address for any person with multiple address is always selected regardless of the one you pick.

The patch has solved one problem and left another remaining.

Before it chose the wrong person if you had two persons matching the same criteria and you selected the latter of the two. It also garbled the email address so the to: address was mangled once in Evolution.

Sebastien Bacher (seb128) wrote :

the change was not supposed to fix this bug and that's why it has not been closed yet

Sebastien Bacher (seb128) wrote :

the bug has been fixed upstream now

Changed in nautilus-sendto:
status: Triaged → Fix Committed
Sebastien Bacher (seb128) wrote :

the fix will be uploaded to hardy too

Changed in nautilus-sendto:
importance: Undecided → Low
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nautilus-sendto - 1.0.1-0ubuntu1

---------------
nautilus-sendto (1.0.1-0ubuntu1) intrepid; urgency=low

  * New upstream version:
    - Fix e-mail selection in the Evolution plugin when a single contact
      has multiple addresses (lp: #195580)
    - Fix sending from nautilus when the path contains an ampersand

 -- Sebastien Bacher <email address hidden> Fri, 08 Aug 2008 13:51:57 +0200

Changed in nautilus-sendto:
status: Fix Committed → Fix Released
Changed in nautilus-sendto:
status: Incomplete → Invalid
Changed in nautilus-sendto:
status: Invalid → Unknown
Changed in nautilus-sendto:
status: Unknown → Fix Released
Changed in nautilus-sendto:
assignee: nobody → desktop-bugs
Martin Pitt (pitti) wrote :

Accepted into -proposed, please test and give feedback here. Please see https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in nautilus-sendto:
status: Confirmed → Fix Committed
Sebastien Bacher (seb128) wrote :

could anybody confirm that the update is working correctly so the bug fix can go to hardy-updates?

This is almost fixed in proposed.

1. If I use only the mouse (after the auto-complete list appears) everything works fine.

2. If I tab out of the email field after selecting an address and then press enter it works fine.

3. If I press enter after selecting an address while the address field is still focused, it still selects the first address instead of the one I selected.

Steps to reproduce:

1. Right click -> send to...
2. press TAB (to focus email field)
3. type 'mar' in the email field
4. use arrow keys to select second 'Maria' in the autocomplete list
5. press enter to select the address
6. press enter again to send the file
7. The first address is filled in in Evolution instead of the one I selected.

Sebastien Bacher (seb128) wrote :

the new comment seems a corner case and a new issue, it should not likely block the candidate update

Martin Pitt (pitti) wrote :

Thanks for testing. Can you please open a new bug report about the remaining case? Thanks!

Martin Pitt (pitti) wrote :

Copied to hardy-updates.

Changed in nautilus-sendto:
status: Fix Committed → Fix Released
Changed in nautilus-sendto:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.