Nautilus freezes (greys out) on with certain directories

Bug #590906 reported by Mike Goldberg on 2010-06-07
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
nautilus-python (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: nautilus

1. Description: Ubuntu 10.04 LTS
    Release: 10.04
    64-bit version

2. nautilus 1:2.30.1-0ubuntu1

3. When I change to a directory containing the Haiku OS source code, I expect the directory to be displayed.

4. Instead, nautilus freezes up and grays out. In addition, incoming network activity shoots up to ~300 KiB/s until the window is killed.

You can get the offending directory, the Haiku OS source code by running:

svn checkout http://svn.haiku-os.org/haiku/haiku/trunk haiku/haiku

Warning: this will download 993.1 MB of stuff to your computer.

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: nautilus 1:2.30.1-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.32-22.36-generic 2.6.32.11+drm33.2
Uname: Linux 2.6.32-22-generic x86_64
NonfreeKernelModules: nvidia
Architecture: amd64
Date: Mon Jun 7 12:22:36 2010
ExecutablePath: /usr/bin/nautilus
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release amd64 (20100429)
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.utf8
 SHELL=/bin/bash
SourcePackage: nautilus
XsessionErrors:
 (polkit-gnome-authentication-agent-1:1561): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed
 (gnome-terminal:1952): Gtk-CRITICAL **: gtk_accel_map_unlock_path: assertion `entry != NULL && entry->lock_count > 0' failed
 (Thunar:2307): Gdk-CRITICAL **: gdk_window_get_window_type: assertion `GDK_IS_WINDOW (window)' failed
 (Thunar:2307): Gdk-CRITICAL **: gdk_window_get_window_type: assertion `GDK_IS_WINDOW (window)' failed

Mike Goldberg (gdimike-gmail) wrote :
Pedro Villavicencio (pedro) wrote :

Thank you taking the time to report this bug and helping to make Ubuntu better. Please try to obtain a backtrace of the freeze following the instructions at http://wiki.ubuntu.com/DebuggingProgramCrash and upload the backtrace (as an attachment) to the bug report. This will greatly help us in tracking down your problem.

Changed in nautilus (Ubuntu):
importance: Undecided → Medium
status: New → Incomplete
Mike Goldberg (gdimike-gmail) wrote :

Attached is a backtrace, more or less generated by the instructions at http://wiki.ubuntu.com/DebuggingProgramCrash.

As gdb debugging nautilus ignored my control + c commands, I scraped the information out of ddd. (Fortunately, gdb running in ddd did respond to control + c.)

I asked Google for a better way, but I had no joy with anything I found, even from Stack Overflow. I know that there is a way to interrupt or control gdb while it is running besides control + c, but I am clueless as to how to do so. Can anyone tell me how, besides RTFM? It would be nice to add this information to the instructions at http://wiki.ubuntu.com/DebuggingProgramCrash. As a (very inactive) member of the Ubuntu BugSquad, I volunteer myself to do the editing.

Pedro Villavicencio (pedro) wrote :

Let's try this, when nautilus is in the freeze status check for its PID when you have the PID you can pass that to gdb with the following command: gdb nautilus PID . gdb is going to be attached to that freeze process and provide you of an stacktrace, try that and let me know how it works, thanks in advance!.

Mike Goldberg (gdimike-gmail) wrote :

OK, did as you requested. I ran gdb nautilus PID and generated a stacktrace, which I captured with script. It's bigger than the previous stacktrace that I tried to generate (331360 bytes vs 72881 bytes).

Pedro Villavicencio (pedro) wrote :

are you using the python-nautilus extensions? Could you please try to disable that and check if it's working fine? looks like that's the one causing the freeze. Thanks for the quick reply Mike!.

Mike Goldberg (gdimike-gmail) wrote :

I removed python-nautilus and rebooted. Nautilus not longer freezes on the 'haiku' directory. Cool.

Thanks for working with me on this.

Pedro Villavicencio (pedro) wrote :

let's reassign it to nautilus-python so they can have a look into this, thanks for the quick reply Mike.

affects: nautilus (Ubuntu) → nautilus-python (Ubuntu)
Changed in nautilus-python (Ubuntu):
status: Incomplete → New
Frode Woldsund (frodus86) wrote :

I have the same problem. And disable python-nautilus extensions fixed it ;)

Frode Woldsund (frodus86) wrote :

For your information:
.. after I then reinstalled it, it seems to work perfectly again. I have had no issues. and yes, I have rebooted 4-5 times, and it still works

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers