Update nautilus-python to latest upstream version - 1.2.x

Bug #1529460 reported by dino99 on 2015-12-27
28
This bug affects 4 people
Affects Status Importance Assigned to Milestone
nautilus-python (Debian)
Fix Released
Unknown
nautilus-python (Ubuntu)
Medium
Unassigned

Bug Description

nautilus-python package in Ubuntu is very old - v 1.1 released 7 years ago (2011), still depending on python2.7

Please update packages to latest upstream version - 1.2.x, this supports building with Python 3 and has other improvements:

1.2.2: - Fixed bug #792427, Fix folder string comparison to prevent duplicate extension loading

1.2.1: - Fixed bug #792348, Fix syntax error when building docs using python3

1.2:
    - Added capability to compile with python 3 support using PYTHON environment variable
    - Fix #781232, Improve extension path loading semantics to follow XDG recommendations
    - Fix #791208, require Nautilus 3.0 before importing extensions to prevent warnings
    - Switch to using gtkdoc mkhtml for generating devhelp2 documentation

See https://gitlab.gnome.org/GNOME/nautilus-python/blob/master/NEWS

syslog is logging that error which seems related to:
org.gnome.Nautilus[1695]: ** (nautilus:8309): CRITICAL **: nautilus_menu_provider_get_background_items: assertion 'NAUTILUS_IS_MENU_PROVIDER (provider)' failed

related reopened report: bug #1429535

Details
-------
https://gitlab.gnome.org/GNOME/nautilus-python/blob/master/NEWS

https://gitlab.gnome.org/GNOME/nautilus-python/compare/NAUTILUS_PYTHON_1_1_0...NAUTILUS_PYTHON_1_2_2

nautilus-python 1.2.2-1 doesn't use python3 and neither 1.1-6 or 1.2.2-1 build the docs.

ProblemType: Bug
DistroRelease: Ubuntu 18.04
Package: python-nautilus 1.1-6
CurrentDesktop: GNOME
SourcePackage: nautilus-python

dino99 (9d9) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nautilus-python (Ubuntu):
status: New → Confirmed
Changed in nautilus-python (Ubuntu):
importance: Undecided → Medium
Jeremy Bicha (jbicha) on 2017-12-17
tags: added: py2-removal
removed: third-party-packages
Sam Bull (dreamsorcerer) wrote :

Is this likely to be done for 18.04? It looks like the upstream project supports building with Python 3 with version 1.2.

tags: added: bionic cosmic
removed: apport-bug
description: updated
summary: - Please port to python 3
+ Update nautilus-python to latest upstream version - 1.2.x - migrate to
+ Python 3
Changed in nautilus-python (Debian):
status: Unknown → New
Jeremy Bicha (jbicha) on 2018-09-10
tags: added: upgrade-software-version

Please file a separate bug for the python3 switch.

summary: - Update nautilus-python to latest upstream version - 1.2.x - migrate to
- Python 3
+ Update nautilus-python to latest upstream version - 1.2.x
Jeremy Bicha (jbicha) on 2018-10-08
description: updated
Changed in nautilus-python (Ubuntu):
status: Confirmed → In Progress
Jeremy Bicha (jbicha) wrote :

nautilus-python 1.2.2 will be available in Ubuntu 18.10.

https://launchpad.net/ubuntu/+source/nautilus-python/1.2.2-1

Changed in nautilus-python (Ubuntu):
status: In Progress → Fix Released
Changed in nautilus-python (Debian):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.