Rebuild for libgnome-desktop-2-7 -> libgnome-desktop-2-11 transition (reversenbs)

Bug #309529 reported by Andrew Starr-Bochicchio on 2008-12-18
10
Affects Status Importance Assigned to Milestone
avant-window-navigator (Ubuntu)
Undecided
Unassigned
awn-extras-applets (Ubuntu)
Undecided
Unassigned
desktop-data-model (Ubuntu)
Undecided
Unassigned
epiphany-browser (Ubuntu)
Undecided
Unassigned
galeon (Ubuntu)
Undecided
Unassigned
gnome-desktop-sharp2 (Ubuntu)
Undecided
Unassigned
gnome-launch-box (Ubuntu)
Undecided
Unassigned
gnome-main-menu (Ubuntu)
Undecided
Unassigned
go-home-applet (Ubuntu)
Undecided
Unassigned
icewm (Ubuntu)
Undecided
Unassigned
nautilus-open-terminal (Ubuntu)
Undecided
Unassigned
netbook-launcher (Ubuntu)
Undecided
Unassigned
quick-lounge-applet (Ubuntu)
High
Unassigned

Bug Description

Binary package hint: nautilus-open-terminal

Packages Build Depending on libgnome-desktop-dev must be rebuilt for libgnome-desktop-2-7 -> libgnome-desktop-2-11 transition.

Fix for icewm

Changed in icewm:
status: New → In Progress
Changed in nautilus-open-terminal:
status: New → In Progress

Fix for quick-lounge-applet

fix for nautilus-open-terminal

avant-window-navigator

awn-extras-applets

Changed in quick-lounge-applet:
status: New → Confirmed
Changed in icewm:
status: In Progress → Confirmed
Changed in nautilus-open-terminal:
status: In Progress → Confirmed
Changed in awn-extras-applets:
status: New → Confirmed
Changed in avant-window-navigator:
status: New → Confirmed

netbook-launcher (1.2-0ubuntu2) jaunty; urgency=low

  * rebuild for libgnome-desktop soname change

 -- Michael Vogt < <email address hidden> > Wed, 17 Dec 2008 21:43:06 +0100

Changed in netbook-launcher:
status: New → Fix Released

gnome-launch-box (0.4-0ubuntu3) jaunty; urgency=low

  * rebuild for libgnome-desktop soname change

 -- Michael Vogt < <email address hidden> > Wed, 17 Dec 2008 21:42:08 +0100

Changed in gnome-launch-box:
status: New → Fix Released

gnome-main-menu (0.9.11+dfsg-0ubuntu2) jaunty; urgency=low

  * rebuild for libgnome-desktop soname change

 -- Michael Vogt < <email address hidden> > Wed, 17 Dec 2008 21:39:53 +0100

Changed in gnome-main-menu:
status: New → Fix Released

go-home-applet

Changed in go-home-applet:
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package galeon - 2.0.6-2build1

---------------
galeon (2.0.6-2build1) jaunty; urgency=low

  * Rebuild for libgnome-desktop-2-7 -> libgnome-desktop-2-11
    transition. (LP: #309529)

 -- Stefan Ebner <email address hidden> Fri, 19 Dec 2008 11:32:19 +0100

Changed in galeon:
status: New → Fix Released
Stefan Ebner (sebner) wrote :
Stefan Ebner (sebner) wrote :

quick-lounge-applet FTBFS for me.

cc -DHAVE_CONFIG_H -I. -I.. -I.. -I.. -DPREFIX=\"/usr\" -DSYSCONFDIR=\"/etc\" -DDATADIR=\"/usr/share\" -DLIBDIR=\"/usr/lib\" -DGNOMELOCALEDIR=\""/usr/share/locale"\" -DGLADEDIR=\""/usr/share/quick-lounge-applet/glade"\" -DGMENU_I_KNOW_THIS_IS_UNSTABLE -pthread -D_REENTRANT -DORBIT2=1 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/gtk-2.0 -I/usr/lib/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/pango-1.0 -I/usr/include/pixman-1 -I/usr/include/freetype2 -I/usr/include/directfb -I/usr/include/libpng12 -I/usr/include/libgnome-2.0 -I/usr/include/orbit-2.0 -I/usr/include/gconf/2 -I/usr/include/gnome-vfs-2.0 -I/usr/lib/gnome-vfs-2.0/include -I/usr/include/libbonobo-2.0 -I/usr/include/dbus-1.0 -I/usr/lib/dbus-1.0/include -I/usr/include/bonobo-activation-2.0 -I/usr/include/libgnomeui-2.0 -I/usr/include/libart-2.0 -I/usr/include/gnome-keyring-1 -I/usr/include/libbonoboui-2.0 -I/usr/include/libgnomecanvas-2.0 -I/usr/include/libxml2 -I/usr/include/gail-1.0 -I/usr/include/gnome-vfs-module-2.0 -I/usr/include/gnome-desktop-2.0 -I/usr/include/startup-notification-1.0 -I/usr/include/libglade-2.0 -I/usr/include/panel-2.0 -I/usr/include/gnome-menus -g -O2 -g -Wall -O2 -c dlg-properties.c
dlg-properties.c:31:41: error: libgnomeui/gnome-ditem-edit.h: No such file or directory
dlg-properties.c: In function 'update_list':
dlg-properties.c:422: warning: unused variable 'box'
dlg-properties.c: In function 'get_button_from_uri':
dlg-properties.c:712: warning: unused variable 'box'
make[3]: *** [dlg-properties.o] Error 1
make[3]: Leaving directory `/tmp/buildd/quick-lounge-applet-2.12.5/src'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/tmp/buildd/quick-lounge-applet-2.12.5'
make[1]: *** [all] Error 2
make[1]: Leaving directory `/tmp/buildd/quick-lounge-applet-2.12.5'
make: *** [debian/stamp-makefile-build] Error 2

Andrew, mind taking a look at it?

Changed in quick-lounge-applet:
assignee: nobody → andrewsomething
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package go-home-applet - 0.2-0ubuntu2

---------------
go-home-applet (0.2-0ubuntu2) jaunty; urgency=low

  * Rebuild for libgnome-desktop-2-7 -> libgnome-desktop-2-11
    transition. (LP: #309529)

 -- Andrew Starr-Bochicchio <email address hidden> Thu, 18 Dec 2008 19:22:04 -0500

Changed in go-home-applet:
status: Confirmed → Fix Released

libgnomeui/gnome-ditem-edit.h has been removed from libgnome-desktop-2, this causes the FTBFS with quick-lounge-applet. Upstream bug: http://bugzilla.gnome.org/show_bug.cgi?id=559584

I attempted to resolve this by shipping gnome-ditem-edit.h as a patch with quick-lounge-applet. I placed it in /src and changed the includes in the files that call it from:

#include <libgnomeui/gnome-ditem-edit.h >

to:

#include "gnome-ditem-edit.h"

This allowed me get past the previous build error, but then I hit this:

/tmp/buildd/quick-lounge-applet-2.12.5/src/quick-lounge.c:795: undefined reference to `gnome_ditem_edit_new'
/tmp/buildd/quick-lounge-applet-2.12.5/src/quick-lounge.c:811: undefined reference to `gnome_ditem_edit_get_type'
/tmp/buildd/quick-lounge-applet-2.12.5/src/quick-lounge.c:811: undefined reference to `gnome_ditem_edit_grab_focus'
quick-lounge.o: In function `new_launcher_dialog_response_cb':
/tmp/buildd/quick-lounge-applet-2.12.5/src/quick-lounge.c:746: undefined reference to `gnome_ditem_edit_get_ditem'
quick-lounge.o: In function `quick_lounge_util__item_properties':
/tmp/buildd/quick-lounge-applet-2.12.5/src/quick-lounge.c:577: undefined reference to `gnome_ditem_edit_new'
/tmp/buildd/quick-lounge-applet-2.12.5/src/quick-lounge.c:578: undefined reference to `gnome_ditem_edit_get_type'
/tmp/buildd/quick-lounge-applet-2.12.5/src/quick-lounge.c:578: undefined reference to `gnome_ditem_edit_set_ditem'
/tmp/buildd/quick-lounge-applet-2.12.5/src/quick-lounge.c:604: undefined reference to `gnome_ditem_edit_grab_focus'
quick-lounge.o: In function `ditem_properties_apply_timeout':
/tmp/buildd/quick-lounge-applet-2.12.5/src/quick-lounge.c:391: undefined reference to `gnome_ditem_edit_get_ditem'
quick-lounge.o: In function `ditem_properties_close':
/tmp/buildd/quick-lounge-applet-2.12.5/src/quick-lounge.c:542: undefined reference to `gnome_ditem_edit_clear'
quick-lounge.o: In function `ditem_properties_clicked':
/tmp/buildd/quick-lounge-applet-2.12.5/src/quick-lounge.c:462: undefined reference to `gnome_ditem_edit_get_type'
/tmp/buildd/quick-lounge-applet-2.12.5/src/quick-lounge.c:462: undefined reference to `gnome_ditem_edit_set_ditem'

Any suggestions of what to try next would be appreciated....

Changed in icewm:
status: Confirmed → Incomplete
Changed in nautilus-open-terminal:
status: Confirmed → Incomplete

icewm and nautilus-open-terminal are now FTBFS with gnome-vfs issues....

Please hold off.

Changed in awn-extras-applets:
status: Confirmed → Incomplete
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package avant-window-navigator - 0.3~bzr489-1build1

---------------
avant-window-navigator (0.3~bzr489-1build1) jaunty; urgency=low

  * Rebuild for libgnome-desktop-2-7 -> libgnome-desktop-2-11
    transition. (LP: #309529)

 -- Andrew Starr-Bochicchio <email address hidden> Thu, 18 Dec 2008 19:01:40 -0500

Changed in avant-window-navigator:
status: Confirmed → Fix Released

Merging from Debian experimental and adding a build-dep on libgconf2-dev fixes the nautilus-open-terminal issue. It now builds in a Jaunty pbuilder correctly.

nautilus-open-terminal (0.9-3ubuntu1) jaunty; urgency=low

  * Merge from Debian experimental.
  * Rebuild for libgnome-desktop-2-7 -> libgnome-desktop-2-11
    transition. (LP: #309529)
  * debian/control: Add missing Build-dep on libgconf2-dev

Changed in nautilus-open-terminal:
status: Incomplete → Confirmed

Even after adding a Build-dep on libgnomevfs2-dev, icewm will not build. Here's the error:

gnome2.cc:25:19: error: gnome.h: No such file or directory
gnome2.cc:27:40: error: libgnomevfs/gnome-vfs-init.h: No such file or directory
gnome2.cc: In member function 'void GnomeMenu::addEntry(const char*, const char*, int, bool)':
gnome2.cc:122: error: 'gnome_pixmap_file' was not declared in this scope
gnome2.cc: In function 'int main(int, char**)':
gnome2.cc:351: error: 'gnome_vfs_init' was not declared in this scope
make[3]: *** [gnome2.o] Error 1
make[3]: Leaving directory `/tmp/buildd/icewm-1.2.36/src'
make[2]: *** [base] Error 2
make[2]: Leaving directory `/tmp/buildd/icewm-1.2.36'
make[1]: *** [stamp-conf] Error 2
make[1]: Leaving directory `/tmp/buildd/icewm-1.2.36'
make: *** [build-stamp] Error 2
dpkg-buildpackage: failure: debian/rules build gave error exit status 2
pbuilder: Failed autobuilding of package

Any ideas?

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nautilus-open-terminal - 0.9-3ubuntu1

---------------
nautilus-open-terminal (0.9-3ubuntu1) jaunty; urgency=low

  * Merge from Debian experimental. (LP: #309529)
  * debian/control: Add missing Build-dep on libgconf2-dev

 -- Andrew Starr-Bochicchio <email address hidden> Sat, 20 Dec 2008 10:55:58 +0100

Changed in nautilus-open-terminal:
status: Confirmed → Fix Released
Stefan Ebner (sebner) wrote :

Andrew,
merges from Experimental are OK so you don't have to add also the debian changes to the debdiff.
Besides, you made some changes without mentioning them.
I've done a proper merge which means I took the Debian sources files and only added the b-p, changed maintainer and added the changelog entries for you.

Would you mind reporting our changes back to Debian so we can sync next time?

Changed in epiphany-browser:
status: New → Confirmed
Changed in gnome-desktop-sharp2:
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-desktop-sharp2 - 2.20.1-2ubuntu6

---------------
gnome-desktop-sharp2 (2.20.1-2ubuntu6) jaunty; urgency=low

  * Rebuild for libgnome-desktop-2-7 -> libgnome-desktop-2-11
    transition. (LP: #309529)
  - debian/patches/02_gnomedesktop_dllmap
    + Actually map the new libgnome-desktop-2-11 lib. Fixes
      the dependency generation and library use.

 -- Stefan Ebner <email address hidden> Fri, 19 Dec 2008 12:02:37 +0100

Changed in gnome-desktop-sharp2:
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package epiphany-browser - 2.24.1-1ubuntu3

---------------
epiphany-browser (2.24.1-1ubuntu3) jaunty; urgency=low

  * Rebuild for libgnome-desktop-2-7 -> libgnome-desktop-2-11
    transition. (LP: #309529)

 -- Stefan Ebner <email address hidden> Fri, 19 Dec 2008 11:49:54 +0100

Changed in epiphany-browser:
status: Confirmed → Fix Released

I'm unsubscribing the Sponsors' Team for now. Please re-subscribe when ready.

Changed in awn-extras-applets:
status: Incomplete → New
Changed in icewm:
status: Incomplete → New
Changed in quick-lounge-applet:
assignee: andrewsomething → nobody
status: In Progress → New

icewm (1.2.36-1ubuntu2) jaunty; urgency=low

  * Rebuild for libgnome-desktop-2-7 -> libgnome-desktop-2-11
    transition. (LP: #309529)
  * Fix FTBFS due to libgnome-desktop transition.
   - Add build depend on libgnomeui-dev
   - Add fedora-icewm-configure.dpatch derived from Fedora
    + pkg-config --cflags gnome-desktop-2.0 doesn't implicitly include
      libgnomeui-2.0 anymore, so add it in explicitly

Changed in icewm:
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package awn-extras-applets - 0.3~bzr912-1ubuntu1

---------------
awn-extras-applets (0.3~bzr912-1ubuntu1) jaunty; urgency=low

  * Rebuild against libgnome-desktop-2-11. LP: #309529.
  * Add missing build-dependency on libglade2-dev.
  * debian/patches/99-gnomeui-CFLAGS.patch: Add libgnomeui-2.0 CFLAGS,
    since aff-utils.c needs gnome-icon-lookup.h.

 -- Steve Langasek <email address hidden> Wed, 14 Jan 2009 02:31:11 +0000

Changed in awn-extras-applets:
status: New → Fix Released
Steve Langasek (vorlon) wrote :

Hi Andrew,

Thanks for the icewm patch. Looks correct to me, I should be uploading it as soon as I verify here that it fixes the build failure.

Do you plan to submit this patch upstream to the Debian maintainers as well?

Changed in icewm:
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package icewm - 1.2.36-1ubuntu3

---------------
icewm (1.2.36-1ubuntu3) jaunty; urgency=low

  * Rebuild for libgnome-desktop-2-7 -> libgnome-desktop-2-11
    transition. (LP: #309529)
  * Fix FTBFS due to libgnome-desktop transition.
   - Add build depend on libgnomeui-dev
   - Add fedora-icewm-configure.dpatch derived from Fedora
    + pkg-config --cflags gnome-desktop-2.0 doesn't implicitly include
      libgnomeui-2.0 anymore, so add it in explicitly

 -- Andrew Starr-Bochicchio <email address hidden> Tue, 13 Jan 2009 14:38:16 -0500

Changed in icewm:
status: In Progress → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package desktop-data-model - 1.2.5-1ubuntu1

---------------
desktop-data-model (1.2.5-1ubuntu1) jaunty; urgency=low

  * Rebuild against libgnome-desktop-2-11. LP: #309529.
  * Add a build-dependency on libgnomevfs2-dev, which is no longer
    implicitly included by gnome-desktop.

 -- Steve Langasek <email address hidden> Wed, 14 Jan 2009 07:31:30 +0000

Changed in desktop-data-model:
status: New → Fix Released

Changes forwarded to Debian:

nautilus-open-terminal:
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=511845

icewm-gnome-support:
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=511847

Universe-Sponsors can be unsubscribed until a fix for quick-lounge-applet is found.

Daniel Holbach (dholbach) wrote :

I'm unsubscribing the Sponsors' Team for now. Please re-subscribe when ready.

Changed in quick-lounge-applet:
assignee: nobody → andrewsomething
status: New → In Progress

New upstream allows quick-lounge-applet to build correctly with GNOME 2.25.*

quick-lounge-applet (2.13.1-0ubuntu1) jaunty; urgency=low

  * New upstream release.
   - Removed the animation when launching the application.
   - Support launching apps by dropping files on them (#171739).
   - Use the default panel launcher icon, if the icon is missing.
   - Allow to specify the number of rows (columns) explicitly. Patch by
     Jared Warren (#161444).
   - Re-designed the "choose application from menu" dialog.
   - Replaced the old launcher dialog with a dialog similar to the one
     used by gnome-panel.
   - Migrated the documentation to gnome-doc-utils.
   - Ported to gio.
   - Removed the libglade dependency.
   - Bugs fixed:
    + #532174: Odd behaviour when changing the order of the icons.
    + #559584: does not build on GNOME 2.25 Patch by Migi.
    + #551786: applet still uses deprecated gnome-stock-about icon
      instead of gtk-about. Patch by Pacho Ramos.
  * Fixes FTBFS due to libgnome-desktop-2-7 -> libgnome-desktop-2-11
    transition. (LP: #309529)
  * debian/control:
   - Drop depricated libgnome-desktop-dev Build Dependency.
   - Add versionized Build Dependency on libgtk2.0-dev (>= 2.14.0)
   - Add Build Dependency on gnome-doc-utils (>= 0.4.2)
  * Drop debian/patches/20_dbus_session_bus_address.diff
   - Included upstream.
  * debian/quick-lounge-applet.install: update for new release

Changed in quick-lounge-applet:
assignee: andrewsomething → nobody
status: In Progress → Confirmed
Iain Lane (laney) wrote :

Lintian error for quick-lounge-applet:

  quick-lounge-applet source: build-depends-on-x-metapackage build-depends: xorg-dev

Changed in quick-lounge-applet:
importance: Undecided → High
status: Confirmed → Incomplete

Drop un-needed xorg-dev Build-Dep. Fixes Litian warning.

Alessio Treglia (quadrispro) wrote :

Uploaded, thanks!

I have fixed a small issue in debian/copyright to get clean from all lintian warnings.

Changed in quick-lounge-applet:
status: Incomplete → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package quick-lounge-applet - 2.13.1-0ubuntu1

---------------
quick-lounge-applet (2.13.1-0ubuntu1) jaunty; urgency=low

  [ Andrew Starr-Bochicchio ]
  * New upstream release.
   - Removed the animation when launching the application.
   - Support launching apps by dropping files on them (#171739).
   - Use the default panel launcher icon, if the icon is missing.
   - Allow to specify the number of rows (columns) explicitly. Patch by
     Jared Warren (#161444).
   - Re-designed the "choose application from menu" dialog.
   - Replaced the old launcher dialog with a dialog similar to the one
     used by gnome-panel.
   - Migrated the documentation to gnome-doc-utils.
   - Ported to gio.
   - Removed the libglade dependency.
   - Bugs fixed:
    + #532174: Odd behaviour when changing the order of the icons.
    + #559584: does not build on GNOME 2.25 Patch by Migi.
    + #551786: applet still uses deprecated gnome-stock-about icon
      instead of gtk-about. Patch by Pacho Ramos.
  * Fixes FTBFS due to libgnome-desktop-2-7 -> libgnome-desktop-2-11
    transition. (LP: #309529)
  * debian/control:
   - Drop depricated libgnome-desktop-dev Build Dependency.
   - Drop un-needed xorg-dev Build-Dep. Fixes Litian warning.
   - Add versionized Build Dependency on libgtk2.0-dev (>= 2.14.0)
   - Add Build Dependency on gnome-doc-utils (>= 0.4.2)
  * Drop debian/patches/20_dbus_session_bus_address.diff
   - Included upstream.
  * debian/quick-lounge-applet.install: update for new release

  [ Alessio Treglia ]
  * debian/copyright: refers to /usr/share/common-licenses/GPL-2 in order
    to clean lintian warnings.

 -- Andrew Starr-Bochicchio <email address hidden> Mon, 02 Feb 2009 23:48:06 -0500

Changed in quick-lounge-applet:
status: Fix Committed → Fix Released
Changed in nautilus-open-terminal (Ubuntu):
status: Fix Released → Fix Committed
Changed in nautilus-open-terminal (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.