Extension not working in Oneiric

Bug #849361 reported by Emilien Klein on 2011-09-13
20
This bug affects 2 people
Affects Status Importance Assigned to Milestone
nautilus-image-manipulator (Ubuntu)
Undecided
Unassigned
Oneiric
Undecided
Unassigned

Bug Description

== SRU ==

[Impact]
Nautilus Image Manipulator does not work in Oneiric since the Nautilus extension and the program had to be upgraded to work with Nautilus 3 and PyGI/GTK+ 3. See related bug reports [0] and [1].

[Development Fix]
I have released a new microrelease that solely addresses this issue. N I M 0.4 is now available and I've uploaded it to Debian Unstable. The package in Precise should work out of the box when it is refreshed from Sid (along with python-nautilus). I haven't actually tested the package in Precise, but have in Debian Sid and Ubuntu Oneiric (see below).

[Stable Fix]
Version 0.4 is a microrelease made to address only this problem, no new functionality has been added. The changes can be reviewed in lp:nautilus-image-manipulator, r92 to r100. The code in version 0.4 is the same as the current head, i.e. r100.

I've installed the package straight from Debian [3] and it works in Oneiric. There is a warning when installing the package with `dpkg` since there is a dependency on python-nautilus (>= 1.1) but Oneiric has 1.0-0ubuntu2. But the needed patch to python-nautilus [4] is present in the current version in Oneiric. I would need somebody to explain to me if the Depends line in `debian/control` needs to be modified to `python-nautilus (>= 1.0-0ubuntu2)` manually, or if this can be done automagically.

[Test Case]
bzr branch lp:nautilus-image-manipulator
cd nautilus-image-manipulator
mkdir -p ~/.local/share/nautilus-python/extensions
cp ./nautilus_image_manipulator/nautilus-image-manipulator-extension.py ~/.local/share/nautilus-python/extensions
sudo ln -s [FULL_PATH_TO_PWD]/bin/nautilus-image-manipulator /usr/bin
nautilus -q && nautilus --no-desktop

When right-clicking on an image file (or a group of files), a new contextual menu will appear, called "Resize images...". It launches Nautilus Image Manipulator.

[Regression Potential]
The package is currently broken in Oneiric, i.e. it can be installed from the repository but nothing will appear. No other package depend on this package, so I see very little regression potential. Consider also that Oneiric is the first release where Nautilus Image Manipulator would be available, so there is no problem like upgrading users being affected.

[0] https://bugs.launchpad.net/ubuntu/+source/nautilus-image-manipulator/+bug/849361
[1] https://bugs.launchpad.net/ubuntu/+source/nautilus-image-manipulator/+bug/859104
[3] http://packages.debian.org/sid/all/nautilus-image-manipulator/download
[4] https://bugs.launchpad.net/ubuntu/+source/nautilus-python/+bug/858925

== ORIGINAL DESCRIPTION ==

In order to fix bug #836601, the package got rebuilt so as to put the extension in the "correct" Gnome3 nautilus extension folder:
/usr/lib/nautilus/extensions-3.0/
Now the package is placing the extension in that folder, however the right-click menu is not displayed after restarting the session.

According to python-nautilus' /usr/share/doc/python-nautilus/README in Oneiric:

As of nautilus-python 0.7.0, scripts are also loaded from $XDG_DATA_DIR/nautilus-python/extensions, which includes ~/.local/share and /usr/share (or whatever your $XDG_DATA_DIR is set to).

I also saw an example here [0] that changed the path where the extension is set to /usr/share/nautilus-python/extensions
The last comment here [1] also mentions the use of this new folder.

I need to investigate how the Python Nautilus extensions are supposed to work with Gnome3/nautilus-python 1.0...
In order to test, I also installed nautilus-pastebin, and that program's extension also failed to show. There seems to be a generalized problem with Python Nautilus extensions starting with Ubuntu 11.10...

[0] https://github.com/danielgtaylor/arista/pull/54/files
[1] https://bugzilla.redhat.com/show_bug.cgi?id=708891

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nautilus-image-manipulator (Ubuntu):
status: New → Confirmed
Changed in nautilus-image-manipulator (Ubuntu):
assignee: nobody → Emilien Klein (emilien-klein)
status: Confirmed → Fix Released
Emilien Klein (emilien-klein) wrote :

Updated the description for the SRU. I need to find a sponsor for the `Nominate for series`, and to upload the package...

description: updated
summary: - Menu not displayed after installation
+ Extension not working in Oneiric
Changed in nautilus-image-manipulator (Ubuntu):
assignee: Emilien Klein (emilien-klein) → nobody
Chow Loong Jin (hyperair) wrote :

I'll review and upload this later if nobody else has already done so.

Emilien Klein (emilien-klein) wrote :

Thanks Chow Loong Jin for sponsoring the upload.

Just out of curiosity, how will you handle the difference in version numbers for the dependency on python-nautilus?

The Debian package depends on python-nautilus (>= 1.1) but Oneiric has 1.0-0ubuntu2. The Oneiric version has the same patches that are needed from the 1.1 version, so the extension works fine with 1.0-0ubuntu2 (tested on Oneiric). Will you update the debian/control file, or what is the procedure in this case?

Chow Loong Jin (hyperair) wrote :

Hmm, it looks like nautilus-image-manipulator hasn't actually hit Ubuntu yet, so setting this as fixed released in Ubuntu isn't quite right.

As for the python-nautlus (>= 1.1) dependency in Debian, it looks like you were the one who made the change. Do you need python-nautilus >= 1.1 for some specific purpose?

Emilien Klein (emilien-klein) wrote :

Indeed, the fix is released upstream and in Debian Sid, but you're right, in Ubuntu it isn't yet released (that's what we're currently working on...)

To have the Nautilus extensions work with Nautilus 3, release 1.1 of python-nautilus is needed. However, in Oneiric we integrated the needed patches before upstream released 1.1 [0], which resulted in the 1.0-0ubuntu2. As far as Ubuntu is concerned, the dependency can be made on >= 1.0-0ubuntu2 (but NOT 1.0-0ubuntu1 since the patches are not present in there).

The reason why the Debian package lists >= 1.1 is that Debian upgraded it's python-nautilus directly from version from 0.6.1 to 1.1 [1].

Do you need more information from my side for the upload?

[0] https://bugs.launchpad.net/ubuntu/+source/nautilus-python/+bug/858925
[1] http://packages.qa.debian.org/n/nautilus-python.html

On 02/11/2011 20:08, Emilien Klein wrote:
> Indeed, the fix is released upstream and in Debian Sid, but you're
> right, in Ubuntu it isn't yet released (that's what we're currently
> working on...)

Okay, let's set the status accordingly -- it'll get set to fix released when the
sync happens.

  affects ubuntu/nautilus-image-manipulator
  status fixcommitted

  affects ubuntu/nautilus-image-manipulator

> To have the Nautilus extensions work with Nautilus 3, release 1.1 of
> python-nautilus is needed. However, in Oneiric we integrated the needed
> patches before upstream released 1.1 [0], which resulted in the
> 1.0-0ubuntu2. As far as Ubuntu is concerned, the dependency can be made
> on >= 1.0-0ubuntu2 (but NOT 1.0-0ubuntu1 since the patches are not
> present in there).
>
> The reason why the Debian package lists >= 1.1 is that Debian upgraded
> it's python-nautilus directly from version from 0.6.1 to 1.1 [1].

Ah, I see. That makes sense. Sorry, I didn't read the description properly. In
this case, I think we should sync python-nautilus 1.1 and
nautilus-image-manipulator 0.4-1 from Debian into Precise, and then make a
separate upload of nautilus-image-manipulator into oneiric-proposed.

--
Kind regards,
Loong Jin

Changed in nautilus-image-manipulator (Ubuntu):
status: Fix Released → Fix Committed
Emilien Klein (emilien-klein) wrote :

2011/11/2 Chow Loong Jin <email address hidden>:
> Ah, I see. That makes sense. Sorry, I didn't read the description properly. In
> this case, I think we should sync python-nautilus 1.1 and
> nautilus-image-manipulator 0.4-1 from Debian into Precise, and then make a
> separate upload of nautilus-image-manipulator into oneiric-proposed.

Seems like a good plan.
How do we go about the sync, is it going to happen automatically (if
so, from which, stable or unstable, and when?) or do we need to do
something?

Chow Loong Jin (hyperair) wrote :

On 02/11/2011 23:05, Emilien Klein wrote:
> Seems like a good plan.
> How do we go about the sync, is it going to happen automatically (if
> so, from which, stable or unstable, and when?) or do we need to do
> something?

I just synced nautilus-python last night (that wasn't going to happen manually),
and will do the nautilus-image-manipulator sync now. No real point in waiting,
in my opinion. No point in leaving bugs hanging.

--
Kind regards,
Loong Jin

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nautilus-image-manipulator - 0.4-1

---------------
nautilus-image-manipulator (0.4-1) unstable; urgency=low

  * New upstream release
    - Transition to Nautilus 3 and GObject introspection
      (Closes: #644694) (LP: #859104 and LP: #849361).
  * debian/control:
    - Require python-nautilus 1.1 or higher
    - Depend on gir1.2-gtk-3.0, gir1.2-glib-2.0, gir1.2-nautilus-3.0
    - Remove build dependency on pkg-config and python-nautilus
  * debian/watch:
    - Add `debian uupdate` after the URL
  * debian/copyright:
    - Conform to DEP-5: Machine-readable debian/copyright

 -- Emilien Klein <email address hidden> Wed, 26 Oct 2011 22:00:22 +0200

Changed in nautilus-image-manipulator (Ubuntu):
status: Fix Committed → Fix Released
Chow Loong Jin (hyperair) wrote :

Alright, I've uploaded to oneiric-proposed.

  subscribe ubuntu-sru

--
Kind regards,
Loong Jin

Changed in nautilus-image-manipulator (Ubuntu Oneiric):
status: New → Triaged
Emilien Klein (emilien-klein) wrote :

Thanks for the sync of both packages. and the upload of N I M.
However, in the queue [0] I only see N I M, not nautilus-python. I believe the latter has to be uploaded too, otherwise the N I M package will not be installable. Could you upload nautilus-python too?

[0] https://launchpad.net/ubuntu/oneiric/+queue?queue_state=1

Chow Loong Jin (hyperair) wrote :

On 03/11/2011 17:53, Emilien Klein wrote:
> Thanks for the sync of both packages. and the upload of N I M.
> However, in the queue [0] I only see N I M, not nautilus-python. I believe the latter has to be uploaded too, otherwise the N I M package will not be installable. Could you upload nautilus-python too?
>
> [0] https://launchpad.net/ubuntu/oneiric/+queue?queue_state=1
>

You mentioned that nautilus-python 1.0-0ubuntu2 was usable, so I changed the
binary dep of n-i-m. Was that wrong?

--
Kind regards,
Loong Jin

Emilien Klein (emilien-klein) wrote :

Oh, great, I hadn't seen that. Indeed, debian/control now lists "python-nautilus (>= 1.0-0ubuntu2~)", so this should be fine. Sorry for the misunderstanding ;)

Laudeci Oliveira (laudeci) wrote :

The version 0.3-1build1 on Oneiric works ok here, just the progress dialog after the resize/rotate property dialog is not showed.

Emilien Klein (emilien-klein) wrote :

Laudeci, this is most probably due to the needed upgrade to GTK+3 and GI. The 0.4 release should have all this fixed. Please test when it is uploaded to oneiric-proposed.

Chow Loong Jin (hyperair) wrote :

On 03/11/2011 23:28, Laudeci Oliveira wrote:
> The version 0.3-1build1 on Oneiric works ok here, just the progress
> dialog after the resize/rotate property dialog is not showed.
>

Weird, I don't even get the right click option using the 0.3-1build1 version.
0.4 works though.

--
Kind regards,
Loong Jin

Hello Emilien, or anyone else affected,

Accepted nautilus-image-manipulator into oneiric-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in nautilus-image-manipulator (Ubuntu Oneiric):
status: Triaged → Fix Committed
tags: added: verification-needed
Chow Loong Jin (hyperair) wrote :

Works for me.

Martin Pitt (pitti) on 2011-11-05
tags: added: verification-done
removed: verification-needed
Emilien Klein (emilien-klein) wrote :

Confirming that the package from -proposed works. Thanks!

Laudeci Oliveira (laudeci) wrote :

I am using 0.4-1~ubuntu0.1 from proposed, the resize works, but I am not able to see the progress dialog, the only way to see if it finnishes is looking to file size changes. Can you see the progress dialog?

Hmmmm, I do see the progress bar. Have you been resizing more than one
image at a time? If so, please open a new bug with some screenshots.
thx!

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nautilus-image-manipulator - 0.4-1~ubuntu0.1

---------------
nautilus-image-manipulator (0.4-1~ubuntu0.1) oneiric-proposed; urgency=low

  * Backport to oneiric-proposed (LP: #849361)
  * Lower python-nautilus dependency (patches backported to ubuntu version)
    Thanks to Emilien Klein <email address hidden>
 -- Chow Loong Jin <email address hidden> Thu, 03 Nov 2011 08:11:20 +0800

Changed in nautilus-image-manipulator (Ubuntu Oneiric):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers