nautilus crashes when opening any folder or file (nautilus-dropbox and new glib)

Bug #932627 reported by brian baker on 2012-02-15
288
This bug affects 53 people
Affects Status Importance Assigned to Milestone
glib2.0 (Ubuntu)
High
Robson de Arruda
nautilus-dropbox (Ubuntu)
Undecided
Robson de Arruda

Bug Description

bb@Dream-Test:~$ nautilus
Initializing nautilus-dropbox 0.7.1

** CRITICAL **: nautilus_menu_provider_get_background_items: assertion `NAUTILUS_IS_MENU_PROVIDER (provider)' failed

** CRITICAL **: nautilus_menu_provider_get_background_items: assertion `NAUTILUS_IS_MENU_PROVIDER (provider)' failed

** CRITICAL **: nautilus_menu_provider_get_background_items: assertion `NAUTILUS_IS_MENU_PROVIDER (provider)' failed

** CRITICAL **: nautilus_menu_provider_get_background_items: assertion `NAUTILUS_IS_MENU_PROVIDER (provider)' failed

** CRITICAL **: nautilus_menu_provider_get_background_items: assertion `NAUTILUS_IS_MENU_PROVIDER (provider)' failed

** CRITICAL **: nautilus_menu_provider_get_background_items: assertion `NAUTILUS_IS_MENU_PROVIDER (provider)' failed

** CRITICAL **: nautilus_menu_provider_get_background_items: assertion `NAUTILUS_IS_MENU_PROVIDER (provider)' failed

** CRITICAL **: nautilus_menu_provider_get_background_items: assertion `NAUTILUS_IS_MENU_PROVIDER (provider)' failed

** CRITICAL **: nautilus_menu_provider_get_background_items: assertion `NAUTILUS_IS_MENU_PROVIDER (provider)' failed

** CRITICAL **: nautilus_menu_provider_get_background_items: assertion `NAUTILUS_IS_MENU_PROVIDER (provider)' failed

** CRITICAL **: nautilus_menu_provider_get_background_items: assertion `NAUTILUS_IS_MENU_PROVIDER (provider)' failed

** CRITICAL **: nautilus_menu_provider_get_file_items: assertion `NAUTILUS_IS_MENU_PROVIDER (provider)' failed

** CRITICAL **: nautilus_menu_item_list_free: assertion `item_list != NULL' failed

** CRITICAL **: nautilus_menu_item_list_free: assertion `item_list != NULL' failed

** CRITICAL **: nautilus_menu_item_list_free: assertion `item_list != NULL' failed

** CRITICAL **: nautilus_menu_provider_get_file_items: assertion `NAUTILUS_IS_MENU_PROVIDER (provider)' failed

** CRITICAL **: nautilus_menu_item_list_free: assertion `item_list != NULL' failed

** CRITICAL **: nautilus_menu_item_list_free: assertion `item_list != NULL' failed

** CRITICAL **: nautilus_menu_item_list_free: assertion `item_list != NULL' failed

** CRITICAL **: nautilus_menu_provider_get_file_items: assertion `NAUTILUS_IS_MENU_PROVIDER (provider)' failed

** CRITICAL **: nautilus_menu_item_list_free: assertion `item_list != NULL' failed

** CRITICAL **: nautilus_menu_item_list_free: assertion `item_list != NULL' failed

** CRITICAL **: nautilus_menu_item_list_free: assertion `item_list != NULL' failed

** CRITICAL **: nautilus_menu_provider_get_file_items: assertion `NAUTILUS_IS_MENU_PROVIDER (provider)' failed

** CRITICAL **: nautilus_menu_item_list_free: assertion `item_list != NULL' failed

** CRITICAL **: nautilus_menu_item_list_free: assertion `item_list != NULL' failed

** CRITICAL **: nautilus_menu_item_list_free: assertion `item_list != NULL' failed
Nautilus-Share-Message: Called "net usershare info" but it failed: 'net usershare' returned error 255: net usershare: cannot open usershare directory /var/lib/samba/usershares. Error No such file or directory
Please ask your system administrator to enable user sharing.

** CRITICAL **: nautilus_menu_provider_get_file_items: assertion `NAUTILUS_IS_MENU_PROVIDER (provider)' failed

** CRITICAL **: nautilus_menu_item_list_free: assertion `item_list != NULL' failed

** CRITICAL **: nautilus_menu_item_list_free: assertion `item_list != NULL' failed

** CRITICAL **: nautilus_menu_item_list_free: assertion `item_list != NULL' failed

** CRITICAL **: nautilus_menu_provider_get_file_items: assertion `NAUTILUS_IS_MENU_PROVIDER (provider)' failed
GLib (gthread-posix.c): Unexpected error from C library during 'Invalid argument': pthread_cond_timedwait. Aborting.
Aborted (core dumped)

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: nautilus 1:3.3.5-0ubuntu2
ProcVersionSignature: Ubuntu 3.2.0-16.25-generic-pae 3.2.6
Uname: Linux 3.2.0-16-generic-pae i686
NonfreeKernelModules: nvidia
ApportVersion: 1.91-0ubuntu1
Architecture: i386
Date: Wed Feb 15 11:03:56 2012
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release i386 (20111012)
ProcEnviron:
 LANGUAGE=en_US:en
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: nautilus
UpgradeStatus: No upgrade log present (probably fresh install)
mtime.conffile..etc.xdg.autostart.nautilus.autostart.desktop: 2012-02-09T19:37:45.212164

Related branches

brian baker (brian-m-baker) wrote :
Jason Stapels (jstapels) wrote :

I had the same problem in 11.10. Uninstalling the dropbox package resolved the issue for me, so it's possible the issue is on their end.

affects: nautilus (Ubuntu) → nautilus-dropbox (Ubuntu)
Raphaël Hertzog (hertzog) wrote :

Brian, can you verify if uninstalling nautilus-dropbox fixes the problem? And if reinstalling it triggers it again?

If removing nautilus-dropbox doesn't fix the problem, try the same with nautilus-share.

It would be great if you could provide a gdb backtrace, see https://wiki.ubuntu.com/Backtrace to learn how to create a backtrace.

brian baker (brian-m-baker) wrote :

I can confirm removing nautilus-dropbox fixes the problem and reinstalling it triggers it again! i will do a back trace in the next hour or so when i am back at my computer :-)

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nautilus-dropbox (Ubuntu):
status: New → Confirmed
Jason Stapels (jstapels) wrote :

I installed the older nautilus-dropbox 0.6.8-1, same issue. I'll attach a backtrace shortly.

affects: nautilus-dropbox (Ubuntu) → nautilus (Ubuntu)
Jason Stapels (jstapels) wrote :

Here's a backtrace of the problem I'm getting.

-----

ii nautilus 1:3.2.1-0ubuntu3.2 file manager and graphical shell for GNOME
ii nautilus-dropbox 0.6.8-1 Dropbox integration for Nautilus

Jason Stapels (jstapels) wrote :

Sorry for the comment spam. I have the same issue with nautilus 1:3.2.0-0ubuntu5 as well.

brian baker (brian-m-baker) wrote :

can't do more of a backtrace when nautilus crashes it freezes my terminal and it won't except copy/paste or typed in commands!!

Sebastien Bacher (seb128) wrote :

Why did that get reassigned to nautilus? The comments and stacktraces confirm it's a nautilus-dropbox issue

affects: nautilus (Ubuntu) → nautilus-dropbox (Ubuntu)
Raphaël Hertzog (hertzog) wrote :

Apparently this bug affects people who have enabled PPA with developement versions of glib. Anyone that is affected, please post the output of this command: dpkg-query -W libglib2.0-0

It's not yet clear whether the bug is in glib or in nautilus-dropbox.

Jason Stapels (jstapels) wrote :

~$ dpkg-query -W libglib2.0-0
libglib2.0-0 2.31.17+git20120215.eafb108c-0ubuntu1~11.10~ricotz0

Chris Goller (goller) wrote :

goller@tdw:~$ dpkg-query -W libglib2.0-0
libglib2.0-0 2.31.18-0ubuntu1

Chris Goller (goller) wrote :

Here is my backtrace for this nautilus/dropbox issue. This is with the debug glib.

Chris Goller (goller) wrote :

Adding more backtrace information from nautilus-dropbox.

Jim (jimvernon) wrote :

libglib2.0-0 2.31.18-0ubuntu1

Jim (jimvernon) wrote :

FYI, this happened today after installing updates. There was no update for Dropbox, but libglib2.0 went from 2.31.16 to 2.31.18.

Chris Goller (goller) wrote :

I think I've tracked it down...

http://ftp.gnome.org/pub/gnome/sources/glib/2.31/glib-2.31.18.news

glib did this change
 * g_async_queue_timed_pop has been deprecated in favor of
  the new g_async_queue_timeout_pop, which uses relative
  delays in microseconds instead of a GTimeVal.

and the exact change in g_async_queue_timed_pop

+ if (end_time != NULL)
+ {
+ m_end_time = g_get_monotonic_time () +
+ (end_time->tv_sec * G_USEC_PER_SEC + end_time->tv_usec -
+ g_get_real_time ());
+ }
+ else
+ m_end_time = -1;
+

end_time->tv_sec * G_USEC_PER_SEC + end_time->tv_usec - g_get_real_time () returns a value far less than 0 and it causes
the m_end_time to be less than 0.

Therefore, this sets m_end_time to negative creating an invalid argument to be passed to pthread_cond_wait.

I think just casting end_time->tv_sec to gint64 is all that is needed.

Willem Pieterson (wpieterson) wrote :

Problem surfaced for me after installing todays 12.04 updates

Raphaël Hertzog (hertzog) wrote :

Chris, thanks for tracking it down. Do you feel like reporting it upstream? I don't see the bug yet on https://bugzilla.gnome.org/buglist.cgi?product=glib&bug_status=UNCONFIRMED&bug_status=NEW&bug_status=ASSIGNED&bug_status=REOPENED&version=2.31.x

I have added glib to the list of affected packages since the underlying bug is there.

Changed in glib2.0 (Ubuntu):
status: New → Confirmed
Changed in glib2.0 (Ubuntu):
importance: Undecided → High

darkrain@rain:~$ nautilus
Initializing nautilus-dropbox 0.7.1
Initializing nautilus-image-converter extension
Initializing nautilus-open-terminal extension
Initializing nautilus-gdu extension
Nautilus-Share-Message: Called "net usershare info" but it failed: 'net usershare' returned error 255: net usershare: cannot open usershare directory /var/lib/samba/usershares. Error No such file or directory
Please ask your system administrator to enable user sharing.

GLib (gthread-posix.c): Unexpected error from C library during 'Invalid argument': pthread_cond_timedwait. Aborting.
Aborted (core dumped)

darkrain@rain:~$ dpkg-query -W libglib2.0-0
libglib2.0-0 2.31.18-0ubuntu1

steps to recreate problem is: as simple as open nautilus and click on any folder.

Sebastien Bacher (seb128) wrote :

Thanks Chris for the investigation, I raised the issue on https://bugzilla.gnome.org/show_bug.cgi?id=669670 and will ping upstream on IRC later as well

summary: - nautilus crashes when opening any folder or file
+ nautilus crashes when opening any folder or file (nautilus-dropbox and
+ new glib)
riddle (riddlepl) wrote :

I have also : libglib2.0-0 2.31.18-0ubuntu1

Nekhelesh Ramananthan (nik90) wrote :

I have the problem after installed some Precise updates. It is caused due to 2.31.18-0ubuntu1.

Changed in nautilus-dropbox (Ubuntu):
status: Confirmed → Invalid
Changed in glib2.0 (Ubuntu):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package glib2.0 - 2.31.18-0ubuntu2

---------------
glib2.0 (2.31.18-0ubuntu2) precise; urgency=low

  * debian/patches/git_queue_overflow.patch: git patch, fix an overview issue
    leading to nautilus-dropbox segfaults (lp: #932627)
 -- Sebastien Bacher <email address hidden> Wed, 22 Feb 2012 19:47:04 +0100

Changed in glib2.0 (Ubuntu):
status: Fix Committed → Fix Released
Changed in glib2.0 (Ubuntu):
assignee: nobody → Robson de Arruda (robinho-ac10)
Changed in nautilus-dropbox (Ubuntu):
assignee: nobody → Robson de Arruda (robinho-ac10)
no longer affects: dropbox-share

I just got affected by the problem after rebooting after today's update, removing nautilus dropbox fixed it. It looks like I am using glib2.0.

ZOkI ZuAn (zoki) wrote :

Man help me i have also same problem
my glib version is ----
libglib2.0-0 2.32.1-0ubuntu2

i have also tried to remove dropbox but the broblem continues.

see what to do i have latest version of glib ,do i have to downgrade my glib

aloctavodia (aloctavodia) wrote :

same problem Zoki reports

aloctavodia (aloctavodia) wrote :

nautilus --no-desktop "fix" the problem.

Asher Wood (zeklandia) wrote :

It affects me, but I have the package dropbox installed (the package from Dropbox's website) as opposed to nautilus-dropbox. This is the error I get upon entering ONLY the Dropbox folder (every other folder works fine, but it used to not work at all):

Initializing nautilus-open-terminal extension
Initializing nautilus-dropbox 1.6.0

(nautilus:10191): GLib-GObject-CRITICAL **: g_object_set: assertion 'G_IS_OBJECT (object)' failed

(nautilus:10191): GLib-GObject-CRITICAL **: g_object_set: assertion 'G_IS_OBJECT (object)' failed

(nautilus:10191): Gtk-WARNING **: Refusing to add non-unique action 'NautilusDropbox::browse' to action group 'DirExtensionsMenuGroup'
Segmentation fault

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.