Ubuntu Budgie: Bad integration with Dropbox

Bug #1683051 reported by Nicolas Michel on 2017-04-15
34
This bug affects 4 people
Affects Status Importance Assigned to Milestone
nautilus-dropbox (Ubuntu)
Medium
fossfreedom

Bug Description

Hi,

I'm using Dropbox and it doesn't integrate well with Ubuntu Budgie:
- fail to install through GUI:
  - download deb from browser
  - click on the deb file from chromium
  - it start "software" application
  - click on "install"
  - nothing is happening
Workaround:
- install with gdebi. I see that the Dropbox installer ask a question ([...] are you sure? [Y|N]) so maybe the software application cannot handle interactive deb?

After installing with gdebi, the icon is not the right one in the icon applet at the top right and clicking on it shows me an empty popover.

fossfreedom (fossfreedom) wrote :

This is a problem with the proprietary Dropbox Daemon not budgie. The Daemon only works with unity.

The workaround is to disable the startup Dropbox and create your own with the command

dbus-launch dropbox start -i

Changed in budgie-remix:
status: New → Triaged
fossfreedom (fossfreedom) wrote :

ok - have a patch ready for this. Just waiting for the repositories to open up again for further development.

Changed in nautilus-dropbox (Ubuntu):
status: New → Confirmed
assignee: nobody → fossfreedom (fossfreedom)
fossfreedom (fossfreedom) wrote :

Please find enclosed a patch for Artful that reuses the work Martin did for zesty and extends this for Ubuntu Budgie.

Changed in budgie-remix:
status: Triaged → Invalid
no longer affects: budgie-remix
tags: added: artful
Changed in nautilus-dropbox (Ubuntu):
status: Confirmed → In Progress
summary: - Bad integration with Dropbox
+ Ubuntu Budgie: Bad integration with Dropbox
Changed in nautilus-dropbox (Ubuntu):
importance: Undecided → Medium
fossfreedom (fossfreedom) wrote :

revised patch - better python syntax

Bhavani Shankar (bhavi) wrote :

Looking into this

Bhavani Shankar (bhavi) wrote :

Looks fine. Uploaded.

Thanks!

Changed in nautilus-dropbox (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nautilus-dropbox - 2015.10.28-1ubuntu2

---------------
nautilus-dropbox (2015.10.28-1ubuntu2) artful; urgency=medium

  * debian/patches:
    + Add fix-budgie-indicator-menu.patch. Coerce XDG_CURRENT_DESKTOP to report
      "Unity" ensuring the indicator icon and menu work correctly for
      the budgie-desktop environment. (LP: #1683051)

 -- David Mohammed <email address hidden> Sun, 16 Apr 2017 10:03:58 +0100

Changed in nautilus-dropbox (Ubuntu):
status: Fix Committed → Fix Released
Muffat (jeanbernard-muffat-z) wrote :

Hello
since ubuntu 17.10 (gnome 3), dropbox starts, its icon is on the top panel, and after a moment it crashes. Ihad not this problem in the past.

fossfreedom (fossfreedom) wrote :

Muffat, please create a new bug report. This bug report is for Ubuntu budgie and it's icon display. Crashes on the gnome 3 desktop is another issue.
Thanks

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers