Dropbox icon not working on Xubuntu 14.04

Bug #1546176 reported by Alex on 2016-02-16
168
This bug affects 34 people
Affects Status Importance Assigned to Milestone
caja-dropbox (Ubuntu)
Undecided
Martin Wimpress
dropbox (Ubuntu)
Undecided
Unassigned
nautilus-dropbox (Ubuntu)
Undecided
Unassigned

Bug Description

The dropbox icon is not working under Xubuntu 14.04. The issue started few days ago, I suppose this problem is caused by some recent update.

Jack (jackhmoss) wrote :

When you say the dropbox icon "is not working" what do you mean by this?

Jack (jackhmoss) on 2016-02-18
Changed in nautilus-dropbox (Ubuntu):
status: New → Confirmed

By this I mean that instead of the usual dropbox icon in the notification
area I see a red circle, and it is also not possible to click on the icon
and change any settings. The issue started few days ago after an update,
and it probably only affects xubuntu (i tested in lubuntu, and the icon was
working). Moreover, the problem affects both nautilus-drobox and ppa
dropbox packages. I tried to reinstall both of them independently, and the
icon was never working. So it seems to be rather a problem of the
notification panel in xubuntu, but I am not able to figure it out.

2016-02-18 1:42 GMT+01:00 Jack <email address hidden>:

> When you say the dropbox icon "is not working" what do you mean by this?
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1546176
>
> Title:
> Dropbox icon not working on Xubuntu 14.04
>
> Status in nautilus-dropbox package in Ubuntu:
> New
>
> Bug description:
> The dropbox icon is not working under Xubuntu 14.04. The issue started
> few days ago, I suppose this problem is caused by some recent update.
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/nautilus-dropbox/+bug/1546176/+subscriptions
>

Jack (jackhmoss) wrote :

I believe that this maybe either a bug to do with the dependencies or an error on the dropbox dev's end as other icons in the tray seem to work fine.
Also, with your testing on lubuntu was this a clean install without any updates, as if it was testing with Xubuntu then maybe you would be able to find what update it was that caused the bug

liutianren (liutianren) wrote :

Confirm the same problem in Ubuntu 15.10, Xfce desktop.

I believe it's a bug introduced in recent dropbox update. Because I have dropbox 3.12.5 and dropbox 3.14.7 running on my computer simultaneously, the earlier version is not affected by this problem.

Alex (strelal83) wrote :

My test with lubuntu was on the same machine on which xubuntu is running,
not on a clean install. The icon is working properly there.
Am 18.02.2016 8:50 nachm. schrieb "Jack" <email address hidden>:

> I believe that this maybe either a bug to do with the dependencies or an
> error on the dropbox dev's end as other icons in the tray seem to work fine.
> Also, with your testing on lubuntu was this a clean install without any
> updates, as if it was testing with Xubuntu then maybe you would be able to
> find what update it was that caused the bug
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1546176
>
> Title:
> Dropbox icon not working on Xubuntu 14.04
>
> Status in nautilus-dropbox package in Ubuntu:
> Confirmed
>
> Bug description:
> The dropbox icon is not working under Xubuntu 14.04. The issue started
> few days ago, I suppose this problem is caused by some recent update.
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/nautilus-dropbox/+bug/1546176/+subscriptions
>

Jack (jackhmoss) wrote :

I can confirm what liutianren stated about Xubuntu 15.10 with the Dropbox bug.
I am not sure whether this bug could be reported to Dropbox or not?

Alex (strelal83) wrote :

Of course it should be reported, it is quite an issue for people who use
dropbox with xfce.
Am 18.02.2016 11:11 nachm. schrieb "Jack" <email address hidden>:

> I can confirm what liutianren stated about Xubuntu 15.10 with the Dropbox
> bug.
> I am not sure whether this bug could be reported to Dropbox or not?
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1546176
>
> Title:
> Dropbox icon not working on Xubuntu 14.04
>
> Status in nautilus-dropbox package in Ubuntu:
> Confirmed
>
> Bug description:
> The dropbox icon is not working under Xubuntu 14.04. The issue started
> few days ago, I suppose this problem is caused by some recent update.
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/nautilus-dropbox/+bug/1546176/+subscriptions
>

Alex (strelal83) wrote :

PS: is it possible to downgrade to an earlier dropbox version? Are old
packages available somewhere?
Am 18.02.2016 11:11 nachm. schrieb "Jack" <email address hidden>:

> I can confirm what liutianren stated about Xubuntu 15.10 with the Dropbox
> bug.
> I am not sure whether this bug could be reported to Dropbox or not?
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1546176
>
> Title:
> Dropbox icon not working on Xubuntu 14.04
>
> Status in nautilus-dropbox package in Ubuntu:
> Confirmed
>
> Bug description:
> The dropbox icon is not working under Xubuntu 14.04. The issue started
> few days ago, I suppose this problem is caused by some recent update.
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/nautilus-dropbox/+bug/1546176/+subscriptions
>

robbielink (robbielink) wrote :

I only got this problem when I updated my system to Lubuntu 15.10 from 15.04 today. Dropbox indicator worked fine until then.

Jeff (boardman-malibu) wrote :

Same here using xubuntu 14.04.3

I found this entry in ~/.cache/xfce4-indicator-plugin.log repeated every time I restarted Dropbox

DEBUG Indicator-Application Building new application entry: org.kde.StatusNotifierItem-2553-1 with icon: at position 1
DEBUG libindicator-plugin Entry added for io=libapplication.so
WARNING LIBDBUSMENU-GLIB Getting layout failed: GDBus.Error:org.freedesktop.DBus.Error.UnknownObject: No such object path '/MenuBar'
CRITICAL LIBDBUSMENU-GLIB dbusmenu_menuitem_send_about_to_show: assertion 'DBUSMENU_IS_MENUITEM(mi)' failed

The last line was repeated every time I clicked on the panel icon.

I only just now confirmed that my installation was updated on 2/16/16 without me knowing about it!

Maciej (pan-efem) wrote :

Linux Mint 17.3 Cinnamon. Indicator works as is, but it's not active, there is no menu after right/left click.

Bhaveek Desai (bhaveekdesai) wrote :

Linux Mint 17.3 XFCE. dropbox indicator not working after running a routine upgrade 3 days ago.
Current dropbox package installed: "dropbox_1.6.2_amd64.deb"

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in dropbox (Ubuntu):
status: New → Confirmed
marcelo spitteler (mspittel) wrote :

Same issue in Linux Mint 17.2 XFCE. When Dropbox daemon is started with 'sudo dropbox start' the icon shows properly and works OK in "Notification Area". When the daemon is started as normal user with 'dropbox start' then icon shows up in "Indicator Plugin" but as a red slashed circle on black background, when clicked shows an empty menu that does nothing. It is a bug in a recent update of Dropbox. Extensive discussion in http://askubuntu.com/questions/732967/dropbox-icon-is-not-working-xubuntu-14-04-lts-64/734886 and the simplest workaround is

Just insert:

os.environ['DBUS_SESSION_BUS_ADDRESS'] = ""

into /usr/bin/dropbox

at the beginning, after

import os

Peter (nitep) wrote :

Thanks marcelo
That worked for me on Xubuntu 15.10 64 bit

groby (groby) wrote :

Same issue on my LXDE Lubuntu 15.10 system.

robbielink (robbielink) wrote :

the fix in #14 worked for me

Another workaround from http://askubuntu.com/a/739018/506976 for the current Dropbox tray icon bugs that is reported to work at least on the Linux distributions Fedora, Kubuntu, Linux Mint, openSUSE, Slackware, Ubuntu... and the desktop environments Cinnamon, KDE 4, KDE 5, Mate, Unity... is the command line:

dropbox stop && dbus-launch dropbox start

Maciej (pan-efem) wrote :

#18 worked for me. Thanks Juan!

Norbert (asterix52) wrote :

The workarounds doesn't work for Xubuntu 16.04.

dropbox stop && dropbox start

brings the indicator back.

But how to fix the autostart for Xubuntu 16.04?

Norbert (asterix52) wrote :

This fixes it.

On the Dropbox menu go to Preferences. Deselect "Start Dropbox on system startup"

Go to Session and Startup > Application Autostart and add the following startup item:

bash -c 'export DBUS_SESSION_BUS_ADDRESS="" && dropbox start -i'

summary: - Dropbox icon not working on Xubuntu 14.04
+ Dropbox icon not working on Xubuntu 14.04 or Ubuntu MATE 16.04
Changed in caja-dropbox (Ubuntu):
status: New → Confirmed

My fix from #21 work only for a logout and not for a reboot.

For Xubuntu 16.04 this workaround works:

On the Dropbox menu go to Preferences. Deselect "Start Dropbox on system startup"

Go to Session and Startup > Application Autostart and add the following startup item:

bash -c 'sleep 30 && dropbox stop && export XDG_CURRENT_DESKTOP="Unity" && dropbox start -i'

After 30sec the dropbox icon is correct.

See also this bugreport: https://bugs.launchpad.net/ubuntu/+source/nautilus-dropbox/+bug/1559249

Alfred (alfred-egger) wrote :

This problem also exists on Kubuntu 14.0.4.5 running Dropbox 3.18.1.

dropbox stop && DBUS_SESSION_BUS_ADDRESS="" dropbox start

makes it work again.

Changed in caja-dropbox (Ubuntu):
assignee: nobody → Martin Wimpress (flexiondotorg)
status: Confirmed → In Progress
Changed in caja-dropbox (Ubuntu):
status: In Progress → Fix Committed
Changed in caja-dropbox (Ubuntu):
status: Fix Committed → Fix Released
summary: - Dropbox icon not working on Xubuntu 14.04 or Ubuntu MATE 16.04
+ Dropbox icon not working on Xubuntu 14.04

the fix in #14 worked for me
thanks marcelo

Xubuntu 16.04 fresh install from release date here.

#14 and #22 solutions work only manually for me. They don't work in the Autostart Apps because Dropbox keeps re-creating the Autostart entry every time I login, and executes first. Yes, I've tried "dropbox autostart n".

Simple solution for me was to remove nautilus-dropbox and install caja-dropbox. The caja version respects the autostart yes / no, as it should.
All good in Xubuntu.

Ads20000 (ads20000) wrote :

Wait, so does caja-dropbox work perfectly with Xubuntu 16.04 and Thunar (1.6.10)? I'm impressed that Martin managed to get that released given all the freezes on 16.04 at the time!
Martin, would it be possible for you to apply your caja-dropbox fix to nautilus-dropbox or is that not possible?

Ads20000 (ads20000) wrote :

Oh well. I installed Dropbox from the Deb on their website and installed thunar-dropbox-plugin and the workaround which works for me (Xubuntu 16.04 LTS) is:
1. Use `dropbox stop && dbus-launch dropbox start` (without backticks (``)) in Terminal
2. Dropbox indicator > Preferences... > uncheck Start Dropbox on system startup
3. Add `dbus-launch dropbox start` (without backticks (``)) to Session and Startup > Application Autostart

The workaround that worked on Gnome flashback and the indicator applet is

XDG_CURRENT_DESKTOP="Unity" dropbox start -i

However the first time I tried it I got an empty menu. I wonder if it worked because of some side effect with the other tests I did between the two runs. The dropbox icon is totally black.

In some cases the icon doesn't even show, but the dropbox process is always running in the background.
I got no icon with:

dbus-launch dropbox start
DBUS_SESSION_BUS_ADDRESS="" dropbox start

More details:

$ echo $XDG_CURRENT_DESKTOP
GNOME-Flashback:Unity

After that successful run of "XDG_CURRENT_DESKTOP="Unity" dropbox start -i" I quit from dropbox using the menu. I run

dropbox start -i # icon with empty menu
dropbox stop
XDG_CURRENT_DESKTOP="Unity" dropbox start -i # icon with colors but empty menu
dropbox stop
XDG_CURRENT_DESKTOP="Unity" dropbox start -i # black icon with menu
dropbox stop
XDG_CURRENT_DESKTOP="Unity" dropbox start -i # black icon with menu

Interestingly I always get this warning

(dropbox:25615): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:1:1: Expected a valid selector

So, there could be a workaround but it's a little shaky.

Donmatas (elcorreodematias) wrote :

Solution #27 works for me

Xubuntu 16.04

Thanks!

Solution #27 does not work for me on xubuntu 16.04. The dropbox icon is still missing after restart

#14 does not work for me either. First it shows the replacement icon and after some seconds this icon disappears

... #22 neither, dropbox 12.4.22 (nautilus-dropbox)

Jeff (boardman-malibu) wrote :

Currently running Dropbox 13.4.21 on Xubuntu 14.04.5. Every time the program updates I get the red circle on the taskbar and mouseovers don't work. I just re-add the line:

   export DBUS_SESSION_BUS_ADDRESS=''

to the 'dropboxd' script in my '~/.dropboxd-dist' folder ,and restart dropbox

The point of all these solutions is to hide the DBUS user session and the indicator-plugin from Dropbox so it is forced to use the system-tray API instead. The Dropbox app doesn't provide the correct interfaces for the indicator to use.

Of course your must have a system-tray plugin (like 'Notification Area' in xfce4) on your desktop for this to work

For xfce4, all script based solutions may fail if session saving is enabled, because the binary could be launched directly. In my ~/.profile file I added the lines:

    rm -f /home/jhm/.cache/sessions/*session*
    rm -f /home/jhm/.cache/sessions/*.state

because even when I tell xfce4 not to save, it does anyway.

One recent problem I discovered was Dropbox not being installed in the /home/<user> folder but in /var instead. I probably used the Software store for that one. If you don't get monthly updates check this line in the '/usr/bin/dropbox' script:

    PARENT_DIR = os.path.expanduser("~") #This is correct

I could write a hourly cron job to check and repair my dropdoxd script but I want to know if next update fails to fix the problem.

#33 does not work for me on 16.10

Eduardo Corral (eduardocorral) wrote :

Happening on Zesty

#28 works for me

XDG_CURRENT_DESKTOP="Unity" dropbox start -i

Pnashdc (pnashdc) wrote :

#22 works for me (clean install of ubuntu 17.04 (zesty)), BUT at the expense of icon live status.

fabricio (fabriciofialho) wrote :

#14 worked for me on Xubuntu 16.04.

See askubuntu.com/a/737615 for a step-by-step guide.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers