desktop icons disappear on Ubuntu 15.04 when clicking Open Dropbox folder

Bug #1453655 reported by Ilan Tal on 2015-05-11
110
This bug affects 21 people
Affects Status Importance Assigned to Milestone
Nautilus
Fix Released
Medium
nautilus (Ubuntu)
Low
Unassigned
Vivid
Undecided
Unassigned
Wily
Low
Unassigned
nautilus-dropbox (Ubuntu)
Undecided
Unassigned

Bug Description

I've been using both Ubuntu and dropbox for several years. With Ubuntu 15.04 there is a new problem that my desktop icons disappear when I click on the dropbox icon in the status bar and choose Open Dropbox Folder. Then the desktop icons will disappear - but will remain visible in Files -> Desktop.

The only way I know to get the desktop icons back is to log out and then log back in again. The bug is 100% reproducible, and it never appeared before 15.04. I also have Copy on my status bar. Clicking on Copy -> Open Copy Folder has no problems. Likewise I can use File with a right click and use Open a New Window and that too is OK. Only dropbox has a problem and only since 15.04

If I can help in any way, please contact me ilan.tal - at - gmail.com

[Impact]
DE-agnostic programs that invoke nautilus using "nautilus --no-desktop" will make the nautilus-rendered desktop vanish. Dropbox is one such case.

[Test Case]
1. Launch nautilus, and make sure it is currently rendering the desktop.
2. Run "nautilus --no-desktop /"
3. See if the desktop vanishes.

[Regression Potential]
The patch is relatively trivial, only affecting the --no-desktop codepath. As a worst case, --no-desktop would not function correctly in cases where nautilus is not already running (--no-desktop when nautilus is not already running means nautilus should not render the desktop at all). Just to make sure, this additional test case should be used:

1. Kill nautilus, and make sure it doesn't get relaunched.
2. Check to see what the desktop looks like (shouldn't be rendered by nautilus, at least)
3. Launch "nautilus --no-desktop /"
4. Make sure that nautilus really doesn't render a desktop.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nautilus-dropbox (Ubuntu):
status: New → Confirmed
Daniel (dalves31) wrote :

I have the exact same issue. I can restore the icons by opening Dconf and going to org - gnome - desktop - background and unticking and ticking show-desktop-icons.

Chow Loong Jin (hyperair) wrote :

Huh, as far as I know, there's nothing really particularly special about the Dropbox folder. Is this a nautilus bug instead? Does it happen with any other folders?

Ilan Tal (ilan-tal) wrote :

It is clearly not obvious that it should be connected to dropbox. In fact it took me a while to find where the connection was. It is however connected to dropbox. I have solved the problem personally in that I now never ask to open a dropbox window. Instead I right click on File and choose Open a New Window. That works properly. Right click on the dropbox icon -> Open Dropbox folder will kill my desktop icons.
This didn't used to happen before 15.04.

On Sat, Jun 06, 2015 at 09:32:07AM -0000, Ilan Tal wrote:
> It is clearly not obvious that it should be connected to dropbox. In fact it
> took me a while to find where the connection was. It is however connected to
> dropbox. I have solved the problem personally in that I now never ask to open
> a dropbox window. Instead I right click on File and choose Open a New Window.
> That works properly. Right click on the dropbox icon -> Open Dropbox folder
> will kill my desktop icons. This didn't used to happen before 15.04.

Hmm, it doesn't seem to do this for me. I'm running 15.04 too.

Could you try opening a terminal, and running this command:
nautilus $HOME/Dropbox

Then check if the the bug occurs.

--
Kind regards,
Loong Jin

Ilan Tal (ilan-tal) wrote :

The dropbox command is located somewhere else:

ilan@ilan-main:~$ $HOME/Dropbox
bash: /home/ilan/Dropbox: Is a directory
ilan@ilan-main:~$

I just tried again right click on the dropbox icon on the taskbar -> Open Dropbox Folder and again it erased my desktop icons. One of the icons is to fire up Netbeans if that helps. Another one is to fire up Virtual box to start up XP. My guess is that it isn't important what exactly the icons are.

Now I will log out and back in to get my icons back. I can still clearly see them in $Home/Desktop, so the bug is alive and well.

Chow Loong Jin (hyperair) wrote :

The command is "nautilus $HOME/Dropbox", not "$HOME/Dropbox".

And nevermind, I've figured it out. Dropbox launches nautilus using "nautilus --no-desktop $HOME/Dropbox", which, in Ubuntu 15.04, turns off the desktop icon rendering. I think this is solely a bug in nautilus, because as far as I know, "--no-desktop" was supposed to just tell nautilus not to render the desktop *only* while launching.

I have the exact same problem.

@ Chow Loong Jin: could you please let us know how to fix this, if possible? thanks a lot.

Ilan Tal (ilan-tal) wrote :

Congratulations. It looks like you are 99% of the road the fix the bug.

Changed in nautilus-dropbox (Ubuntu):
status: Confirmed → Invalid
Changed in nautilus (Ubuntu):
status: New → Triaged
status: Triaged → Confirmed
Changed in nautilus (Ubuntu):
status: Confirmed → Triaged
Changed in nautilus:
importance: Unknown → Medium
status: Unknown → Confirmed
Changed in nautilus (Ubuntu):
importance: Undecided → Low
Changed in nautilus:
status: Confirmed → Fix Released
Chow Loong Jin (hyperair) wrote :

Here's a debdiff against 1:3.14.2-0ubuntu10 to fix this bug.

Changed in nautilus-dropbox (Ubuntu Vivid):
status: New → Invalid
no longer affects: nautilus-dropbox (Ubuntu Vivid)
no longer affects: nautilus-dropbox (Ubuntu Wily)
Chow Loong Jin (hyperair) wrote :

Crap, wrongly targeted vivid. Meant to target wily.

Chow Loong Jin (hyperair) wrote :

Here's the fixed patch.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nautilus (Ubuntu Vivid):
status: New → Confirmed
Marc Deslauriers (mdeslaur) wrote :

ACK on the wily debdiff, uploaded. Thanks!

Changed in nautilus (Ubuntu Wily):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nautilus - 1:3.14.2-0ubuntu10

---------------
nautilus (1:3.14.2-0ubuntu10) wily; urgency=low

  * debian/patches/ignore-no-desktop-if-not-first-launch.patch:
    - Don't shut off the desktop when external application calls nautilus
      --no-desktop on a running GNOME desktop. (LP: #1453655)

 -- Chow Loong Jin <email address hidden> Thu, 18 Jun 2015 18:14:50 +0800

Changed in nautilus (Ubuntu Wily):
status: Fix Committed → Fix Released
Chow Loong Jin (hyperair) wrote :

Debdiff for vivid.

description: updated
Martin Pitt (pitti) wrote :

Uploaded vivid SRU with sanitized version number, thanks! Unsubscribing sponsors now.

Changed in nautilus (Ubuntu Vivid):
status: Confirmed → In Progress

Hello Ilan, or anyone else affected,

Accepted nautilus into vivid-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/nautilus/1:3.14.2-0ubuntu9.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in nautilus (Ubuntu Vivid):
status: In Progress → Fix Committed
tags: added: verification-needed
Nico (nico-schellingerhout) wrote :

I have just installed 15.04 and experienced the same issue that Ilan reported. Upon reading this thread, I upgraded Nautilus to the proposed version (1:3.14.2-0ubuntu9.1), and can confirm that the problem is gone.

So far, no other problems detected.

Thanks for the support.

-Nico

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nautilus - 1:3.14.2-0ubuntu9.1

---------------
nautilus (1:3.14.2-0ubuntu9.1) vivid; urgency=low

  * debian/patches/ignore-no-desktop-if-not-first-launch.patch:
    - Don't shut off the desktop when external application calls nautilus
      --no-desktop on a running GNOME desktop. (LP: #1453655)

 -- Chow Loong Jin <email address hidden> Wed, 24 Jun 2015 11:50:03 +0800

Changed in nautilus (Ubuntu Vivid):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for nautilus has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Matt (mattdt) wrote :

I have very recently made a clean install of 16.04LTS with what appears to be the exact same issue and also seems related to Dropbox. Open Dropbox folder and desktop icons disappear. They are still in the System generated Desktop folder in Home but if I attempt to move them to the desktop the action will not be allowed. The only solution is as stated before, to log out then back in.

Just wondering if the fix in 15.0 has been migrated to 16.04 for fixes and updates? I used Synaptic to see if the 15.0 fix was there under Pre-Release for Nautilus but I don't see anything that looks correct.

Thanks.

Ilan Tal (ilan-tal) wrote :

Hi Matt,
I just checked on my 16.04LTS and I have no problem. For me at least, it is fixed.

Luigi Pezzotta (sunshadow86) wrote :

Hello,
I'm here to report that this bug still appears for me on a recent clean install of Ubuntu 16.10. It was also present, for me, in a previous installation of Ubuntu 16.04. Whenever I open the dropbox folder from the dropbox indicator, all the icons on the desktop disappear.
I have nautilus version 1:3.20.3-1ubuntu3.1.

Leandro Heck (leoheck) wrote :

Hi, I still have this problem on Ubuntu 16.04.1 LTS, with nautilus 1:3.20.3-1ubuntu2~ubuntu16.04.1 installed.

Changed in nautilus-dropbox (Ubuntu):
status: Invalid → Confirmed
Andrea Gamba (andrea-gamba) wrote :

I have the same problem in 16.10

maarten derksen (derxen) wrote :

I have the same problem in 17.04

Adrian King (aking-il) wrote :

Same issue in Ubuntu 17.04 (Unity)

SUPER_ET_DUPER (machst) wrote :

Same issue in Ubuntu 16.10

Leandro Heck (leoheck) wrote :

Me too on Ubuntu 17.04

Ivo (ivo-onraedt-be) wrote :

same problem with Ubuntu 17.04 (Zesty) :
I had two installs : one upgrade from Ubuntu 16.04 and one clean install (next to existing windows 10 partition). The problem was not present with Ubuntu 16.04.
In both installations the problem occurs : desktop icons disappear when dropbox folder is opened from system tray

Mark (mark-rennie) wrote :

Same issue in 17.04 (a clean install). Do not have this problem with the 16.04 LTS release I have running on another computer.

Would greatly appreciate a fix for this, have been living with it now for 6 months and, although no data is lost, it is REALLY annoying and gives an impression of "flakiness". Only affects the desktop if I access the dropbox folders from the icon in the system tray, if I go there through the file manager all works ok.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.