Dropbox indicator not showing correct status

Bug #1069113 reported by bjaanes on 2012-10-20
280
This bug affects 66 people
Affects Status Importance Assigned to Milestone
nautilus-dropbox (Ubuntu)
Undecided
Unassigned

Bug Description

In the system tray (unity) the dropbox indicator is spinning and all is good. But when i click the icon, the status says "Connecting". But that is not the case. Dropbox is actually downloading files and it works 100%.

$ dropbox status
Downloading 129 files (262.8 kB/sec, 23 hr left)

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nautilus-dropbox (Ubuntu):
status: New → Confirmed
no longer affects: dropbox-share
Matthias Schmidt (mschmidt) wrote :

Problem exists with Dropbox Version 1.4.17. It is already fixed in the latest unstable build. See

https://forums.dropbox.com/topic.php?id=91315

I tried it here, but the unstable version rendered my system unuseable. Nearly 100% CPU load and a high memory consumption. I stick with the old version for now.

Ben de Mora (ben-demora) wrote :

Just seen Matthias' comment. I'll wait for the fix to come downstream from Dropbox - my stuff is definitely in sync, it's just the status that's wrong. Minor irritation, which will soon be gone.

Amr Ibrahim (amribrahim1987) wrote :

Auto-update is disabled in the ubuntu downstream package which is just a wrapper (script to download the dropbox client from upstream). You'll have to do "gksudo dropbox update" in a terminal or Alt+F2 to get the latest release. I did it and it is working very well.

Dave Vree (hdave) wrote :

Doing a "dropbox update" doesn't work for me. I'm running 1.4.12 and that capability doesn't seem to be supported. No idea how to proceed.

Amr Ibrahim (amribrahim1987) wrote :

Make sure you did a "gksudo dropbox update". This update option is provided only for the package "nautilus-dropbox" downloaded from the Ubuntu Software Center. If you downloaded the package directly from dropbox.com, it would update automatically, you don't have to do anything.

I had the problem described above with v1.4.12.
Did a "gksudo dropbox update", and now have v1.4.21 and... works great and fine !
Thanks !

psychok7 (nunok7) wrote :

this worked for me after i exited dropbox and:
"Hey guys,
Please uninstall the client by running rm -rf ~/.dropbox-dist or sudo rm -rf /var/lib/dropbox/.dropbox-dist
then run dropbox start -i to install the latest version.
Cheers,
David"

Sebastian (slovdahl) wrote :

Worked for me too!

Dave Vree (hdave) wrote :

@pyschok7 - thanks! Your instructions were the only ones that worked for me. Now happily running 1.6.0 with no issues.

Jeffrey Zhang (jeffrey4l) wrote :

@pyschok7 - work for me too. Thanks a lot.

Leonardo Lazarte (llazarte) wrote :

@pyschok7 - Thanks a lot!

I did:
> dropbox stop
> mv ~/.dropbox-dist ~/DROPBOX-DIST (backup, just in case! :-)
> sudo mv /var/lib/.dropbox-dist /var/lib/DROPBOX-DIST (idem)
> dropbox start -i

It recreated /var/lib/.dropbox-dist
I have no ~/.dropbox-dist now

Dropbox is working perfectly
Dropbox applet is working ok.

 @pyschok7 - we`re already in 2014 and your tip has solved my problem! Thanks a lot.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers