Crash when clicking "Write to Disc"

Bug #73796 reported by Lachlan
4
Affects Status Importance Assigned to Milestone
nautilus-cd-burner
Invalid
Undecided
Unassigned
nautilus-cd-burner (Ubuntu)
Medium
Ubuntu Desktop Bugs

Bug Description

Binary package hint: nautilus-cd-burner

Using the same hardware, it worked perfectly with the version of nautilus that came with Dapper. I re-installed a fresh Edgy on the same machine, and now when I try to burn a DVD it crashes. I will attach the bug report that was auto-generated.

The drive can still read DVDs. I have not yet tried other burning software.

Revision history for this message
Lachlan (lachlan) wrote :

Here is the crash report.

description: updated
Revision history for this message
Sebastien Bacher (seb128) wrote :

Thank you for your bug. Could you get a backtrace with libglib2.0-0-dbg libgtk2.0-0-dbg nautilus-cd-burner-dbgsym installed?

Changed in nautilus-cd-burner:
assignee: nobody → desktop-bugs
importance: Undecided → Medium
status: Unconfirmed → Needs Info
Revision history for this message
Lachlan (lachlan) wrote :
Download full text (4.6 KiB)

Ok, I installed libglib2.0-0-dbg libgtk2.0-0-dbg, but I couldn't find nautilus-cd-burner-dbgsym.

This is my set up. I am sourcing files from a couple different physical hard drives, and copied those files to the "CD/DVD Creator Folder" using drag and drop in gnome.

1. I closed the gui folder, and open up a terminal.
2. I ran nautilus-cd-burner from the command line
3. The "Write to Disc" dialog gui pops up. I accept the defaults:
     Write Disc To: AOPEN DUW1608/ARR
     Data Size: 4.0 GB
     Write Speed: Maximum Possible
4. I clicked 'Write"
5. I clicked "OK" on the Popup to disable microsoft file name compatibility.

then the gui hangs, on the console I get this:

*** glibc detected *** nautilus-cd-burner: free(): invalid pointer: 0x081ea970 ***
======= Backtrace: =========
/lib/tls/i686/cmov/libc.so.6[0xb78318bd]
/lib/tls/i686/cmov/libc.so.6(__libc_free+0x84)[0xb7831a44]
/usr/lib/libglib-2.0.so.0(g_free+0x31)[0xb7931b51]
/usr/lib/libglib-2.0.so.0(g_ptr_array_free+0x5c)[0xb790cb9c]
nautilus-cd-burner[0x8056bab]
nautilus-cd-burner[0x804fc37]
/usr/lib/libglib-2.0.so.0[0xb7928aa1]
/usr/lib/libglib-2.0.so.0(g_main_context_dispatch+0x182)[0xb792a802]
/usr/lib/libglib-2.0.so.0[0xb792d7df]
/usr/lib/libglib-2.0.so.0(g_main_loop_run+0x1a9)[0xb792db89]
/usr/lib/libgtk-x11-2.0.so.0(gtk_main+0xb4)[0xb7c60574]
nautilus-cd-burner[0x804d812]
/lib/tls/i686/cmov/libc.so.6(__libc_start_main+0xdc)[0xb77e08cc]
nautilus-cd-burner[0x804d501]
======= Memory map: ========
08048000-0805b000 r-xp 00000000 03:01 6685359 /usr/bin/nautilus-cd-burner
0805b000-0805c000 rw-p 00013000 03:01 6685359 /usr/bin/nautilus-cd-burner
0805c000-083e2000 rw-p 0805c000 00:00 0 [heap]
b4d00000-b4d21000 rw-p b4d00000 00:00 0
b4d21000-b4e00000 ---p b4d21000 00:00 0
b4e97000-b4ea1000 r-xp 00000000 03:01 2326595 /lib/libgcc_s.so.1
b4ea1000-b4ea2000 rw-p 00009000 03:01 2326595 /lib/libgcc_s.so.1
b4eaf000-b4f13000 r--p 00000000 03:01 6930587 /usr/share/fonts/truetype/ttf-dejavu/DejaVuSans-Oblique.ttf
b4f13000-b4f1a000 r-xp 00000000 03:01 6686124 /usr/lib/libfam.so.0.0.0
b4f1a000-b4f1b000 rw-p 00006000 03:01 6686124 /usr/lib/libfam.so.0.0.0
b4f1b000-b4f20000 r-xp 00000000 03:01 2326556 /lib/libacl.so.1.1.0
b4f20000-b4f21000 rw-p 00005000 03:01 2326556 /lib/libacl.so.1.1.0
b4f29000-b4f2d000 r-xp 00000000 03:01 6750587 /usr/lib/gtk-2.0/2.10.0/loaders/libpixbufloader-png.so
b4f2d000-b4f2e000 rw-p 00003000 03:01 6750587 /usr/lib/gtk-2.0/2.10.0/loaders/libpixbufloader-png.so
b4f2e000-b4f3a000 r-xp 00000000 03:01 6750519 /usr/lib/gnome-vfs-2.0/modules/libfile.so
b4f3a000-b4f3b000 rw-p 0000b000 03:01 6750519 /usr/lib/gnome-vfs-2.0/modules/libfile.so
b4f3b000-b4f9b000 rw-s 00000000 00:08 4259860 /SYSV00000000 (deleted)
b4f9b000-b4faa000 r-xp 00000000 03:01 2326569 /lib/libbz2.so.1.0.3
b4faa000-b4fab000 rw-p 0000f000 03:01 2326569 /lib/libbz2.so.1.0.3
b4fab000-b4fdb000 r-xp 00000000 03:01 6686047 /usr/lib/libcroco-0.6.so.3.0.1
b4fdb000-b4fde000 rw-p 0002f000 03:01 6686047 /usr/lib/libcroco-0.6.so.3.0.1
b4fde000-b5007000 r-xp 00000000 03:01 6686297 /usr/lib/libgsf-1.so.114.0.1
b5007000-b500a000 rw-p 00028000 03:01 6686297 /...

Read more...

Revision history for this message
Sebastien Bacher (seb128) wrote :

you can get the dbgsym packages from the "deb http://people.ubuntu.com/~pitti/ddebs edgy main universe" apt source. That seems to be an incorrect free() call, could you run valgrind (https://wiki.ubuntu.com/Valgrind) to get details about it after installing the dbgsym package?

Revision history for this message
Lachlan (lachlan) wrote :

Well, after installing nautilus-cd-burner-dbgsym - I don't get the crash anymore. I have burnt 3 DVDs in a row without error. Two of those burns were through valgrind if you still are interested in the logs.

I guess your development version fixes this issue. Thanks for your help!

Revision history for this message
Lachlan (lachlan) wrote :

Whoops - spoke too soon. It just crashed again on the 4th DVD. I was able to run it through valgrind to reproduce the crash. I will attach the logs.

Changed in nautilus-cd-burner:
status: Needs Info → Confirmed
Revision history for this message
Mario Đanić (mario-danic) wrote :

Do you still experience the problem with feisty/gutsy?

Revision history for this message
Lachlan (lachlan) wrote :

No, things seem fine now. I haven't had that problem in a long time. I'm on fiesty now, by the way.

Revision history for this message
Daniel Holbach (dholbach) wrote :

Closing the bug. Thanks for following up!

Changed in nautilus-cd-burner:
status: New → Invalid
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers