The cd burning dialog can be closed, and does not ask for confirmation

Bug #63547 reported by Vincenzo Ciancia
2
Affects Status Importance Assigned to Milestone
nautilus-cd-burner (Ubuntu)
Medium
Ubuntu Desktop Bugs

Bug Description

Binary package hint: nautilus-cd-burner

As in subject, I hit ALT+F4 with focus on the wrong window, the cd burning dialog instead of the nautilus file manager window, in the middle of the burning process, and I lost a DVD (so a little amount of money). When doing something non-reversible such as stopping writing to a DVD, confirmation MUST be asked.

=== A comment about the current gnome situation ===

Ok, I was burning my FIRST non rewritable device with Nautilus. If someone is wondering why I say "FIRST non rewritable", it is because every time I test gnome again, I discover so many small bugs and crashes that I never feel like trusting a gnome application for something serious. I know, as an experienced user, that a badly designed burning program can waste my money ruining burned cd, and also my time.

After having installed Ubuntu 6.10 again, after a week of intense usage, it looked to me like gnome is becoming trust-able, and trusted it in writing a non-rewritable DVD. I was just plain wrong. Heck, was it MY fault, pressing alt+F4 on the wrong window? Of course, but why does k3b ask for confirmation? I bet also windows programs do that! Come on, if I write a file system, I am supposed to be really careful when saving file data, and if I write a cd burner, I am supposed to be really careful in not throwing away a dvd without asking for confirmation first.

The problem is, that this "gnome is broken" feeling cannot go away from my head. I will keep on using it (not nautilus-cd-burner, of course, for now) because I really like it. Will try to report all bugs I find, and, really, thanks to the ubuntu team for having fixed them all, I am really impressed. I didn't pay for that, and you worked for me so hard, that I feel obliged to try to do my best to help ubuntu.

This comment is really non-constructive, sorry, but I think it's better to leave it here. I use to recommend linux to friends and even my mother, but I cannot recommend ubuntu+gnome yet, even if it is so faster than the others, and so much more usable at first sight. I would really like to be able to recommend it. Will keep on reporting bugs I find :)

Revision history for this message
Vincenzo Ciancia (vincenzo-ml) wrote :

The bug has been fixed in edgy, should I mark this as "fix released"?

Revision history for this message
Sebastien Bacher (seb128) wrote :

Thank you for the bug and the update, if that's fixed to the current worked version the bug can be marked fixed, doing that now. Ranting on a bug is not really useful, people writting those software do they best to fix bugs and write good softwares, often without being payed and you will find few softwares without any bug, better to work at making them better

Changed in nautilus-cd-burner:
assignee: nobody → desktop-bugs
importance: Undecided → Medium
status: Unconfirmed → Fix Released
Revision history for this message
Vincenzo Ciancia (vincenzo-ml) wrote :

Sebastian, I understand, but please understand that, at the time of this bug report, I really had enough of it, I mean all the bugs I was encountering in what was called a stable version.

If ubuntu and gnome developers don't accept that their real problem is that their software has a lot more bugs than any other equivalent software, no change will happen. And since I like gnome and ubuntu, I would like to see a change happen :)

Sorry for bothering you all with these two comments, though.

Revision history for this message
Sebastien Bacher (seb128) wrote :

Ubuntu mostly ship upstream software, the same software than other distribution, and the same bugs too. You would have faced that same bug using fedora, suse, mandriva or debian when they shipped the same version of GNOME. Your claim about the number of bugs compared to other software isn't based on any fact and probably not true.

Do you know of any software which has no bug? Do you think that people don't realize from the bug reports they get that their software has bugs and that they need to "accept" that fact? Fixing bugs take time and trying to explain to those guys they don't do a good job is not going to make them work harder to fix your problem. You should better try being constructive, make useful bug reports which make easier for people to fix bugs and send patches maybe, that is going to make the software better

Revision history for this message
Vincenzo Ciancia (vincenzo-ml) wrote :

I don't want to offend anyone. Since you're helping me helping ubuntu for the few I can, I am really sorry to have made you upset. I should really reply in private and am going to do it, but don't want to leave here such a bad mood, so let me explain:

I don't think developers are not doing a good job. The difference between dapper and edgy is really astonishing, so many bugs have been closed in so few time. Moreover, I agree, this particular bug is an upstream bug, but I want to point out a situation which seems not to be likely to change soon. I report bugs regularly, with backtraces, and use ubuntu a lot; this is the reason why I know a lot of ubuntu-specific, embarassing bugs and sometimes would like to try to communicate to ubuntu developers, that since there is this very positive moment in ubuntu's popularity, much more care should be but in the details of the distribution. If someone would like to know examples of what I mean with ubuntu specific bugs, or why I consider those embarassing, just write to me in private - but I don't expect to be so important for you :)

Revision history for this message
Sebastien Bacher (seb128) wrote :

I'm not upset don't worry, I just want to point that many bugs are still open because there is not enough people working on them and not because those who are working are not doing a good job. Anyway that is out of topic for that bug now so let's stop the comments about it on launchpad

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers