An error in Rhythmbox burning dialog - endless list of repetitive speed values

Bug #55327 reported by Francesco Accattapà
42
Affects Status Importance Assigned to Milestone
Rhythmbox
Fix Released
Medium
nautilus-cd-burner (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

There is an error in the cd burning dialog in rhythmbox. I get a default write speed of 0x, and if I try to change it I get an endless list of progressive values. I guess that some sequential screenshots will explain the problem much better that my poor english, so I'm attaching them.

Steps to reproduce:
1. Open Rhythmbox
2. Add any tracks to any playlist
3. Try burning this playlist to the CD.

All this is on an updated edgy; rhythmbox version: 0.9.5-1ubuntu3

CD burner (hardware): MATSHITACD-RW CW-8123

Revision history for this message
Francesco Accattapà (callipeo) wrote :
Revision history for this message
Francesco Accattapà (callipeo) wrote :
Revision history for this message
Francesco Accattapà (callipeo) wrote :
Revision history for this message
Mateusz Drożdżyński (matid) wrote :

Thanks for your bug report. This particular bug has been filed
with the developers of the software. You can track this and make
comments here: http://bugzilla.gnome.org/show_bug.cgi?id=350082

description: updated
Changed in rhythmbox:
status: Unconfirmed → Confirmed
Revision history for this message
Mateusz Drożdżyński (matid) wrote :

This bug is probably hardware-dependent.
I was able to reproduce it when I selected SAMSUNG CD-R/RW DRIVE SW-252F burner, however it doesn't occur when I chose LITE-ON DVDRW SOHW-1673S.

Changed in rhythmbox:
status: Unknown → Unconfirmed
Revision history for this message
Sebastien Bacher (seb128) wrote :

Could you run /usr/lib/nautilus-cd-burner/list_cddrives and copy the datas for the corresponding drive to a comment?

Changed in rhythmbox:
assignee: nobody → desktop-bugs
importance: Untriaged → Low
Revision history for this message
Mateusz Drożdżyński (matid) wrote :
Revision history for this message
Mateusz Drożdżyński (matid) wrote :
Revision history for this message
Mateusz Drożdżyński (matid) wrote :

I split the output of list_cddrives for easier viewing.

Revision history for this message
Mateusz Drożdżyński (matid) wrote :

After looking at the output from list_cddrives I think that this bug is filled against the wrong package. I can reproduce it in nautilus' CD/DVD creator and therefore I change to package to nautilus-cd-burner.

Revision history for this message
Nafallo Bjälevik (nafallo) wrote :

I can reproduce it on a PIONEER DVD-RW DVR-111D.

Revision history for this message
Nafallo Bjälevik (nafallo) wrote :
Revision history for this message
Hussam Al-Tayeb (hussam) wrote :

I also see this on a LG CD-RW.
This of course worked fine in dapper.

Revision history for this message
Sebastien Bacher (seb128) wrote :

could you also attach a lshal log?

Revision history for this message
Michael R. Head (burner) wrote :

Here's my list_cddrives output.

Revision history for this message
Michael R. Head (burner) wrote :

Here's my lshal output

Revision history for this message
Sebastien Bacher (seb128) wrote :

I've uploaded a package with a patch from upstream to fix the issue:

" nautilus-cd-burner (2.16.0-0ubuntu2) edgy; urgency=low
 .
   * debian/patches/03_fix_speeds_list.patch:
     - patch from bugzilla to fix repetitive speeds being listed
       (Ubuntu: #55327)"

Could people comment saying if that update fixes their issue or not? Marking as fixed for now. Feel free to reopen if you still have the issue

Changed in nautilus-cd-burner:
status: Confirmed → Fix Released
Revision history for this message
Nafallo Bjälevik (nafallo) wrote :

 Hi,

Just commented on the upstream bug. I _can_ burn now, but now the issue is that it thinks 4.something is a good top speed on a 16x burner :-/. Is this a reopen or a new bug though?

Cheers, /C

Changed in rhythmbox:
status: Unconfirmed → Fix Released
Revision history for this message
Sebastien Bacher (seb128) wrote :

open a new bug for the 4 against 16x with the log from lshal, it might be hal not listing other speeds for the drive

Revision history for this message
Michael R. Head (burner) wrote :

I commented on the bugzilla bug, but I'll mention here too that the patch isn't completely perfect, but it's a decent work around for the HAL problem. Attached is my current list_cdddrives output.

Changed in rhythmbox:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.