Nautilus-cd-burner and Brasero are unable to blank DVD-RW

Bug #53962 reported by Jiba
24
This bug affects 2 people
Affects Status Importance Assigned to Milestone
nautilus-cd-burner (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

Binary package hint: nautilus-cd-burner

Nautilus-cd-burner fails to blank my DVD-RW, although K3B blanks the same DVD-RW.

Similarly, GnomeBaker fails too.

XCDroast fails too, and complains about cdrecord-ProDVD missing, but i didn't found a package for it, and it doesn't appear in the dependences.

After blanking the CD with K3B, nautilus-cd-burner was able to write on it.

In conclusion, i'm wondering wether a cdrecord-prodvd package is not missing, and should be a dependency for nautilus-cd-burner.

I'm using Ubuntu Dapper Drake, and my CD burner is a "TOSHIBA CD/DVDW SDR6472U".

Revision history for this message
snapscanes (snapscanes) wrote :

"dvd+rw-format -force /dev/dvd" work erase DVD-RW
"Nautilus-cd-burner" no work
I'm using Ubuntu Dapper Drake, and my CD burner is a "SONY DVD RW DW-Q58A".

Revision history for this message
jim (hesoez) wrote :

I have the dapper packages for nautilus-cd-burner and dvd+rw-tools installed

GnomeBaker works now since 0.6.0 was added to dapper through backports.

Maybe it is just a matter of calling the wrong command in the background.

--------------------------------------
$dvd+rw-format /dev/dvd
* DVD�RW/-RAM format utility by <email address hidden>, version 4.10.
* 4.7GB DVD-RW media in Sequential mode detected.
- media is not blank
- you have the option to re-run dvd+rw-format with:
  -force[=full] to enforce new format or mode transition
                and wipe the data;
  -blank[=full] to change to Sequential mode.
----------------------------------
Maybe it didn't used to need an option but it needs it now.

When i use '-blank':
----------------------------------
$dvd+rw-format -blank /dev/dvd
* DVD�RW/-RAM format utility by <email address hidden>, version 4.10.
* 4.7GB DVD-RW media in Sequential mode detected.
* blanking 95.2\
---------------------

My disk is empty now.
---------------------
$dvd+rw-format /dev/dvd
* DVD�RW/-RAM format utility by <email address hidden>, version 4.10.
* 4.7GB DVD-RW media in Sequential mode detected.
- media is blank
- given the time to apply full blanking procedure I've chosen
  to insist on -force option upon mode transition.
---------------------

Could this be checked?
thanks

Revision history for this message
jim (hesoez) wrote :

lines 1724 to 1746 in 'nautilus-burn-recorder.c' from 'nautilus-cd-burner-2.14.3.orig.tar.gz'.
When the medium is not empty and of type 'NAUTILUS_BURN_MEDIA_TYPE_DVD_PLUS_RW' it doesn't seem to do anything.
And it seems to only add the '-blank' flag if the medium is not 'NAUTILUS_BURN_MEDIA_TYPE_DVD_PLUS_RW'
I don't know what exactly 'NAUTILUS_B...PLUS_RW' is and i don't have time to search further but it seems worth having a look at.

grtz

Revision history for this message
Sebastien Bacher (seb128) wrote :

Do you still have that bug?

Revision history for this message
jim (hesoez) wrote :

I have updated my dapper and tried again but it still fails.

Revision history for this message
Sebastien Bacher (seb128) wrote :

What version of Ubuntu do you use now? Could you run /usr/lib/nautilus-cd-burner/list_cddrives with a DVD-RW to the drive and copy that to a comment?

Changed in nautilus-cd-burner:
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: Unconfirmed → Needs Info
Revision history for this message
Sebastien Bacher (seb128) wrote :

could you also attach a lshal log to the bug?

Revision history for this message
jim (hesoez) wrote :

Because my primary hard drive was failing i had to reinstall the system and took the opportunity to upgrade to edgy. I have the same problem in edgy though.
I have the output from 'list_cddrives' and the part from 'lshal' for cd-rom attached.

Revision history for this message
Skeletonix (tomaskloucek) wrote :

Yeah, I have same problem. If I want burn DVD-RW in nautilus-cd-burner and not erase DVD-RW before, burning finish with error... Creating image starts properly. than jump up a dialog if I want erase DVD-RW and than error ... :(

Changed in nautilus-cd-burner:
status: Needs Info → Unconfirmed
Revision history for this message
DavidBentham (dbentham) wrote :

Hi currently experiencing the same problem with dvd-rw disks.

K3B formats ok, so there must be a underlaying problem with the nautilus-cdburner.

Revision history for this message
DavidBentham (dbentham) wrote :

Answering to my question.

I've just updated the firmware of the drive to 1.73 from 1.71

Seems to of solved the problem.

The drive was SONY DVD RW AW-G170A

Hope this helps someone?

Revision history for this message
Mario Đanić (mario-danic) wrote :

Others: Can you still reproduce problem with gutsy?

Changed in nautilus-cd-burner:
status: New → Incomplete
Revision history for this message
Alec Wright (alecjw) wrote :

Mario: Yes I can. I'm using gutsy here and nautilus-cd-burner cant blank dvd's but dvd+rw-format -force /dev/dvd does. I get the same error message as jim posted on 2006-12-14.

Changed in nautilus-cd-burner:
status: Incomplete → New
Revision history for this message
Alec Wright (alecjw) wrote :

Fixed in gutsy now =]

Changed in nautilus-cd-burner:
status: New → Fix Released
Revision history for this message
Alec Wright (alecjw) wrote :

Scratch that, its not. Sorry.

Changed in nautilus-cd-burner:
status: Fix Released → Confirmed
Revision history for this message
LinuxComp (myynti-linuxcomp) wrote :

Same problem here on Gutsy. Tried erasing DVD-RW-disks in both Brasero and Gnomebaker. After Gnomebaker had erased the DVD-RW it gives me an error when I insert the disc. Tried to erase another disc with Brasero and it just keeps erasing but it wont finish.

Revision history for this message
Vladimír Burian (vburian) wrote :

Same problem here on Hardy Beta.

Revision history for this message
psl (slansky) wrote :

Ubuntu 8.04.1, i386, Nautilus 2.22.3

I can reproduce the issue. When I try to write an ISO image to a DVD+RW or DVD-RW and the rewritable disk s not empty, I am informed that disk has to be erased. When I press ERASE button, I get an error after a while that disk cannot be erased. and that is correct, DVD-RW disk has to be formatted...

Nautilus should run format (not erase) for DVD rewritable disks. Or it should offer a FORMAT button for DVD-RW and DVD+RW disks.

As a workaround, I run GnomeBaker and format a disk manually from Tools menu.

Revision history for this message
Mat H (mat.hd) wrote :

Why is nautilus cd burner forcing itself as the default burner as it did after i was using Brasero cutting in half way through a burn?
Personally i feel rather let down by my Ubuntu in general and wasted hours trying to get two burns over Xmas. I think it may be the result of updating a kernel or Mobile-broadband-provider-info (which hitched/connected itself to my brasero burner in the synaptic package manager) ?
I do remember deleting a Cd/Dvd burner not long ago from my Ubuntu Software Center in maverick using a x86 64 laptop whether this did someting i'll never know.
Could there be a problem with my Nautilus default settings ?
I've tried reinstalling K3B and Brasero Burner with Dao and noticed this had no effect. When i switched burning from Brasero to K3b i noticed that a gconf notice came up on the screen about changing a setting of which i did and it help me finish what i was copying.
I'm aware that i was able to burn Cd's easily before any updates.! I'm also wondering how many people had problems with their CD Burners after the kernel update in Maverick 10.10 x86 64 ?

Revision history for this message
Thomas Hotz (thotz-deactivatedaccount) wrote :

Can you please list up the CD burners not working correctly? Thank you!

Changed in nautilus-cd-burner (Ubuntu):
status: Confirmed → Incomplete
Revision history for this message
dino99 (9d9) wrote :

hi Thomas,

instead listing the not working, i prefer to list the only one working: k3b
everything either make errors /burn too quickly & cant be slowed down/lag fonctions/...

dino99 (9d9)
tags: added: raring saucy
Revision history for this message
Thomas Hotz (thotz-deactivatedaccount) wrote :

Hello dino99, thank you for your reply!

K3B would be a good alternative, but Brasero is the standard burning program in Ubuntu and we should work hard to make burning with Brasero under Ubuntu (Unity) working like a charm.

Changed in nautilus-cd-burner (Ubuntu):
status: Incomplete → Confirmed
summary: - Nautilus-cd-burner is unable to blank DVD-RW
+ Nautilus-cd-burner and Brasero are unable to blank DVD-RW
Revision history for this message
Thomas Schmitt (scdbackup) wrote :

Hi,

i am the developer of libburn, which might be employed as burn backend
by Brasero. In this case i offer my help with finding the reasons of failure.

Needed would be a tester with an affected Brasero program, the necessary
type of media, and the willingness to run experiments with command line
applications of libburn (cdrskin or xorriso).

Have a nice day :)

Thomas

Revision history for this message
Thomas Schmitt (scdbackup) wrote :

Hi,

i noticed that the properties of DVD-RW are misrepresented
in some of the posts.

DVD-RW can assume two states: sequential and overwritable.

The sequential state behaves much like CD-R or DVD-R. The medium
has an own table-of-content where it records the track boundaries
of one or more burn sessions.
DVD-RW in sequential state have to be blanked before they can
be re-used from scratch. There are two blanking strategies:
fast and full.
Fast blanking of DVD-RW causes the medium to be unable of the
"incremental" write type. Only a single track and session can
be written in DAO mode.
Full blanking lasts as long as writing full DVD of data. It has
the benefit, though, to bring the medium into the same state as
a virgin DVD-R, which can accept more than one burn session and
does not necessarily need to know the size of the session in advance.

In the overwritable state, a DVD-RW resembles DVD+RW or DVD-RAM.
It has no own table-of-content, and only one track which can be
read and written in random access mode with 32 KiB granularity.
Overwritable DVD-RW do not need blanking for being re-used from
scratch. One may write 64 KiB of zeros to their start in order to
invalidate an existing ISO 9660 filesystem, which would cause
programs like growisofs or xorriso to append the new data rather
than to start writing a completely new ISO 9660 filesystem.

DVD-RW are sold in blank sequential state.

One may bring a sequential DVD-RW into overwritable state by e.g:
  dvd+rw-format -force /dev/...

One may bring an overwritable DVD-RW or a non-blank sequential DVD-RW
into blank sequential state by e.g.:
  dvd+rw-format -blank=full /dev/...

Only capable of DAO writing is the result of
  dvd+rw-format -blank=fast /dev/...

It depends on the state of the medium and on deliberate decisions
of the burn frontend program or its user, whether a DVD-RW gets
blanked or formatted.

With DVD+RW (which have sneaked into this bug report too) there
is no decision to be done by the frontend. The backend must know
about the peculiarities of DVD+RW background formatting and issue
the necessary FORMAT commands if needed.
This is the reason why burn programs on DVD+RW sometimes report
formatting for a few seconds before they start to write.

Have a nice day :)

Thomas

tags: added: precise quantal
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers