Ubuntu

CD/DVD Creator using incorrect file size units

Reported by Joel Parker on 2007-08-04
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Nautilus
Expired
Medium
nautilus-cd-burner (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

Binary package hint: nautilus

The Nautilus CD/DVD Creator function is using completely wrong file size units in its dialogs.

I have an example file:

$ ls -lh --si
total 1.2G
-rwxr--r-- 1 joeljkp joeljkp 1.2G 2007-08-02 23:03 file.7z
$ ls -lh
total 1.1G
-rwxr--r-- 1 joeljkp joeljkp 1.1G 2007-08-02 23:03 file.7z
$

Notice that that's 1.2 gigabytes in SI form (1GB = 1000^3 bytes), and 1.1 gigabytes in non-SI form (1GB = 1024^3 bytes, equiv. to 1.1 gibibytes).

When I put this file into the CD/DVD Creator, it shows the file size as 1.1GB (obviously using the non-standard notation).

However, when I press the Write to Disc function, it states "Data Size: 1.0 GiB".

This means that this dialog is trying to use gibibytes by assuming the file listing is using SI gigabytes. This assumption is wrong, leading to all kinds of confusion.

Either the Write to Disc dialog should say "1.1 GB" (keeping with non-standard notation), "1.1 GiB" (standard binary notation but not internally consistent with the file listing), or "1.2 GB" (again, standard notation but not internally consistent with the file listing).

ProblemType: Bug
Architecture: i386
Date: Fri Aug 3 19:43:34 2007
DistroRelease: Ubuntu 7.04
ExecutablePath: /usr/bin/nautilus
Package: nautilus 1:2.18.1-0ubuntu1
PackageArchitecture: i386
ProcCmdline: nautilus --no-default-window --sm-client-id default2
ProcCwd: /home/joeljkp
ProcEnviron:
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/home/joeljkp/Software/bin
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: nautilus
Uname: Linux joel-laptop 2.6.20-16-generic #2 SMP Thu Jun 7 20:19:32 UTC 2007 i686 GNU/Linux

Joel Parker (jjkp) wrote :
Pedro Villavicencio (pedro) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This bug is known upstream : http://bugzilla.gnome.org/show_bug.cgi?id=163834 ; please feel free to posts your comments there, thanks in advance.

Changed in nautilus:
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: New → Triaged
Changed in nautilus:
status: Unknown → Confirmed
Endolith (endolith) wrote :

Maybe the best way would be to show both measurements, since this creates both CDs and DVDs.

CD size is stated in MiB and DVD size is stated in GB:

4.7 GB DVD = 4.7 x 1000 x 1000 x 1000 bytes

"700 MB" CD = 360,000 x 2048 = 737,280,000 bytes = 703.1 MiB

Pedro Villavicencio (pedro) wrote :

Does this still applies to brasero? Nautilus-cd-burner was replaced by brasero in 2.26.

Changed in nautilus-cd-burner (Ubuntu):
status: Triaged → Incomplete
Changed in nautilus:
status: Confirmed → Invalid
Pedro Villavicencio (pedro) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to New. Thanks again!.

Changed in nautilus-cd-burner (Ubuntu):
status: Incomplete → Invalid
Endolith (endolith) on 2010-03-13
tags: added: units-policy
Changed in nautilus:
importance: Unknown → Medium
status: Invalid → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions

Related blueprints

Remote bug watches

Bug watches keep track of this bug in other bug trackers.