Nautilus Actions don't show up in Nautilus right-click menu if the command is not a full path

Bug #488612 reported by Mike Durham on 2009-11-26
40
This bug affects 7 people
Affects Status Importance Assigned to Milestone
Nautilus Actions
Fix Released
Medium
nautilus-actions (Ubuntu)
Wishlist
Didier Roche

Bug Description

Binary package hint: nautilus

It appears that Nautilus Actions doesn't work in Lucid. I've installed 3 actions but they don't show in the right-click menu.

ProblemType: Bug
Architecture: i386
Date: Thu Nov 26 16:34:23 2009
DistroRelease: Ubuntu 10.04
Package: nautilus 1:2.28.1-0ubuntu2
ProcEnviron:
 LANG=en_AU.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-5.6-generic
SourcePackage: nautilus
Uname: Linux 2.6.32-5-generic i686

Mike Durham (mdurhamesq) wrote :
affects: nautilus (Ubuntu) → nautilus-actions (Ubuntu)
panjandrum (panjandrummail) wrote :

I have the same problem on Debian sid.

Sense Egbert Hofstede (sense) wrote :

A new version of nautilus-actions landed today. Could you please check with the latest release? Please also include the version number of nautilus-actions you've got installed in your reply.

Doug McMahon (mc3man) on 2010-03-30
Changed in nautilus-actions (Ubuntu):
status: New → Confirmed
Doug McMahon (mc3man) wrote :

Lucid Fully updated as of 03/30 (gnome, nautilus, ect.)
Using 2.30.0-0ubuntu1
While actions can be created, saved, edited, ect. they fail to appear in the context menu.

Tested on 2 separate installs, the same behavior was seen previously with 2.29.4 (self built)

A built 2.29.4 does work in karmic so I'm gathering I understand how to use it, at least in a basic sense (obviously the 2.29.X releases are considerably different than the previous 1.1X.X as seen in karmic and earlier

Same thing here. Nautilus Actions worked just fine in Lucid (with a setup inherited from Karmic) until Monday's updates, then all the context menu items disappeared. Upon noticing this I zapped my Nautilus Actions configuration (by moving the entire ~/.gconf/apps/nautilus-actions branch to a safe place) and created a couple of new actions for testing purposes, throwing in a few "killall nautilus" commands and log-ins/log-outs in between, all to no avail. Whatever actions I define, they won't appear in the actual context menus in Nautilus.

It seems that at the same time diff-ext (which allows comparing files in meld via Nautilus' context menus) also stopped working. This may be an indication that the breakage is due to some recent change in the way Nautilus integrates context menu items from third-party apps.

OTOH the Nautilus Actions Configuration tool, which wouldn't even start in Lucid until Monday, is now mostly working, albeit with lots of minor and not-so-minor bugs, the worst being that the export assistant doesn't actually export anything.

Sense Egbert Hofstede (sense) wrote :

I can confirm this issue myself and have reported it upstream. Since this means the work for the Bug Squad is done for now I'm setting the status to Triaged. The importance is set to Medium since this bug renders a non-core application pretty useless.
Thank you for your feedback.

Changed in nautilus-actions (Ubuntu):
importance: Undecided → Medium
status: Confirmed → In Progress
status: In Progress → Triaged
Sense Egbert Hofstede (sense) wrote :

The upstream developer said that he cannot confirm this issue. I'll do some further testing to see why it doesn't work on Lucid.

He also made the following remarks:
"- there is no need to killall nautilus when you update an action in NACT; GConf
is monitored, and the Nautilus context menu is automatically updated when an
action is updated in GConf.

- yes, 2.29.x is a big evolution over 1.12 serie

- I confirm that export tool doesn't actually export anything under Lucid
  (though as a temporary work-around, drag-and-drop seems fine)

- "albeit with lots of minor and not-so-minor bugs": could Sebastian be kind
enough to report them, please?"

As soon as I find the time and patience I'll file a couple of bug reports for those other issues that I stumpled upon in the config tool. For now I just want my Nautilus Actions back. I really miss them, they used to make life so much easier!

For starters and just to give a few examples (admittedly off-topic), the developer may want to have a closer look at the export assistant's general usability. The initial dialog ("This assistant will guide you ...") is unnecessary. I found the custom "Selecting the target folder" dialog quite confusing with all those panes and boxes. Something a little closer to established standards would be preferable. The following dialog, "Selecting the export format", will overwhelm any user who is not deep into gconf internals. With a little playing around or, even better, looking an average user over the shoulder while actually using the export assistant it could be improved a lot.

Another minor issue that irritated me was that, on the "Folders" tab for an action, there is by default a / (root directory) item which, when removed, can't be added again to the list. When I click the Plus button, I can select "File system" to add a file:/// folder (which may or may not be the same thing as / in this context). If, on the other hand, I enter / as a string into the Location field of the "Select a folder" dialog and then click Open, an error message appears telling me that "The folder could not be created" because the "file exists". Thankfully it does indeed.

None of this, of course, has anything to do with the present bug report. None of this is, by itself, a big enough problem to justify its own bug report. Maybe if there was some kind of wishlist for Nautilus Actions, I'd simply add them to that.

Pierre (pwieser) wrote :

Hi
I am the Nautilus-Actions maintainer.
I've finally found a case where an action may not be fully loaded in NACT. But as it is not really what is described here, I'm coming to get some more informations.

The case I've found is: when an action has been initially imported via a schemas file, which was the N-A historical import/export format, then only the fields which have been modified after this initial import are actually stored as GConf values under /apps. Unmodified fields are only stored as default values of schemas.
But: these actions are actually found by N-A, and NACT tries to display them. One can verify this because there is several (blank) lines in the left list, and one is able to go up/down..

I will of course fix this bug, but I'm not sure it is the one you have found ?

@Doug: sorry, I'm not able to reproduce the case you describe. All valid actions I create/modify under NACT are displayed in Nautilus context menu. See http://bugzilla-attachments.gnome.org/attachment.cgi?id=157723 for a screenshot.
It may help you provide a "gconftool-2 --dump /apps/nautilus-actions" dump of your configuration in order to debug this issue.

Are you conscious that only 'valid' actions can be candidate to be displayed in the Nautilus context menu ? This means there is a non empty label, and at least one valid profile. A valid profile must have an existing command addressed by a full path.

@Sebastian: there is nothing like a custom "Selecting the target folder" dialog. This is the standard GtkFileChooser class. See http://git.gnome.org/browse/nautilus-actions/tree/src/nact/nact-assistant-export.c.

Regards
Pierre

Doug McMahon (mc3man) wrote :

>It may help you provide a "gconftool-2 --dump /apps/nautilus-actions"

I'm not on lucid atm, will do that later (and may set up a fresh beta2 install

One thing that's bothered me and can't find a screen of of the config tool in use -

is it intended that all the created actions be displayed in red?
(generally red has a negative 'feel' to me

Doug McMahon (mc3man) wrote :

created 4 very simple actions - nothing appears in the context menu
I think I'll try a fresh install ( this is an alpha 1 updated) - noticed 2 comments here that while they alluded to issues with na, didn't indicate that it wasn't working itself
http://ubuntuforums.org/showthread.php?t=1443827

attached the dump (i hope

Steffen Goetz (steffengoetz) wrote :

Hi,
after importing my old actions from my karmic box the actions did not show up in the context menu at first. I had to edit the command of every action to include the full path of the command. After that all works well :-)
It seems that earlier versions of nautilus actions could determine the command paths by itself.

Sense Egbert Hofstede (sense) wrote :

I can confirm that inserting the whole path in the command box does make the action show up. Most people seem to only enter the command, which doesn't make nautilus-actions-config-tool complain, but does make the action not show up.

summary: - Nautilus Actions don't show up in Nautilus right-click menu as they do
- on Karmic
+ Nautilus Actions don't show up in Nautilus right-click menu if the
+ command is not a full path
Changed in nautilus-actions (Ubuntu):
importance: Medium → Wishlist
Doug McMahon (mc3man) wrote :

> "that inserting the whole path in the command box does make the action show up"
same here - all works fine now (and actions are no longer displayed in red

Mike Durham (mdurhamesq) wrote :

> "that inserting the whole path in the command box does make the action show up"

I tried the whole path but preceding it with gksu /usr/bin/nautilus (say) it still doesn't work. A command without the gksu will work. Why TF has it been changed?
Mike

No need to be disrespectful. Probably adding the path to gksu is also necessary, though I couldn't explain why the chance occured.

Mike Durham (mdurhamesq) wrote :

Thanks José Alburquerque, no disrespect intended. As you suggested, putting the full path to gksu makes it work.
Cheers, Mike

Mike Durham (mdurhamesq) wrote :

I should have added that the --path=%M (or any --path=) doesn't work or should I file another bug for that?
Cheers, Mike

Changed in nautilus-actions:
status: Unknown → Fix Released
Didier Roche (didrocks) on 2010-04-19
Changed in nautilus-actions (Ubuntu):
assignee: nobody → Didier Roche (didrocks)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nautilus-actions - 2.30.2-0ubuntu1

---------------
nautilus-actions (2.30.2-0ubuntu1) lucid; urgency=low

  * New upstream release:
    - Fix #615646 reported by Deji Akingunola
      (Nautilus crashes when trash icon is right-clicked)
    - Fix GLib assertions when parsing parameters, using null values
    - Duplicate the profile attached to the Nautilus menu item, rather than
      adding a new reference; then do not try to unref its parent
    - Increment the reference count of the returned GFile location, so that
      it may be safely unreffed when parsing profile parameters
    - Fix incorrect plugins log domains
    - Implement more of the future .desktop files.
    - Refactor NAIContextual class as NAIContext.
    - DBus interface na_tracker_dbus_get_selected_paths() now brings up
      both the URI and the Nautilus mimetype of selected items to the caller.
    - Slightly relax the validity rules of a profile, so that already
      existing actions may be still considered as valid, even when
      commands do not use an absolute path. (LP: #488612)
      (Nautilus Actions' actions don't show up in context menus)
    - Current position and folder of icons chooser dialog are now saved.
    - Fix #614595 reported by Sense Hofstede
      (Not all icons displayed in the nautilus-actions-config-tool)
      (LP: #551479)
    - Do not prevent the export assistant to actually export items
    - Do not let a user untoggle a sort button
    - Do not mark the main window modified when first loading an empty set
    - Folders are definitively a list of paths
    - Also load items which are only described via their schemas
    - Only set defaults on non yet allocated data
    - Parent is not always an action, may be a menu
    - Also delete embedded schema names from GConf entries
    - Monitors GConf schemas
    - No more use GTK_WIDGET_IS_SENSITIVE macro after Gtk 2.20
    - Menu plugin is renamed as libnautilus-actions-menu.so
    - Updated translation
 -- Didier Roche <email address hidden> Mon, 19 Apr 2010 10:35:51 +0200

Changed in nautilus-actions (Ubuntu):
status: Triaged → Fix Released
X I (xandrani) wrote :

This still doesn't work.

The current problem with the product is that there is no help with the application, but even worse is that problems aren't reported to the user, i.e. when I add an action I don't know if it's something I've done wrong or a bug with the application. Feedback to users is imperative for a good product. Currently even if this application is hypothetically functional, without feedback I am left guessing what is wrong!

This would be like trying to save a file to a directory in a text editor, and nothing happening with no error message, when say for example your current username doesn't have access to this directory. This would make the product very unusable, as users wouldn't know if the file had been saved without checking directly, and also they wouldn't initially know why it hadn't been saved.

(also note I tried reporting a bug from the developers website but there was an error - the broken link is: http://bugzilla.gnome.org/simple-bug-guide.cgi?product=nautilus-actions, it should probably be https://bugzilla.gnome.org/enter_bug.cgi?product=nautilus-actions).

X I (xandrani) wrote :

Note that importing menu actions that people have already tested, fail on the latest version, e.g.: http://www.grumz.net/?q=node/205

And yes I've put the full paths where relevant.

Not being rude but was the product tested? Maybe some unit tests (at least testing of the examples listed on grumz.net) would have been useful. Testing is your friend :)

Changed in nautilus-actions:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.