Activity log for bug #1189647

Date Who What changed Old value New value Message
2013-06-10 21:53:01 Jamie Strandboge bug added bug
2013-06-10 22:01:18 Jamie Strandboge description [Impact] * the check-rpc and check-nfs commands are broken in nagios-plugins on 12.04 because the path to rpcinfo is not correct. Once the package is installed, you must adjust /usr/lib/nagios/plugins/utils.pm to use the correct path, but this is overwritten on upgrades [Test Case] $ apt-get install nagios-plugins-basic rpcbind With old version: $ /usr/lib/nagios/plugins/check_rpc -H '127.0.0.1' -C portmap Can't fork for rpcinfo: No such file or directory With new version and corrected path: $ /usr/lib/nagios/plugins/check_rpc -H '127.0.0.1' -C portmap OK: RPC program portmap version 2 version 3 version 4 udp running [Regression Potential] * The regression potential is very low-- there are no code changes and the only change is adjusted the path to a binary. The path is currently wrong so functionality cannot regress on this point. [Impact]  * the check-rpc and check-nfs commands are broken in nagios-plugins on 12.04 because the path to rpcinfo is not correct. Once the package is installed, you must adjust /usr/lib/nagios/plugins/utils.pm to use the correct path, but this is overwritten on upgrades [Test Case] $ sudo apt-get install nagios-plugins-standard rpcbind With old version: $ /usr/lib/nagios/plugins/check_rpc -H '127.0.0.1' -C portmap Can't fork for rpcinfo: No such file or directory With new version and corrected path: $ /usr/lib/nagios/plugins/check_rpc -H '127.0.0.1' -C portmap OK: RPC program portmap version 2 version 3 version 4 udp running [Regression Potential]  * The regression potential is very low-- there are no code changes and the only change is adjusted the path to a binary. The path is currently wrong so functionality cannot regress on this point. [Other Info] * this is already fixed in Ubuntu 13.10
2013-06-10 22:03:29 Jamie Strandboge nominated for series Ubuntu Precise
2013-06-10 22:03:29 Jamie Strandboge bug task added nagios-plugins (Ubuntu Precise)
2013-06-10 22:03:29 Jamie Strandboge nominated for series Ubuntu Saucy
2013-06-10 22:03:29 Jamie Strandboge bug task added nagios-plugins (Ubuntu Saucy)
2013-06-10 22:04:33 Jamie Strandboge nagios-plugins (Ubuntu Saucy): status New Fix Released
2013-06-10 22:08:22 Jamie Strandboge nagios-plugins (Ubuntu Precise): status New In Progress
2013-06-10 22:08:25 Jamie Strandboge nagios-plugins (Ubuntu Precise): assignee Jamie Strandboge (jdstrand)
2013-06-10 22:10:29 Jamie Strandboge description [Impact]  * the check-rpc and check-nfs commands are broken in nagios-plugins on 12.04 because the path to rpcinfo is not correct. Once the package is installed, you must adjust /usr/lib/nagios/plugins/utils.pm to use the correct path, but this is overwritten on upgrades [Test Case] $ sudo apt-get install nagios-plugins-standard rpcbind With old version: $ /usr/lib/nagios/plugins/check_rpc -H '127.0.0.1' -C portmap Can't fork for rpcinfo: No such file or directory With new version and corrected path: $ /usr/lib/nagios/plugins/check_rpc -H '127.0.0.1' -C portmap OK: RPC program portmap version 2 version 3 version 4 udp running [Regression Potential]  * The regression potential is very low-- there are no code changes and the only change is adjusted the path to a binary. The path is currently wrong so functionality cannot regress on this point. [Other Info] * this is already fixed in Ubuntu 13.10 [Impact]  * the check-rpc and check-nfs commands are broken in nagios-plugins on 12.04 because the path to rpcinfo is not correct. Once the package is installed, you must adjust /usr/lib/nagios/plugins/utils.pm to use the correct path, but this is overwritten on upgrades [Test Case] $ sudo apt-get install nagios-plugins-standard rpcbind With old version: $ /usr/lib/nagios/plugins/check_rpc -H '127.0.0.1' -C portmap Can't fork for rpcinfo: No such file or directory With new version and corrected path: $ /usr/lib/nagios/plugins/check_rpc -H '127.0.0.1' -C portmap OK: RPC program portmap version 2 version 3 version 4 udp running [Regression Potential]  * The regression potential is very low-- there are no code changes and the only change is adjusting the path to a binary. The path is currently wrong so functionality cannot regress on this point. [Other Info]  * this is already fixed in Ubuntu 13.10
2013-06-10 22:11:48 Jamie Strandboge attachment added nagios-plugins_1.4.15-5ubuntu3.2.debdiff https://bugs.launchpad.net/ubuntu/+source/nagios-plugins/+bug/1189647/+attachment/3700195/+files/nagios-plugins_1.4.15-5ubuntu3.2.debdiff
2013-06-10 22:14:06 Jamie Strandboge bug added subscriber Ubuntu Stable Release Updates Team
2013-06-17 21:39:43 Jamie Strandboge description [Impact]  * the check-rpc and check-nfs commands are broken in nagios-plugins on 12.04 because the path to rpcinfo is not correct. Once the package is installed, you must adjust /usr/lib/nagios/plugins/utils.pm to use the correct path, but this is overwritten on upgrades [Test Case] $ sudo apt-get install nagios-plugins-standard rpcbind With old version: $ /usr/lib/nagios/plugins/check_rpc -H '127.0.0.1' -C portmap Can't fork for rpcinfo: No such file or directory With new version and corrected path: $ /usr/lib/nagios/plugins/check_rpc -H '127.0.0.1' -C portmap OK: RPC program portmap version 2 version 3 version 4 udp running [Regression Potential]  * The regression potential is very low-- there are no code changes and the only change is adjusting the path to a binary. The path is currently wrong so functionality cannot regress on this point. [Other Info]  * this is already fixed in Ubuntu 13.10 [Impact]  * the check-rpc and check-nfs commands are broken in nagios-plugins on 12.04 because the path to rpcinfo is not correct. Once the package is installed, you must adjust /usr/lib/nagios/plugins/utils.pm to use the correct path, but this is overwritten on upgrades [Test Case] $ sudo apt-get install nagios-plugins-standard rpcbind With old version: $ /usr/lib/nagios/plugins/check_rpc -H '127.0.0.1' -C portmap Can't fork for rpcinfo: No such file or directory With new version and corrected path: $ /usr/lib/nagios/plugins/check_rpc -H '127.0.0.1' -C portmap OK: RPC program portmap version 2 version 3 version 4 udp running [Regression Potential]  * The regression potential is very low-- there are no code changes and the only change is adjusting the path to a binary. The path is currently wrong so functionality cannot regress on this point. [Other Info]  * this is already fixed in Ubuntu 13.10 * Note: the nagios server needs to be restarted (a reload is not enough) for this change to take effect within a configured nagios itself
2013-06-17 21:41:25 Jamie Strandboge description [Impact]  * the check-rpc and check-nfs commands are broken in nagios-plugins on 12.04 because the path to rpcinfo is not correct. Once the package is installed, you must adjust /usr/lib/nagios/plugins/utils.pm to use the correct path, but this is overwritten on upgrades [Test Case] $ sudo apt-get install nagios-plugins-standard rpcbind With old version: $ /usr/lib/nagios/plugins/check_rpc -H '127.0.0.1' -C portmap Can't fork for rpcinfo: No such file or directory With new version and corrected path: $ /usr/lib/nagios/plugins/check_rpc -H '127.0.0.1' -C portmap OK: RPC program portmap version 2 version 3 version 4 udp running [Regression Potential]  * The regression potential is very low-- there are no code changes and the only change is adjusting the path to a binary. The path is currently wrong so functionality cannot regress on this point. [Other Info]  * this is already fixed in Ubuntu 13.10 * Note: the nagios server needs to be restarted (a reload is not enough) for this change to take effect within a configured nagios itself [Impact]  * the check-rpc and check-nfs commands are broken in nagios-plugins on 12.04 because the path to rpcinfo is not correct. Once the package is installed, you must adjust /usr/lib/nagios/plugins/utils.pm to use the correct path, but this is overwritten on upgrades [Test Case] $ sudo apt-get install nagios-plugins-standard rpcbind With old version: $ /usr/lib/nagios/plugins/check_rpc -H '127.0.0.1' -C portmap Can't fork for rpcinfo: No such file or directory With new version and corrected path: $ /usr/lib/nagios/plugins/check_rpc -H '127.0.0.1' -C portmap OK: RPC program portmap version 2 version 3 version 4 udp running [Regression Potential]  * The regression potential is very low-- there are no code changes and the only change is adjusting the path to a binary. The path is currently wrong so functionality cannot regress on this point. [Other Info]  * this is already fixed in Ubuntu 13.10  * Note: the nagios server needs to be restarted (a reload is not enough) for this change to take effect with a configured nagios server
2013-07-05 08:18:49 Colin Watson nagios-plugins (Ubuntu Precise): status In Progress Fix Committed
2013-07-05 08:18:52 Colin Watson bug added subscriber SRU Verification
2013-07-05 08:19:02 Colin Watson tags verification-needed
2013-07-05 08:39:12 Launchpad Janitor branch linked lp:ubuntu/precise-proposed/nagios-plugins
2013-07-05 14:13:38 Jamie Strandboge tags verification-needed verification-done
2013-07-15 14:44:59 Launchpad Janitor nagios-plugins (Ubuntu Precise): status Fix Committed Fix Released
2013-07-15 14:45:05 Colin Watson removed subscriber Ubuntu Stable Release Updates Team