check_ntp_time sometimes report Offset unknown

Bug #1010110 reported by Dominique Potvin
46
This bug affects 7 people
Affects Status Importance Assigned to Milestone
nagios-plugins (Ubuntu)
Undecided
Unassigned
Hardy
Undecided
Stéphane Graber

Bug Description

[Impact]
Sometimes the output from check_ntp_time is "Offset unknown" while the ntp server is fine.

It can stay like that for a while and then comes back to normal.

Here's a sample output while the problem was present on the server:

[Test Case]
Install nagios and wait for the check to fail. when it fails, run the commands manually.

root@server:~# /usr/lib/nagios/plugins/check_ntp_time -H 0.ca.pool.ntp.org
NTP CRITICAL: Offset unknown|

root@server:~# ntpdate -q 0.ca.pool.ntp.org
server 24.37.24.30, stratum 3, offset -0.006237, delay 0.16121
server 72.38.129.202, stratum 2, offset 0.022085, delay 0.05280
server 208.80.96.96, stratum 3, offset 0.030917, delay 0.05905

Install the patched version and notice that the check works now.

[Regression Potential]

Unlikely, the check_ntp_time is now the same as the version in 10.04 which works correctly.

Revision history for this message
Dominique Potvin (dominique-potvin) wrote :

This is happening on hardy and not lucid:

root@server:~# lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 8.04.4 LTS
Release: 8.04
Codename: hardy

root@server:~# dpkg -l|grep nagios-plugins
ii nagios-plugins-basic 1.4.11-1ubuntu5 Plugins for the nagios network monitoring an

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nagios-plugins (Ubuntu):
status: New → Confirmed
Revision history for this message
Marc Gariépy (mgariepy) wrote :
Changed in nagios-plugins (Ubuntu):
status: Confirmed → Fix Released
Changed in nagios-plugins (Ubuntu Hardy):
status: New → In Progress
Marc Gariépy (mgariepy)
description: updated
Revision history for this message
Marc Gariépy (mgariepy) wrote :
Changed in nagios-plugins (Ubuntu Hardy):
assignee: nobody → Stéphane Graber (stgraber)
Revision history for this message
Clint Byrum (clint-fewbar) wrote : Please test proposed package

Hello Dominique, or anyone else affected,

Accepted nagios-plugins into hardy-proposed. The package will build now and be available in a few hours. Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users. If this package fixes the bug for you please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case details of your testing will help us make a better decision. Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in nagios-plugins (Ubuntu Hardy):
status: In Progress → Fix Committed
tags: added: verification-needed
Revision history for this message
Maxime Ménard-Leroux (mmleroux) wrote :

The proposed package for nagios-plugins-basic seems to fix the issue.

The issue comes up usually every hour on hardy hosts. But on the patched host, no nagios alerts for NTP since the proposed package was installed.

Revision history for this message
Stéphane Graber (stgraber) wrote :

Thanks Maxime. Marking verfication-done based on that comment.

tags: added: verification-done
removed: verification-needed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nagios-plugins - 1.4.11-1ubuntu5.1

---------------
nagios-plugins (1.4.11-1ubuntu5.1) hardy-proposed; urgency=low

  * Fix bugs and flaws in best offset server selection of check_ntp_time
    (LP: #1010110)
 -- Marc Gariepy <email address hidden> Tue, 05 Jun 2012 13:08:34 -0400

Changed in nagios-plugins (Ubuntu Hardy):
status: Fix Committed → Fix Released
Revision history for this message
Jon Henry (jon.henry) wrote :

I am experiencing what I think is the same bug on lucid 10.04.4. About once per hour, check_ntp_time reports "Offset unknown" causing Nagios to alarm, only to fix itself a short while later. Please let me know if I can provide any more details, or if I should open this as a new bug report.

lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 10.04.4 LTS
Release: 10.04
Codename: lucid

uname -a
Linux redacted 2.6.32-42-server #95-Ubuntu SMP Wed Jul 25 16:10:49 UTC 2012 x86_64 GNU/Linux

date && /usr/lib/nagios/plugins/check_ntp_time -H local_ntp_server
Tue Aug 21 11:28:54 MDT 2012
NTP CRITICAL: Offset unknown|

date && /usr/lib/nagios/plugins/check_ntp_time -H local_ntp_server
Tue Aug 21 11:32:35 MDT 2012
NTP OK: Offset 0.006026506424 secs|offset=0.006027s;60.000000;120.000000;

dpkg -l nagios-plugins
ii nagios-plugins 1.4.14-1ubuntu1 Plugins for the nagios network monitoring and management system

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers