18.04 package varnish_check version checks for LIBVARNISHAPI_1.0

Bug #1937239 reported by Richard
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
nagios-plugins-contrib (Debian)
New
Undecided
Unassigned
nagios-plugins-contrib (Ubuntu)
Fix Committed
Undecided
Jan Wagner

Bug Description

The nagios-plugins-contrib doesn't install the varnish_check dependency of the libvarnishapi1 package, however, even after manually installing this dependency (okay, manually ensuring this package is installed via Puppet) the file is checking for version LIBVARNISHAPI_1.0, but when you install the currently available libvarnishapi1 package the version in the header is LIBVARNISHAPI_2.0 and so this check fails.

Tags: 18.04
Richard (f-richaad-h)
tags: added: 18.04
Revision history for this message
Jan Wagner (waja) wrote :

the varnish plugin (and libs) are not reliable (and stable ABI wise) so it was droped from package in Debian (and so also in ubuntu if not anybody patches the ubuntu package to ship it anyways).

Changed in nagios-plugins-contrib (Ubuntu):
assignee: nobody → Jan Wagner (waja)
status: New → Fix Committed
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers