Ubuntu

Activity log for bug #896388

Date Who What changed Old value New value Message
2011-11-25 19:41:08 nutznboltz bug added bug
2011-11-25 19:46:59 nutznboltz description After LP: #600941 was pushed out all of our systems started experiencing Nagios nrpe restart failures. Commands like /etc/init.d/nagios-nrpe-server restart would cause nrpe to stop but not restart. I tracked this down to the way that the /etc/init.d/nagios-nrpe-server script is calling start-stop-daemon. The issue is that the "stop" stanza in the /etc/init.d/nagios-nrpe-server script first calls start-stop-daemon which sends SIGTERM to nrpe and then waits only for one second. If nrpe has not exited by that time the pid file will still exist and the /etc/init.d/nagios-nrpe-server script will remove it. Worse if /etc/init.d/nagios-nrpe-server restart is used not only will the pid file be removed, the attempt to restart nrpe will fail provided that the nrpe daemon is still tardy in shutting down. The attempt to start under those circumstances will fail because nrpe will still be bound to a socket and the second attempt at binding will cause the nrpe startup to abort. They should have wondered why there was a comment about "sometimes the pid file does not get removed". They should have tested on systems that have a heavy load and therefore slow nrpe response times. The fix is to add --retry 10 or such to the invocation of start-stop-daemon ... --stop ... Patch forthcoming, see http://askubuntu.com/questions/82631/what-is-the-way-to-submit-a-patch-to-fix-all-the-damage-that-lp-600941-causes ProblemType: Bug DistroRelease: Ubuntu 12.04 Package: nagios-nrpe-server (not installed) ProcVersionSignature: Ubuntu 3.2.0-1.3-generic 3.2.0-rc2 Uname: Linux 3.2.0-1-generic i686 ApportVersion: 1.90-0ubuntu1 Architecture: i386 Date: Fri Nov 25 14:38:05 2011 InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release i386 (20111011) ProcEnviron: PATH=(custom, no user) LANG=en_US.UTF-8 SHELL=/bin/bash SourcePackage: nagios-nrpe UpgradeStatus: No upgrade log present (probably fresh install) After LP: #600941 was pushed out all of our systems started experiencing Nagios nrpe restart failures. Commands like /etc/init.d/nagios-nrpe-server restart would cause nrpe to stop but not restart. I tracked this down to the way that the /etc/init.d/nagios-nrpe-server script is calling start-stop-daemon. The issue is that the "stop" stanza in the /etc/init.d/nagios-nrpe-server script first calls start-stop-daemon which sends SIGTERM to nrpe and then waits only for one second. If nrpe has not exited by that time the pid file will still exist and the /etc/init.d/nagios-nrpe-server script will remove it. Worse if /etc/init.d/nagios-nrpe-server restart is used not only will the pid file be removed, the attempt to restart nrpe will fail provided that the nrpe daemon is still tardy in shutting down. The attempt to start under those circumstances will fail because nrpe will still be bound to a socket and the second attempt at binding will cause the nrpe startup to abort. They should have wondered why there was a comment about "sometimes the pid file does not get removed". They should have tested on systems that have a heavy load and therefore slow nrpe response times. The fix is to add --retry 10 or such to the invocation of start-stop-daemon ... --stop ... Patch forthcoming, see http://askubuntu.com/questions/82631/what-is-the-way-to-submit-a-patch-to-fix-all-the-damage-that-lp-600941-causes See also https://launchpad.net/~nutznboltz/+archive/nrpe-unbreak-lp-600941 ProblemType: Bug DistroRelease: Ubuntu 12.04 Package: nagios-nrpe-server (not installed) ProcVersionSignature: Ubuntu 3.2.0-1.3-generic 3.2.0-rc2 Uname: Linux 3.2.0-1-generic i686 ApportVersion: 1.90-0ubuntu1 Architecture: i386 Date: Fri Nov 25 14:38:05 2011 InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release i386 (20111011) ProcEnviron:  PATH=(custom, no user)  LANG=en_US.UTF-8  SHELL=/bin/bash SourcePackage: nagios-nrpe UpgradeStatus: No upgrade log present (probably fresh install)
2011-11-25 19:55:24 Launchpad Janitor branch linked lp:~nutznboltz/ubuntu/precise/nagios-nrpe/fix-lp896388
2011-11-25 20:26:29 Stéphane Graber nagios-nrpe (Ubuntu): importance Undecided Medium
2011-11-25 20:26:31 Stéphane Graber nagios-nrpe (Ubuntu): assignee Stéphane Graber (stgraber)
2011-11-25 20:27:55 Stéphane Graber nominated for series Ubuntu Lucid
2011-11-25 20:27:55 Stéphane Graber bug task added nagios-nrpe (Ubuntu Lucid)
2011-11-25 20:27:55 Stéphane Graber nominated for series Ubuntu Maverick
2011-11-25 20:27:55 Stéphane Graber bug task added nagios-nrpe (Ubuntu Maverick)
2011-11-25 20:27:55 Stéphane Graber nominated for series Ubuntu Natty
2011-11-25 20:27:55 Stéphane Graber bug task added nagios-nrpe (Ubuntu Natty)
2011-11-25 20:27:55 Stéphane Graber nominated for series Ubuntu Precise
2011-11-25 20:27:55 Stéphane Graber bug task added nagios-nrpe (Ubuntu Precise)
2011-11-25 20:27:55 Stéphane Graber nominated for series Ubuntu Hardy
2011-11-25 20:27:55 Stéphane Graber bug task added nagios-nrpe (Ubuntu Hardy)
2011-11-25 20:27:55 Stéphane Graber nominated for series Ubuntu Oneiric
2011-11-25 20:27:55 Stéphane Graber bug task added nagios-nrpe (Ubuntu Oneiric)
2011-11-25 22:27:38 Clint Byrum tags apport-bug i386 precise running-unity apport-bug i386 precise regression-update running-unity
2011-11-29 23:42:29 Clint Byrum summary Fix Regression Caused by LP: #600941 restart broken - Regression Caused by LP: #600941
2011-11-29 23:50:39 Clint Byrum bug watch added http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=650464
2011-11-29 23:50:39 Clint Byrum bug task added nagios-nrpe (Debian)
2011-12-02 09:58:20 Bug Watch Updater nagios-nrpe (Debian): status Unknown New
2011-12-31 00:35:03 James Troup bug added subscriber The Canonical Sysadmins
2011-12-31 00:35:23 Launchpad Janitor nagios-nrpe (Ubuntu): status New Confirmed
2011-12-31 00:35:23 Launchpad Janitor nagios-nrpe (Ubuntu Lucid): status New Confirmed
2011-12-31 00:35:23 Launchpad Janitor nagios-nrpe (Ubuntu Maverick): status New Confirmed
2011-12-31 00:35:23 Launchpad Janitor nagios-nrpe (Ubuntu Natty): status New Confirmed
2011-12-31 00:35:23 Launchpad Janitor nagios-nrpe (Ubuntu Oneiric): status New Confirmed
2011-12-31 00:35:23 Launchpad Janitor nagios-nrpe (Ubuntu Hardy): status New Confirmed
2012-04-09 21:34:22 Paul Paradise bug added subscriber Paul Paradise
2012-05-01 09:09:37 Bug Watch Updater nagios-nrpe (Debian): status New Fix Released
2012-05-03 10:02:36 Dimitri John Ledkov nominated for series Ubuntu Quantal
2012-05-03 10:12:18 Launchpad Janitor branch linked lp:~dmitrij.ledkov/ubuntu/quantal/nagios-nrpe/merge
2012-05-03 13:35:47 Stéphane Graber bug task added nagios-nrpe (Ubuntu Quantal)
2012-05-03 13:36:01 Stéphane Graber nagios-nrpe (Ubuntu Maverick): status Confirmed Won't Fix
2012-05-03 13:57:19 Stéphane Graber nagios-nrpe (Ubuntu Hardy): assignee Stéphane Graber (stgraber)
2012-05-03 13:57:22 Stéphane Graber nagios-nrpe (Ubuntu Lucid): assignee Stéphane Graber (stgraber)
2012-05-03 13:57:25 Stéphane Graber nagios-nrpe (Ubuntu Natty): assignee Stéphane Graber (stgraber)
2012-05-03 13:57:27 Stéphane Graber nagios-nrpe (Ubuntu Oneiric): assignee Stéphane Graber (stgraber)
2012-05-03 13:57:30 Stéphane Graber nagios-nrpe (Ubuntu Hardy): status Confirmed In Progress
2012-05-03 13:57:32 Stéphane Graber nagios-nrpe (Ubuntu Lucid): status Confirmed In Progress
2012-05-03 13:57:34 Stéphane Graber nagios-nrpe (Ubuntu Natty): status Confirmed In Progress
2012-05-03 13:57:38 Stéphane Graber nagios-nrpe (Ubuntu Oneiric): status Confirmed In Progress
2012-05-03 13:57:41 Stéphane Graber nagios-nrpe (Ubuntu Precise): status Confirmed In Progress
2012-05-03 14:00:12 Launchpad Janitor nagios-nrpe (Ubuntu Quantal): status Confirmed Fix Released
2012-05-03 14:15:50 Stéphane Graber nagios-nrpe (Ubuntu Precise): status In Progress Fix Committed
2012-05-03 14:15:53 Stéphane Graber nagios-nrpe (Ubuntu Oneiric): status In Progress Fix Committed
2012-05-03 14:17:30 Stéphane Graber nagios-nrpe (Ubuntu Natty): status In Progress Fix Committed
2012-05-03 14:19:08 Stéphane Graber nagios-nrpe (Ubuntu Lucid): status In Progress Fix Committed
2012-05-03 14:22:23 Stéphane Graber nagios-nrpe (Ubuntu Hardy): status In Progress Fix Committed
2012-05-03 15:35:18 Martin Pitt bug added subscriber Ubuntu Stable Release Updates Team
2012-05-03 15:35:20 Martin Pitt bug added subscriber SRU Verification
2012-05-03 15:35:23 Martin Pitt tags apport-bug i386 precise regression-update running-unity apport-bug i386 precise regression-update running-unity verification-needed
2012-05-05 15:52:17 Launchpad Janitor branch linked lp:ubuntu/hardy-proposed/nagios-nrpe
2012-05-05 15:52:20 Launchpad Janitor branch linked lp:ubuntu/natty-proposed/nagios-nrpe
2012-05-05 15:52:22 Launchpad Janitor branch linked lp:ubuntu/lucid-proposed/nagios-nrpe
2012-05-05 15:52:25 Launchpad Janitor branch linked lp:ubuntu/precise-proposed/nagios-nrpe
2012-05-05 15:52:27 Launchpad Janitor branch linked lp:ubuntu/oneiric-proposed/nagios-nrpe
2012-05-21 03:38:12 Stéphane Graber tags apport-bug i386 precise regression-update running-unity verification-needed apport-bug i386 precise regression-update running-unity verification-done
2012-05-21 06:41:09 Launchpad Janitor nagios-nrpe (Ubuntu Hardy): status Fix Committed Fix Released
2012-05-21 06:41:14 Launchpad Janitor nagios-nrpe (Ubuntu Lucid): status Fix Committed Fix Released
2012-05-21 06:41:20 Launchpad Janitor nagios-nrpe (Ubuntu Precise): status Fix Committed Fix Released
2012-05-21 06:41:43 Martin Pitt tags apport-bug i386 precise regression-update running-unity verification-done apport-bug i386 precise regression-update running-unity verification-needed
2012-05-22 16:06:50 Stéphane Graber tags apport-bug i386 precise regression-update running-unity verification-needed apport-bug i386 precise regression-update running-unity verification-done
2012-05-22 21:43:10 Launchpad Janitor nagios-nrpe (Ubuntu Natty): status Fix Committed Fix Released
2012-05-22 21:43:14 Launchpad Janitor nagios-nrpe (Ubuntu Oneiric): status Fix Committed Fix Released