Asked to upgrade database right after install

Bug #944128 reported by Mario Limonciello on 2012-03-01
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
mythtv (Ubuntu)
Undecided
Thomas Mashos

Bug Description

beta1 candidate image.

I noticed it's asking me to upgrade the database as soon as the first boot comes up. This was because we transitioned to 0.25 but didn't update the base database file.

This should be fixed so first boot has mythfrontend, no warnings/errors.

Related branches

Mario Limonciello (superm1) wrote :
Changed in mythtv (Ubuntu):
status: New → Confirmed
assignee: nobody → Mario Limonciello (superm1)
milestone: none → ubuntu-12.04-beta-2
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/944128

tags: added: iso-testing
Changed in mythtv (Ubuntu):
assignee: Mario Limonciello (superm1) → Thomas Mashos (tgm4883)
Launchpad Janitor (janitor) wrote :
Download full text (13.2 KiB)

This bug was fixed in the package mythtv - 2:0.25.0~master.20120316.53761e2-0ubuntu1

---------------
mythtv (2:0.25.0~master.20120316.53761e2-0ubuntu1) precise; urgency=low

  [ Thomas Mashos ]
  * Updated DB schema for standard plugins (LP: #944128)

  [ Mario Limonciello ]
  * Remove references to mythmessage.
  * Fix permissions on all existing log files on upgrade.
  * New upstream checkout (53761e2)
  * >>Upstream changes since last upload (6519666):
  * [53761e2] Use toLocal8Bit() for loading mysql.txt.
  * [c3b022a] Don't display frontend status box log viewer button
  * [8284bb7] Mention the detected character encoding
  * [fa639a7] Make users have to figure out if their video works
  * [5fb541e] Update Youtube player API to v3.
  * [2ce3690] Identify DVD commentary tracks in the Audio track
    selection dialog.
  * [cbd9703] Prevent showing 0x0 artwork when a recording doesn't have
    Seas/Ep.
  * [9c4e7fd] Slight mod on [be81782c0] (function names).
  * [187e37d] Close DB connections before running jobs.
  * [be81782] Make sure we cleanup DB connections before thread exit
    (non-MThread).
  * [201c153] Missed a change from 1a651934c
  * [9b6cdba] Rename 'file browse mode' to try and discourage it's use.
    Browsing the database is now 'Browse Library (recommended) and what
    was called file browse is now 'Browse Filesystem (slow)'
  * [9e80861] Rename 'Enable/Disable Flat view' in the video browser to
    'Show/Hide Directory Structure' to try and reduce the confusion this
    mode currently causes.
  * [1a65193] Only display the standby screen if the master backend is
    configured to shut down when idle. We can assume that if the user
    hasn't configured their backend to shut down then they don't care to
    know that the frontends are idle.
  * [15a85ec] Call DestoyMythMainWindow() before exit, even on error
    exits.
  * [d3b4762] Subtitles: Try to reenable the previously selected caption
    type.
  * [20a5628] Don't increment the number of channels returned by
    libdvdnav. This was causing 5.1 audio to be wrongly identified as 7
    channel, and stereo as 3 channel.
  * [c61bb1e] Add debugging for the DVD audio language extension code
    which may prove useful in the future.
  * [f8d2de0] Fully clear the audio ringbuffer when using AC3 re-encoder
  * [f6a8650] Partially revert 5dccbd5f6b3019a67ecc69213ee405bba4b30994
  * [cc2ad7f] Revert "Fix potential leak"
  * [3e26728] Merge branch 'master' of github.com:MythTV/mythtv
  * [684272a] Fix the naming of some jumppoints.
  * [8acfc87] Fix mac compilation using Qt 4.8.0
  * [6ed2587] Allow more room for double-digit cardids in the
    MythCenter[-wide] and default[-wide] themes.
  * [f31d9a7] Fix potential leak
  * [fd36db9] Ignore DVD commentary and AD tracks when auto-selecting
    the audio track.
  * [3e4ec54] Merge branch 'master' of github.com:MythTV/mythtv
  * [5c1f50d] MythCenter-wide: Tidy up a few screen titles
  * [9b6e4e1] Remove MythMessage binary.
  * [1b29d50] MythCenter-wide: Tidy up the 'Custom Record Rules' screen
  * [f56bdfc] MythCenter-wide: Make the multi-line edit resizeable
  * [2b908b4] Squash a pesky compiler warning.
  * [c050aca] Remove ...

Changed in mythtv (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers