Ubuntu

mythfrontend.real crashed with SIGSEGV in AudioOutputBase::audioready()

Reported by MarcRandolph on 2011-12-28
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
MythTV
Unknown
Unknown
mythtv (Ubuntu)
Undecided
Unassigned

Bug Description

Can't recall for certain - think I just tried to start a video

ProblemType: Crash
DistroRelease: Ubuntu 10.04
Package: mythtv-frontend 2:0.24.1+fixes.20111117.f5fd11f-0ubuntu0mythbuntu1
ProcVersionSignature: Ubuntu 2.6.32-27.49-generic 2.6.32.26+drm33.12
Uname: Linux 2.6.32-27-generic i686
NonfreeKernelModules: nvidia
Architecture: i386
CrashCounter: 1
CrashDB: mythbuntu
Date: Tue Dec 27 17:59:26 2011
ExecutablePath: /usr/bin/mythfrontend.real
Installed_mythtv_dbg: 2:0.24.1+fixes.20111117.f5fd11f-0ubuntu0mythbuntu1
ProcCmdline: /usr/bin/mythfrontend.real --logfile /var/log/mythtv/mythfrontend.log
ProcCwd: /home/guest
ProcEnviron:
 LANG=en_US.utf8
 SHELL=/bin/bash
SegvAnalysis:
 Segfault happened at: 0x1a25e1e <_ZN15AudioOutputBase10audioreadyEv+14>: cmpb $0x0,0x7c(%ecx)
 PC (0x01a25e1e) ok
 source "$0x0" ok
 destination "0x7c(%ecx)" (0xa99f1084) not located in a known VMA region (needed writable region)!
SegvReason: writing unknown VMA
Signal: 11
SourcePackage: mythtv
StacktraceTop:
 AudioOutputBase::audioready (this=0xa99f1008) at audiooutputbase.cpp:765
 AudioOutputBase::Drain (this=0xa99f1008)
 AudioOutputPulseAudio::Drain (this=0xa99f1008)
 AudioPlayer::AddAudioData (this=0xad6785ac, buffer=0x0,
 AvFormatDecoder::ProcessAudioPacket (this=0xa954a800,
Title: mythfrontend.real crashed with SIGSEGV in AudioOutputBase::audioready()
UserGroups: adm admin audio cdrom dialout dip fax floppy fuse lpadmin plugdev sambashare scanner tape video

MarcRandolph (mrand) wrote :

StacktraceTop:
 ?? ()
 ?? ()
 ?? ()

Changed in mythtv (Ubuntu):
status: New → Invalid
Download full text (9.0 KiB)

Thank you for your report!

However, processing it in order to get sufficient information for the
developers failed (it does not generate an useful symbolic stack trace). This
might be caused by some outdated packages which were installed on your system
at the time of the report:

libqt4-designer version 4:4.6.2-0ubuntu5.1 required, but 4:4.6.2-0ubuntu5.3 is available
mythtv-frontend version 2:0.24.1+fixes.20111117.f5fd11f-0ubuntu0mythbuntu1 required, but 0.23.0+fixes24158-0ubuntu2 is available
libavahi-common3 version 0.6.25-1ubuntu6.1 required, but 0.6.25-1ubuntu6.2 is available
libqt4-webkit version 4:4.6.2-0ubuntu5.1 required, but 4:4.6.2-0ubuntu5.3 is available
libqtcore4 version 4:4.6.2-0ubuntu5.1 required, but 4:4.6.2-0ubuntu5.3 is available
mysql-common version 5.1.41-3ubuntu12.8 required, but 5.1.41-3ubuntu12.10 is available
libtiff4 version 3.9.2-2ubuntu0.3 required, but 3.9.2-2ubuntu0.7 is available
libpam0g version 1.1.1-2ubuntu5 required, but 1.1.1-2ubuntu5.4 is available
outdated debug symbol package for libusb-0.1-4: package version 2:0.1.12-14ubuntu0.2 dbgsym version 2:0.1.12-14
libgksu2-0 version 2.0.13~pre1-1ubuntu4.1 required, but 2.0.13~pre1-1ubuntu4.2 is available
sysv-rc version 2.87dsf-4ubuntu17 required, but 2.87dsf-4ubuntu17.4 is available
libsndfile1 version 1.0.21-2 required, but 1.0.21-2ubuntu0.10.04.1 is available
libpam-modules version 1.1.1-2ubuntu5 required, but 1.1.1-2ubuntu5.4 is available
libblkid1 version 2.17.2-0ubuntu1 required, but 2.17.2-0ubuntu1.10.04.2 is available
outdated debug symbol package for libblkid1: package version 2.17.2-0ubuntu1.10.04.2 dbgsym version 2.17.2-0ubuntu1
libdbus-glib-1-2 version 0.84-1 required, but 0.84-1ubuntu0.2 is available
libqt4-sql-mysql version 4:4.6.2-0ubuntu5.1 required, but 4:4.6.2-0ubuntu5.3 is available
libgtk2.0-0 version 2.20.1-0ubuntu2 required, but 2.20.1-0ubuntu2.1 is available
dbus version 1.2.16-2ubuntu4 required, but 1.2.16-2ubuntu4.3 is available
sysvinit-utils version 2.87dsf-4ubuntu17 required, but 2.87dsf-4ubuntu17.4 is available
outdated debug symbol package for libgcr0: package version 2.92.92.is.2.30.3-0ubuntu1.1 dbgsym version 2.92.92.is.2.30.0-0ubuntu3
libk5crypto3 version 1.8.1+dfsg-2ubuntu0.4 required, but 1.8.1+dfsg-2ubuntu0.10 is available
libpng12-0 version 1.2.42-1ubuntu2.1 required, but 1.2.42-1ubuntu2.2 is available
mysql-client-core-5.1 version 5.1.41-3ubuntu12.8 required, but 5.1.41-3ubuntu12.10 is available
outdated debug symbol package for mysql-client-core-5.1: package version 5.1.41-3ubuntu12.10 dbgsym version 5.1.41-3ubuntu12.7
libmysqlclient16 version 5.1.41-3ubuntu12.8 required, but 5.1.41-3ubuntu12.10 is available
outdated debug symbol package for libmysqlclient16: package version 5.1.41-3ubuntu12.10 dbgsym version 5.1.41-3ubuntu12.7
outdated debug symbol package for udev: package version 151-12.3 dbgsym version 151-12
libavahi-client3 version 0.6.25-1ubuntu6.1 required, but 0.6.25-1ubuntu6.2 is available
libqt4-dbus version 4:4.6.2-0ubuntu5.1 required, but 4:4.6.2-0ubuntu5.3 is available
libqt4-script version 4:4.6.2-0ubuntu5.1 required, but 4:4.6.2-0ubuntu5.3 is available
outdated debug symbol package for libglu1-mesa: package...

Read more...

tags: removed: need-i386-retrace
MarcRandolph (mrand) wrote :

Silly apport service

Changed in mythtv (Ubuntu):
status: Invalid → Triaged
MarcRandolph (mrand) on 2011-12-28
visibility: private → public
Changed in mythtv:
status: Unknown → New
Changed in mythtv:
status: New → Unknown
MarcRandolph (mrand) wrote :

Unfortunately the developer was not able to uncover any problems with the logs attached. If you are able to reproduce this again, please feel free to attach new crash logs here, or better yet, open a new ticket. If you can get it to crash upon demand, a proper crash dump captured with gdb would be appreciated.

Thank you for trying to help!

Changed in mythtv (Ubuntu):
status: Triaged → Incomplete
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.