Can't record analog TV with WinTV HVR-950Q

Bug #790099 reported by Steven Ourada on 2011-05-30
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
mythtv (Ubuntu)
Undecided
Unassigned

Bug Description

I was not able to record analog TV with the WinTV HVR-950Q with MythTV in Natty. The logs were not very helpful even with --setverbose all; the actual failure point is not logged.

In gdb, I narrowed the problem down to this: in NuppelVideoRecorder.cpp ( http://bazaar.launchpad.net/~ubuntu-branches/ubuntu/natty/mythtv/natty/view/head:/mythtv/libs/libmythtv/NuppelVideoRecorder.cpp ), StartVideoRecording was always failing at line 1076, because usingv4l2 is set and SetFormatV4L2 is a dummy function that always returns false. This is apparently because of the ifdefs related to V4L/V4L2.

I reworked the ifdefs a bit, mimicking what I saw for other V4L stuff, so that the SetFormatV4L2 and DoV4L2 functions were defined correctly. I left DoV4L and DoMJPEG hollowed out since they don't compile and I don't care about 'em.

After that, I was able to record analog through V4L in MythTV. Here are the main parameters I set in MythTV, just in case they aren't all obvious:
In mythtv-setup:
  Video device: /dev/video0
  Audio device: ALSA:hw:CARD=HVR950Q,DEV=0
  Force audio sampling rate: 48000
In mythfrontend, software encoders:
  Width: 720
  Height: 480
  Video codec: MPEG4
  Audio codec: MP3
  Sampling rate: 48000

Here's the patch from the original source to my modified version:
1141c1141
< #if defined(USING_V4L) || defined(USING_V4L2)
---
> #ifdef USING_V4L
1144d1143
< #ifdef USING_V4L
1327d1325
< #endif
1731d1728
< #ifdef USING_V4L
1864d1860
< #endif
1867c1863
< #else // USING_V4L || USING_V4L2
---
> #else // USING_V4L
1872c1868
< #endif // USING_V4L || USING_V4L2
---
> #endif // USING_V4L

Steven Ourada (s-ourada) wrote :

Ooops, looks like my diff was backwards. Here's a new try.

1141c1141
< #ifdef USING_V4L
---
> #if defined(USING_V4L) || defined(USING_V4L2)
1143a1144
> #ifdef USING_V4L
1325a1327
> #endif
1728a1731
> #ifdef USING_V4L
1860a1864
> #endif
1863c1867
< #else // USING_V4L
---
> #else // USING_V4L || USING_V4L2
1868c1872
< #endif // USING_V4L
---
> #endif // USING_V4L || USING_V4L2

Thomas Mashos (tgm4883) wrote :

Did you test this with a mythtv build that was after 5/31? There were some V4L2/V4L changes that needed to happen in the 0.24 builds on natty

Steven Ourada (s-ourada) wrote :

I just tried the PPA version (2:0.24.1+fixes.20110609.4dec7cf-0ubuntu0mythbuntu3) and it seems to work. I see that you removed the V4L2 patch from before, which seemed to be the cause of my problem.

Thanks, I'll run off the PPA version for now, then.

(I'm not very familiar with the Launchpad workflow. How do I indicate that I am happy now? Or do I leave it up to you all to change the status?)

Thomas Mashos (tgm4883) on 2011-06-10
Changed in mythtv (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions