[SRU] "Could not install the upgrades" - installArchives() failed

Bug #68400 reported by Paul Bell on 2006-10-26
22
Affects Status Importance Assigned to Milestone
mythtv (Ubuntu)
High
Mario Limonciello
Dapper
Undecided
Unassigned
Edgy
Undecided
Unassigned

Bug Description

Binary package hint: update-manager

Updating from Dapper 6.06 (kernel 2.6.15-27-amd64-k8) to Edgy 6.10 (kernel 2.6.17-10-generic), I received the following error...

-----8<-----

Could not install the upgrades

The upgrade aborts now. Your system could be in an unusable state. A
recovery was run (dpkg --configure -a).

Please report this bug against the 'update-manager' package and include
the files in /var/log/dist-upgrade/ in the bugreport.

installArchives() failed

-----8<-----

I rebooted without incident and the system appears fine.

Paul

Paul Bell (launchpad-dpb) wrote :

Attaching /var/log/dist-upgrade/*.log as requested.

Paul Bell (launchpad-dpb) wrote :
Paul Bell (launchpad-dpb) wrote :
description: updated

Here is what makes the upgrade fail:

Setting up mythtv-database (0.20-0.2ubuntu2) ...
Failed to connect to database: Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2) at -e line 5, <> line 1.
Failed to create database (incorrect admin username/password?)
If you supplied incorrect information, try:
dpkg-reconfigure --force mythtv-database
dpkg: error processing mythtv-database (--configure):
 subprocess post-installation script returned error exit status 1

Changed in mythtv:
importance: Undecided → High
status: Unconfirmed → Confirmed
Paul Bell (launchpad-dpb) wrote :

Hi Michael, thanks for that.

Presumably Mythtv was the only failure. It was a real hassle to get working on Dapper so I'm uninstalling anyway.

Cheers ... Paul

Mario Limonciello (superm1) wrote :

Paul,

What packages were you using for mythtv in dapper?

I've seen some similar things crop up, but i'm still not sure exactly where to point this bug at.

Paul Bell (launchpad-dpb) wrote :

Mario,

http://www.ubuntu.moshen.de/dists/dapper/mythtv/

MythTV was working before I upgraded to Edgy (with 0.19-5 and 0.20).

Cheers ... Paul

Mario Limonciello (superm1) wrote :

Paul,
At this point i'm blaming this on mysql-server not running during the upgrade. It seems that mythtv-database is getting configured before mysql server is, and thus mysql server isn't started until later.

If you haven't already upgraded, can you do me a favor and upgrade mysql-server before doing update-manager? See if the upgrade does cleanly.

Paul Bell (launchpad-dpb) wrote :

Sorry Mario but after rebooting yesterday everything was upgraded.

Mythtv was broken afterwards in regard to being unable to connect to mysql-server but this may have been due to my inadvertently selecting the new version of '/etc/mysql/my.cnf'. I'm not sure, I'm pretty new to Ubuntu (and Linux).

Thanks ... Paul

I got the same failure message, but in a different context? I'm testing an Edubuntu server (amd64) installation dist-upgrade and got the 'installArchives() failed' during restarting the DHCP server. I will attach the logs (note that I encountered other problems earlier in the upgrade process, so those will show up in the logs too, cf. bug 67133 about nfs-kernel-server).

Mario Limonciello (superm1) wrote :

I'm attaching a debdiff that should resolve this problem and allow mythtv-database to silently fail if mysql-server isn't running. It will be the user's responsibility to reconfigure the database if this happens.

Changed in mythtv:
status: Confirmed → Fix Committed
Michael Vogt (mvo) wrote :

It would be very nice if this fix could be backported to edgy so that a dapper->edgy upgrade does not fail on this step.

StefanPotyra (sistpoty) wrote :

Hi,

from a first glimpse, the debdiff looks good. Just two minor minor things:
* distribution should be edgy-proposed
* the version should be 0.20-0.2ubuntu2.1~proposed1

+1, since I guess whoever does the upload can simply change these.

Oh, and Mario, please set yourself as assignee for this bug.

Cheers,
   Stefan.

Kees Cook (kees) wrote :

I'm ready to upload this, if I can get 2 more +1's from the motu-sru, I'll go ahead.

Changed in mythtv:
assignee: nobody → superm1
Daniel T Chen (crimsun) wrote :

+1 pending the adjustments that Stefan has mentioned.

Steve Kowalik (stevenk) wrote :

+1 from me as well, also provided the adjustments Stefan mentioned are done.

StefanPotyra (sistpoty) wrote :

Uploaded by Kees, thanks.

Martin Pitt (pitti) wrote :

Accepted upload into edgy-proposed, please go ahead with QA testing.

Also, please do something to this dapper task, I guess it shoud just be rejected.

Changed in mythtv:
status: Unconfirmed → Fix Committed
Martin Pitt (pitti) wrote :

Tentatively closing dapper task. Please reopen and beat me up if this was wrong.

Changed in mythtv:
status: Unconfirmed → Rejected
Martin Pitt (pitti) wrote :

Oh, and pretty pleaes fix this in Feisty first. This was an oversight from my side, stable updates without a prior fix in Feisty are actually forbidden.

This is the same fix that's in feisty, so it shouldn't be a worry.

On 2/23/07, Martin Pitt <email address hidden> wrote:
>
> Oh, and pretty pleaes fix this in Feisty first. This was an oversight
> from my side, stable updates without a prior fix in Feisty are actually
> forbidden.
>
> --
> [SRU] "Could not install the upgrades" - installArchives() failed
> https://launchpad.net/bugs/68400
>

--
Mario Limonciello
<email address hidden>

Martin Pitt (pitti) wrote :

Closing Feisty task as per Mario's comment.

Changed in mythtv:
status: Fix Committed → Fix Released
Changed in mythtv:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers