Missing dependency on libqt4-webkit-dev

Bug #586007 reported by Felix Geyer
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
mythplugins (Ubuntu)
Undecided
Unassigned
mythtv (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: mythtv

QtWebKit is no longer part of libqt4-dev so all packages using it need to build-depend on libqt4-webkit-dev.

Revision history for this message
Mario Limonciello (superm1) wrote : Re: [Mythbuntu-bugs] [Bug 586007] [NEW] Missing dependency on libqt4-webkit-dev

The biggest problem here is that we need to make sure that the builds are
still compatible with Lucid and earlier too. The exact same packaging is
used by the Mythbuntu auto-builds project (www.mythbuntu.org/auto-builds)

I *think* this diff would work - but it will need to be tested to make sure

=== modified file 'debian/control'
--- debian/control 2010-05-25 13:43:31 +0000
+++ debian/control 2010-05-26 19:42:47 +0000
@@ -14,6 +14,7 @@
                 ccache,
                 yasm,
                 libqt4-dev,
+ libqt4-webkit-dev | libqt4-dev,
                 libqt4-opengl-dev,
                 libdvb-dev,
                 po-debconf,

On Wed, May 26, 2010 at 13:37, Felix Geyer <email address hidden> wrote:

> Public bug reported:
>
> Binary package hint: mythtv
>
> QtWebKit is no longer part of libqt4-dev so all packages using it need
> to build-depend on libqt4-webkit-dev.
>
> ** Affects: mythplugins (Ubuntu)
> Importance: Undecided
> Status: New
>
> ** Affects: mythtv (Ubuntu)
> Importance: Undecided
> Status: New
>
> ** Also affects: mythplugins (Ubuntu)
> Importance: Undecided
> Status: New
>
> --
> Missing dependency on libqt4-webkit-dev
> https://bugs.launchpad.net/bugs/586007
> You received this bug notification because you are a member of Mythbuntu
> Bug Team, which is subscribed to mythtv in ubuntu.
>
> Status in “mythplugins” package in Ubuntu: New
> Status in “mythtv” package in Ubuntu: New
>
> Bug description:
> Binary package hint: mythtv
>
> QtWebKit is no longer part of libqt4-dev so all packages using it need to
> build-depend on libqt4-webkit-dev.
>
>
>
> _______________________________________________
> Mailing list: https://launchpad.net/~mythbuntu-bugs
> Post to : <email address hidden>
> Unsubscribe : https://launchpad.net/~mythbuntu-bugs
> More help : https://help.launchpad.net/ListHelp
>

--
Mario Limonciello
<email address hidden>

Revision history for this message
Felix Geyer (debfx) wrote :

It seems a bit unsafe as a dependency resolver could ignore libqt4-webkit-dev even when it's needed.

This should be better:
libqt4-webkit-dev | libqt4-dev (<< 4:4.7.0~beta1),

Revision history for this message
Thomas Mashos (tgm4883) wrote : Re: [Mythbuntu-bugs] [Bug 586007] Re: Missing dependency on libqt4-webkit-dev

That looks like it would work to me. Keeping the libqt4-dev as well.

                 ccache,
                 yasm,
                 libqt4-dev,
                 libqt4-webkit-dev | libqt4-dev (<< 4:4.7.0~beta1),
                 libqt4-opengl-dev,
                 libdvb-dev,
                 po-debconf,

Thomas

On Wed, May 26, 2010 at 1:37 PM, Felix Geyer <email address hidden> wrote:

> It seems a bit unsafe as a dependency resolver could ignore libqt4
> -webkit-dev even when it's needed.
>
> This should be better:
> libqt4-webkit-dev | libqt4-dev (<< 4:4.7.0~beta1),
>
> --
> Missing dependency on libqt4-webkit-dev
> https://bugs.launchpad.net/bugs/586007
> You received this bug notification because you are a member of Mythbuntu
> Bug Team, which is subscribed to mythtv in ubuntu.
>
> Status in “mythplugins” package in Ubuntu: New
> Status in “mythtv” package in Ubuntu: New
>
> Bug description:
> Binary package hint: mythtv
>
> QtWebKit is no longer part of libqt4-dev so all packages using it need to
> build-depend on libqt4-webkit-dev.
>
>
>
> _______________________________________________
> Mailing list: https://launchpad.net/~mythbuntu-bugs
> Post to : <email address hidden>
> Unsubscribe : https://launchpad.net/~mythbuntu-bugs
> More help : https://help.launchpad.net/ListHelp
>

Thomas Mashos (tgm4883)
Changed in mythtv (Ubuntu):
assignee: nobody → Thomas Mashos (tgm4883)
Changed in mythplugins (Ubuntu):
status: New → Confirmed
Changed in mythtv (Ubuntu):
status: New → Confirmed
Changed in mythplugins (Ubuntu):
assignee: nobody → Thomas Mashos (tgm4883)
Revision history for this message
Thomas Mashos (tgm4883) wrote :

I've pushed this to the mythplugins branches and it should be fixed in the next build. I didn't push it to the mythtv branch as we shouldn't need webkit there.

Changed in mythtv (Ubuntu):
status: Confirmed → Invalid
Changed in mythplugins (Ubuntu):
status: Confirmed → Fix Committed
Revision history for this message
Felix Geyer (debfx) wrote :

We had to change the names of the QtWebkit packages to stay in sync with Debian.
The new name is: libqtwebkit-dev

Changed in mythplugins (Ubuntu):
status: Fix Committed → Confirmed
Revision history for this message
Thomas Mashos (tgm4883) wrote : Request for information

Thank you for taking the time to report this bug and helping to make Ubuntu better. Please execute the following command, as it will automatically gather debugging information, in a terminal:

apport-collect 586007

This will help us to find and resolve the problem. Bear in mind that you may need to install the python-launchpadlib package from the universe repository. Additionally, when prompted to give apport-collect permissions for Launchpad you will need to give it at least the ability to "Change Non-Private" data as it will be adding information to your bug report. Thanks in advance!

Changed in mythplugins (Ubuntu):
status: Confirmed → Incomplete
Revision history for this message
Thomas Mashos (tgm4883) wrote :

Please disregard that last request. I had an inadvertent click in bughugger

Changed in mythtv (Ubuntu):
status: Invalid → Confirmed
Changed in mythplugins (Ubuntu):
status: Incomplete → Confirmed
Revision history for this message
Mario Limonciello (superm1) wrote :

this has been fixed in -fixes and -master for the last month or so.

Changed in mythplugins (Ubuntu):
assignee: Thomas Mashos (tgm4883) → nobody
status: Confirmed → Fix Released
Changed in mythtv (Ubuntu):
assignee: Thomas Mashos (tgm4883) → nobody
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers