MythTV playback issue - number of reference frames exceeds max

Bug #585263 reported by Jazzman on 2010-05-25
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
mythtv (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: mythtv

The following error appears in the mythfrontend.log.

The result is that the picture is out of sync very slightly with the sound and with a slight jerk (assumingly due to the discarded frame).

2010-05-24 19:34:19.826 [h264_vdpau @ 0x7f2de04a7360]number of reference frames exceeds max (probably corrupt input), discarding one

This only occurs for TV3 here in New Zealand. It is our only 1080i dvb-t channel. All others are either 720p or 576 and work fine.

Our broadcast mix here is H.264/MPEG-4 AVC.

I am using Mythbuntu 10.04 with a nova-t 500 tuner and an NVidia graphics card.

Please help :-)

Thanks!

Jazzman (neil-hearn) wrote :

The error also appears in mythbackend.log

Per Frøysa (per-froysa) wrote :

My location is Trondheim Norway.

The log files are growing rapidly and I cannot watch live TV because og heavy stuttering. Video and sound freezes at approx. 1 second intervals.

Log contain lots of the following line:
2010-06-04 11:02:40.976 [h264 @ 0x17fc960]number of reference frames exceeds max (probably corrupt input), discarding one

The tuner is a Happauge Nova-T USB Stick.

Please help.

Per Frøysa (per-froysa) wrote :

Let me add: Only one of the programs in this multiplex have this problem. The other two plays fine.
It is the higher resolution of the "prime channel NRK1" that causes trouble. NRK2 and NRK3 are fine.

I may add more infor if someone could tell me how. I have just installed Mythtv and my milage is about zero.

Per Frøysa (per-froysa) wrote :

Please cancel my bug-report! I did not enable VDPAU. I was overtaxing the CPU and that caused this error.
Now - with VDPAU enabled all cannels play fine!

Please cancel...

Andrew Stevens (andrew-stevens) wrote :

Just upgraded from karmic to lucid and hit exactly this problem. VERY noticeable on the heavily inter-cut World-cup coverage on ZDF and ARD here in Germany.

Seems supiciously like a "reincarnation" of

http://svn.mythtv.org/trac/ticket/7522

this was fixed 0.22-fixes. Could it be the ffmpeg upstream fix isn't present in the ubuntu 0.23 builds?

Jazzman (neil-hearn) wrote :

I have since established that my VDPAU setting was wrong. I have an NVidia 8400 card and had the setting set to VDPAU high quality not VDPAU normal.

from http://www.mythtv.org/wiki/VDPAU .........

VDPAU Playback Profiles are automatically created in current versions.

VDPAU High Quality: use Temporal Spatial 2X (Advanced 2X) for all content. To be used with nvidia cards >= 8600GT, >= 9500GT, GT120 or >= GT220
VDPAU Normal: use Temporal 2X for HD content, and Temporal Spatial 2X (Advanced 2X) for SD content. To be used with nvidia cards >= 8400, >= 9300, GT110 or >= GT210
VDPAU Slim: use Bob 2X with skip chroma option, with One Field as fall back, to be used with nvidia cards >= 8200 or when VDPAU Normal doesn't work for some reasons.

So the picture is now fine but I still get the error in the logs.

Andrew Stevens (andrew-stevens) wrote :

Further investigations revealed that the same stream parsing error and hence frame-discards/ stutters also
with non-VDPAU playback profiles. I'm beginning to wonder if the upgrade wasn't quite clean on my machine.

The issue is so obvious visually I can't believe there aren't hordes of outraged german HD World-cup watchers complaining.

I'll investigage further when I can boot back into 10.04 (its a 'production' system ;-) ).

Andrew Stevens (andrew-stevens) wrote :

Looks like difficulties in VDPAU playback were indeed due to some junk left over from upgrades and local installs.
A solid purge and re-install and VDPAU playback is working just fine (actually: much better than with 0.22-fixes under 9.10)

However: CPU playback profiles which worked perfectly under 9.10 and 0.22-fixes still reproducibly and regularly stutter in 720p playback . The10.04 builds seem to be running less efficiently / not making as effective use of both CPU cores. A build difference in the binaries?

Platform: 10.04 32-bit
Hardware: Athlon 64 X2 6000+

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.