should not depend on hardware specific packages

Bug #560214 reported by Brian J. Murrell on 2010-04-10
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
mythtv (Ubuntu)
Undecided
Unassigned
Karmic
Undecided
Unassigned
Lucid
Undecided
Unassigned

Bug Description

Binary package hint: mythtv

Currently libmyth-0.22-0 depends on nvidia specific bits and pieces:

Depends: ... nvidia-185-libvdpau

This is simply wrong. I should not have to carry the burden of nvidia drivers on my system and dkms having to rebuild them every time there is an update on a machine that doesn't even have an nvidia card in it.

There should _never_ be hardware-specific dependencies in non-hardware specific packages such as libmyth.

Mario Limonciello (superm1) wrote :

Couple of things:

1) This only affects Karmic (9.10)
2) This doesn't pull in the NVIDIA drivers, only the VDPAU pieces of them
3) It was like this because libvdpau (to genericize the dependency) didn't exist yet when the packages were produced.
4) In lucid, libmyth depends on libvdpau1 which can dlopen different VDPAU backends. It doesn't even depend on the NVIDIA backend (in case you want to use a different one)

Changed in mythtv (Ubuntu Lucid):
status: New → Fix Released
Changed in mythtv (Ubuntu Karmic):
status: New → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers