Scanning for channels hangs on channel 1 with PVR-150

Bug #452779 reported by Seventoes on 2009-10-16
98
This bug affects 16 people
Affects Status Importance Assigned to Milestone
mythtv (Ubuntu)
High
Unassigned
Nominated for Karmic by Eric Christian

Bug Description

Binary package hint: mythtv

After having a successful install and TV working fine with 9.04, I gave 9.10 a go. After setting up all the things like I did on the working install, I went to scan for channels as normal. The scan stays at "Scanning us-cable-hrc 1 No lock"

The terminal window says:

DTVParamHelper::toString() index out of bounds

...every time I attempt to scan. All available updates are applied as of right now.

ProblemType: Bug
.var.log.mythtv.jamu.log:

Architecture: i386
Date: Fri Oct 16 00:23:09 2009
DistroRelease: Ubuntu 9.10
InstallationMedia: Mythbuntu 9.10 "Karmic Koala" - Alpha i386 (20091014)
MachineType: Dell Inc. OptiPlex GX280
Package: mythtv 0.22.0~zrc1-0ubuntu1
PackageArchitecture: all
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.31-14-generic root=UUID=8bfae10b-6a37-482e-bd74-5f0e912af1ea ro quiet splash
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-14.47-generic
SourcePackage: mythtv
Uname: Linux 2.6.31-14-generic i686
XsessionErrors:
 (polkit-gnome-authentication-agent-1:1645): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed
 (xfce4-terminal:2225): Terminal-WARNING **: Unable to load terminal preferences.
 (xfce4-terminal:2636): Terminal-WARNING **: Unable to load terminal preferences.
dmi.bios.date: 09/17/2004
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A03
dmi.board.name: 0H8164
dmi.board.vendor: Dell Inc.
dmi.chassis.asset.tag: 050127
dmi.chassis.type: 15
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvrA03:bd09/17/2004:svnDellInc.:pnOptiPlexGX280:pvr:rvnDellInc.:rn0H8164:rvr:cvnDellInc.:ct15:cvr:
dmi.product.name: OptiPlex GX280
dmi.sys.vendor: Dell Inc.

Seventoes (seventoes) wrote :
NightStorm (bam-nightstorm) wrote :

I am seeing the same thing. Just upgraded to 9.10 Mythbuntu. Deleted all capture devices and started over. HDHomeRun scanned fine, the digital side of the Hauppauge 1600 also scanned fine, the analog side of the 1600 hangs at us-cable 16. In the terminal window I get:
 2009-10-30 18:00:01.305 DiSEqCDevTree, Warning: No device tree for cardid 12
2009-10-30 18:00:40.742 DTVParamHelper::toString() index out of bounds
2009-10-30 18:02:03.311 DTVParamHelper::toString() index out of bounds
2009-10-30 18:02:03.367 DTVParamHelper::toString() index out of bounds
2009-10-30 18:02:03.421 DTVParamHelper::toString() index out of bounds
2009-10-30 18:02:03.451 DTVParamHelper::toString() index out of bounds
2009-10-30 18:02:03.480 DTVParamHelper::toString() index out of bounds
2009-10-30 18:02:03.534 DTVParamHelper::toString() index out of bounds
2009-10-30 18:02:03.564 DTVParamHelper::toString() index out of bounds
2009-10-30 18:02:03.593 DTVParamHelper::toString() index out of bounds
2009-10-30 18:02:03.649 DTVParamHelper::toString() index out of bounds
2009-10-30 18:02:03.678 DTVParamHelper::toString() index out of bounds
2009-10-30 18:02:03.707 DTVParamHelper::toString() index out of bounds
2009-10-30 18:02:03.761 DTVParamHelper::toString() index out of bounds
2009-10-30 18:02:03.790 DTVParamHelper::toString() index out of bounds

I can click the "Stop Scan" button and that will end it, so at least the GUI is responsive.

tuxBurner (sebasth) wrote :

I also have the same problem.
TV works when i enter channels by my own, in the channel editor, without scanning them.
My capture card is a Hauppauge PVR-150.

Tiemen Gysels (tiemelijn) wrote :

Same here. Hauppauge PVR-500 (dual tuner).
GUI is responsive but doesn't show any progress.
Clean install of 9.10.
Used to work on 8.10.

MarcRandolph (mrand) wrote :

Howdy, and thank you for helping to improve Mythbuntu by reporting this issue. There have been a few important fixes to mythtv since the 9.10 mythbuntu release. Can you can capture latest bug fixes by enabling the auto-builds as described here: http://www.mythbuntu.org/auto-builds ?

Please note that if you see any references to "0.22-trunk", you do not need to be concerned... 0.22-trunk is the same as 0.22-fixes from our perspective (one transitioned into the other).

If your problem remains after updating to the latest ,could one or more of you please capture a verbose log and attach it to this
ticket? You do that by:

sudo /etc/init.d/mythtv-backend stop

and then

[everything between here and "mark" should be on one line:]

sudo mythtv-setup.real --verbose channelscan,siparser,channel,record,extra > mythtv-setup.log

[mark]

You can replace "stop" with "restart" to relaunch the backend.

Changed in mythtv (Ubuntu):
importance: Undecided → High
status: New → Triaged
NightStorm (bam-nightstorm) wrote :

I did as requested on my system. I followed the directions to get the repositories for auto-builds, subscribed to 0.22, and then ran the update manager and accepted the updates. I rebooted and ran the commands as requested.

For the run the console log looked like this (log is attached):

===========================================================
xxx@mythife:~$ sudo bash
[sudo] password for xxx:
root@mythife:~# /etc/init.d/mythtv-backend stop
Rather than invoking init scripts through /etc/init.d, use the service(8)
utility, e.g. service mythtv-backend stop

Since the script you are attempting to invoke has been converted to an
Upstart job, you may also use the stop(8) utility, e.g. stop mythtv-backend
mythtv-backend stop/waiting
root@mythife:~# sudo mythtv-setup.real --verbose channelscan,siparser,channel,record,extra > /tmp/mythtv-setup.log
Xlib: extension "Generic Event Extension" missing on display "localhost:10.0".
Xlib: extension "Generic Event Extension" missing on display "localhost:10.0".
Xlib: extension "Generic Event Extension" missing on display "localhost:10.0".
Xlib: extension "Generic Event Extension" missing on display "localhost:10.0".
Xlib: extension "Generic Event Extension" missing on display "localhost:10.0".
Xlib: extension "Generic Event Extension" missing on display "localhost:10.0".
Xlib: extension "Generic Event Extension" missing on display "localhost:10.0".
Error in my_thread_global_end(): 2 threads didn't exit
===========================================================

(The Xlib errors are probably because I ssh'd into the box from another system)

Between the start and end of the above the Backend setup screen appeared, I went into the channel editor, deleted all channels on the 1600 Analog (which is the tuner that hangs), did a channel scan, and it again hung at channel 16 (as it did in the past). Note that channels 2-16 seem to scan near-instantaneously (there is no waiting on each channel). Seems wrong to me.

I hope that someone else also adds their logs because I'm not 100% on this Hauppauge 1600 tuner card. The card is new to me and after commenting here I've discovered that while the analog side of the card works the digital side has "issues". Proceed with caution.

Tiemen Gysels (tiemelijn) wrote :

I did a channel scan, but the gui kept saying 0% and 'No Lock'. In attachment the requested log.

tuxBurner (sebasth) wrote :

Okay I did the http://www.mythbuntu.org/auto-builds and went to the trunk build.
Nothing changes, the output for the log is identically to Tiemen Gysels ones.

NightStorm (bam-nightstorm) wrote :

FWIW, I just did a quick experiment where I took a scratch disk drive, put it in the system, and loaded Mythbuntu 9.04 on it. It does not have the problem with scanning for channels (i.e., it does not hang as does 9.10).

Andreas P. (oslothefirst) wrote :

got the same issue with a PVR 150, changing to auto-build trunk does not change anything.

Nagon (antonte) wrote :

Exactly the same problem here, GUI is responsive but no progress (as Tieme Gysels said).
I use Ubuntu 9.10 with the latest stable mythtv from the Mythbuntu repository.
I have a Hauppauge HVR-1300, trying to get a analog tv signal.

olituks (olituks) wrote :

I have exactly the same problem.
Can you explain me how-to avoid this?

CBee (cbeerse) wrote :

Here in NL, with analog chanels on an haupauge pvr500 (dual pvr150 :-) there is also no scanning: As soon as the scanning starts, the MythTV-setup termial says "DTVParamHelper::toString() index out of bounds". The mythtv setup screen says:
========
Status: Scanning europe-west E2No Lock
Signal Strength: 0%
Scan: 0%
========

Details from my side: It is 64 bits and ubuntu is localized to use the dutch language, however mythtv-setup is in english.

thusgaard (thusgaard) wrote :

I have the sane problem with my mythbuntu 9.10. I can how ever do a manual setup of channels. Should I post logfiles too?

J;-)

Appieheijn (albert-appieheijn) wrote :

I'm having the same problem as described above.
I attached the verbose log.

mehturt (mehturt) wrote :

I have the same problem with Asus My Cinema-P7131H and Ubuntu 9.10

CBee (cbeerse) wrote :

WORKAROUND (well, manual labor, the quick and dirty way)

I expect the channel scanning fails for more than me alone. My solution was to insert the frequencies manually. My shot was to use both mythweb and phpmyadmin. But I started setting the first channel in the mythtv-backend-setup. At Channel-Editor, I just added a channel with the details I could get hold of. The cable company provided me with a list of channels and their frequencies. I just got one going.

Then I used phpmyadmin to export table 'channel' in database 'mythconverg' to a sql file. This is an editable ascii file. I used my favorite ascii editor (vi for me, you can use yours). I searched for the line with my channel name in it and I replicated this line for every channel and frequency.

For 'ChanID' and 'ChanNum I used an ongoing number.

I ran xmltv as in their documentation until I got a list with channel names and numbers. These numbers are used with their channel name in the 'xmltvid' field.

Name and CallSign are the full name and abreviation.

For the SQL file: Each line must end with a comma (,) except for the last in the sequence, that ends with a semicolum (;)

Finally I imported the file using phpmyadmin.

Of course, I made some errors. For this I used mythweb. THerer at .../mythweb/settings, there at 'tv -> ChannelInfo' you see the same table as exported and imported above. Here you can update single fields as needed. For bulk edits much faster than the mythtv-backend-setup.

Mark Weil (mark-martialfit) wrote :

Scan for channels fails to load channels on a Network Recorder setup with a local .m3u file under 9.10 (worked on 9.04).
This is on an upgraded 9.04 system with daily auto builds enabled.

I had a similar problem with a Winfast Leadtek PVR 2000. In 9.04 everything worked out fine. Upgrade to 9.10 and neither Mythtv, Tvtime or Xawtv could scan channels. It appears that the tuner is no longer responding and cannot change channels.
Did a fresh install with 9.10 with updates and had the same issue.

However when booting in 9.10 using kernel 2.6.31-14 rather than 2.6.31-15 everything works fine again.

Forgot to add that I didn't test scanning as I always enter the frequencies manually in Mythweb anyway. However the important issues was that the card now changes channels again.

For the record, this fails identically for me on a 32-bit and 64-bit fresh install of 9.10 here.

rjaubin (rjaubin) wrote :

Mythbuntu 9.10 also hangs for me while scanning for channels. I have a PVR-500. It hangs after reaching %5.

Boy, am I glad to find I am not alone on this. I finally came to the point of completing my switch to a *nix/osx environment, when I found that MythTV was somewhat unhappy with my dual PVR 150 setup.

I'm running a 32 bit 9.10 with all available updates and scanning fails, usually directly with the same result as CBee showed before:
========
Status: Scanning europe-west E2No Lock
Signal Strength: 0%
Scan: 0%
========
I also found the tuners are in fact working, since manually entering channels will do the trick, but I'm not very confident in my family accepting the errors in entering the channels...

Eric Christian (eric678) wrote :

I have a PVR500 and I am seeing the same thing as everyone else - channel; scanning hangs. I usually get to channel 23, one one occasion on one of the tuners I made it into the high thirties. It turned out to be a fluke though -- next scan stopped at 23 again.

The WAF is getting lower - I moved my tuner to a new machine and I am struggling getting it back to "the way it was"

fastie81 (fastie81) wrote :

Hi Guys
We have the same problem with the scan on HD HomeRun DVB-T
Here is the ticket and it looks like they only going to move this patch into 0.23. I am disappointing as 0.22 only came out now and we will have to wait what 2 year before 0.23 is coming out.
Here is our locked ticket.
http://svn.mythtv.org/trac/ticket/7624
C

dacota (jasoncot) wrote :

I was attempting to get a PVR-150 & PVR-500 working in the last few days and countered the problem described here. When scanning for channels MythTV stops at channel 6. Which I believe is not an active channel on my local cable.

I also attempted to use mplayer to view tv but it could not change channels.

Is this problem still being looked into?

Seventoes (seventoes) wrote :

For me, this is a different issue than #478048. The scan for channels button is just fine, but nothing happens on the scan screen.

mehturt (mehturt) wrote :

Same for me.

dacota (jasoncot) wrote :

I can confirm the same thing, #478048 is not the issue that is occuring for me.

While attempting the work around (manually entering channels into mySQL db) that the channel that the scan stopped on was a blank/empty channel. Since it's consistent on the first not-active channel, it would seem like the channel scanner/tuner isn't recognizing that it should skip/not try to get a lock; or it's dieing when it hits this channel.

frieso (ubuntu-frieso) wrote :

Hi,
I´m having the same problem. I upgraded to 0.23 and still have this error.

mythbackend --version
Please include all output in bug reports.
MythTV Version : 23387
MythTV Branch : trunk
Network Protocol : 56
Library API : 0.23.20100127-1
QT Version : 4.5.2

When I scan for the Channels I get:

...

2010-01-31 13:39:00.123 ChannelScanSM(/dev/video0): Transport Scan Item 'europe-west 69' #111
        mplexid(0) standard(dvb) sourceid(2)
        UseTimer(0) scanning(0)
        timeoutTune(1000 msec)
        frequency(857000000) constellation(512)
          inv(2) bandwidth(3) hp(9) lp(9)
          trans_mode(2) guard_int(4) hierarchy(4)
         offset[0..2]: 0 0 0
2010-01-31 13:39:00.127 ChannelScanSM(/dev/video0): Tune zu europe-west E2 mplexid (0)
2010-01-31 13:39:00.127 DTVParamHelper::toString() index out of bounds
2010-01-31 13:39:00.127 Channel(/dev/video0): Tune(48250000, Tuner 1, , dvb)
2010-01-31 13:39:00.149 Channel(/dev/video0)::Tune(): Frequency is now 48250000
2010-01-31 13:39:00.149 SM(/dev/video0)::Start: begin
2010-01-31 13:39:00.153 SM(/dev/video0)::Start: end
2010-01-31 13:39:00.154 SM(/dev/video0)::Stop: begin
2010-01-31 13:39:00.179 SM(/dev/video0)::Stop: end
2010-01-31 13:39:00.179 ChannelScanSM(/dev/video0): Tune zu europe-west E3 mplexid (0)
2010-01-31 13:39:00.179 DTVParamHelper::toString() index out of bounds
2010-01-31 13:39:00.179 Channel(/dev/video0): Tune(55250000, Tuner 1, , dvb)
2010-01-31 13:39:00.213 Channel(/dev/video0)::Tune(): Frequency is now 55250000
2010-01-31 13:39:00.213 SM(/dev/video0)::Start: begin
2010-01-31 13:39:00.223 SM(/dev/video0)::Start: end
2010-01-31 13:39:11.346 ChannelScanSM(/dev/video0): ChannelScanSM::StopScanner
2010-01-31 13:39:11.346 ChannelScanSM(/dev/video0): ChannelScanSM::RunScanner -- end
2010-01-31 13:39:11.346 SM(/dev/video0)::Stop: begin
2010-01-31 13:39:11.369 SM(/dev/video0)::Stop: end
2010-01-31 13:39:11.369 ChannelScanSM(/dev/video0): ChannelScanSM::StopScanner
2010-01-31 13:39:11.369 SM(/dev/video0)::Stop: begin
2010-01-31 13:39:11.370 SM(/dev/video0)::Stop: end
2010-01-31 13:39:11.370 ChannelScanSM(/dev/video0): ChannelScanSMner Stopped
2010-01-31 13:39:11.370 SM(/dev/video0)::Stop: begin
2010-01-31 13:39:11.370 SM(/dev/video0)::Stop: end

Kernel Version is: 2.6.31-17-generic

I´m having a PVR500 card, using Mythbuntu 9.10

Any ideas?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.