LNB configuration window does not appear under diseqc settings

Bug #449023 reported by gocin on 2009-10-11
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
mythtv (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: mythtv

Hi, I'm running a mythbuntu 9.04 with two Technisat Skystar Rev 2.8B working using a bit handwork.

Ubuntu karmic (development branch) 9.10
0.22.0~trunk22304-0ubuntu1

Versions-Tabelle:
0.22.0~trunk22304-0ubuntu1 0
500 http://de.archive.ubuntu.com karmic/multiverse Packages
100 /var/lib/dpkg/status

Under 9.10 due to Kernel 2.6.31-xx both cards are detected correct which means under the new card menu in mythtv backend setup the cards are detected - source is choosen and linked correct but if I try to set the DISEQC settings to link the card to the LNB no configuration window appears - there is just the entry (unconnected) .
Therefore (I guess) I can't scan any channels.

Best regards, Nico.

ProblemType: Bug
Architecture: i386
Date: Sun Oct 11 22:15:53 2009
DistroRelease: Ubuntu 9.10
NonfreeKernelModules: nvidia
Package: mythtv 0.22.0~trunk22304-0ubuntu1
PackageArchitecture: all
ProcEnviron:
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-13.44-generic
SourcePackage: mythtv
Uname: Linux 2.6.31-13-generic i686
XsessionErrors:
 (polkit-gnome-authentication-agent-1:6781): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed
 (xfce4-terminal:7714): Terminal-WARNING **: Unable to load terminal preferences.

gocin (nico-goeth) wrote :
gocin (nico-goeth) wrote :

Its a Technisat Skystar 2 Rev 2.8B

Here's the console output showing on the mythtv setup as the problem appears.

MarcRandolph (mrand) wrote :

Howdy and thank you for helping to improve Mythbuntu by opening this ticket. Could you please generate a more extensive log with extra debugging turned on so that we can submit it to the developers? To do this, you would probably need to use the following commands in a terminal window:

sudo /etc/init.d/mythtv-backend stop

and then

sudo mythtv-setup.real --verbose channelscan,siparser,channel,record,extra > mythtv-setup.log

replace "stop" with "restart" to relaunch the backend.

Changed in mythtv (Ubuntu):
status: New → Incomplete
gocin (nico-goeth) wrote :

Hi Marc here's the log you requested.
What could be interesting maybe - I tried to install the s2-liplianin and v4l drivers but both didn't compile - maybe I made a mistake - maybe it doesn't matter.

Regards, Nico.

MarcRandolph (mrand) wrote :

Howdy again, unfortunately your log looks truncated. Not sure what happened, but there is (comparatively speaking) nearly empty.

gocin (nico-goeth) wrote :

Hi Marc,

sorry for the strange logfile, I don't know what happend.

But - yesterday I installed the latest updates available and - now it works :-)
I saw that to choose the DISEQC settings you need to 'enable' the windows by pressing a key ( I used cursor right) then the window will be highlighted and the settings can be done.

Another point is that it's only working using the default theme - but maybe that's just work to be done until release.

So thanks for your work!
And best regards,
Nico.

MarcRandolph (mrand) wrote :

Howdy again,

I'm trying to better understand the problem you had and what, if anything, can be done to make sure others don't run into it. Developers may or may not have time to resolve the issues, but I'd like to better understand them. Unfortunately, I don't have the hardware you are talking about, so I'm at a bit of a disadvantage - which we can make up for if you can be extra descriptive. It sounded like there were two things you ran into:

1. You found it non-intuitive to access the DISEQC settings. Could you take a screen-shot or two showing the screen as it is before you used the cursor right key, and then after you use the cursor right key?

2. Accessing the DISEQC settings was not possible with a non-default theme set. Could you take a screen-shot of this?

Are these accurate? Are they problem that you feel others would likely run into?
Thanks!

gocin (nico-goeth) wrote :

Hi again,

the points you pointed on are exact the two issues I tried to describe.

For point 1 - lets say it's just usability I have done some screenshots which show that it's only possible to access the DISEQC menue after you 'activated' the window.

I'll create the Screenshots for II later on.

If I can do some testing on my system, I'll be pleased to do it, to improve Ubuntu / Mythbuntu, even if it's already on a very high level.

Regards,
Nico.

gocin (nico-goeth) wrote :

And hi once more,

I tried to take some screenshots on point II but all themes I tried worked without any problem. So it looks like there is nothing to do at this point I guess.

gocin (nico-goeth) wrote :

Hi,

yesterday I installed the latest updates and tested some things - before I open another bug - here's another issue but I don't which packeage is affected, alsa or mythtv (mythfrontend / mythbackend?) - maybe you could give me an advice what to do?

If I start the system or reboot it mythfrontend starts - starting 'watching TV' the sound is quite loud - I can decrease it using my remote, the bar which shows the percentage reacts but the sound stays as loud as before.
If I'm exiting 'watching TV' and enter the general setup menu where you can set the sound configuration - and I do NOT cange anything, just click thru - and start 'watching TV' again - all works as it should be.

Any idea? Should I open another bug? Or is it known?

Best regards,
Nico.

Børge (borgeh) wrote :

Hello,

I just wanted to add that more people experience this, and this small thread offered the only solution.
I too had problems getting to the window following the "(Unconnected)". Merely pressing <enter>, which would be following standard mythtv style, gets me stuck at "(Unconnected"). Inspired by this thread I clicked the mouse (even though you cannot see any mouse when mythtv runs), then pressed <enter>. I was then able to pick LNB etc.

Solved it for me.
Now I have tested various versions of 9.10 (ub, kub, mythb) and if I recall correctly these had problems too. That's actually yhe reason for trying 9.04 again...

Unfortunately I do not have heaps of great logs about this, didn't think about reporting until this morning....
But this was on a computer with a fresh install of 9.04, adding Avenards 0.22+fixes repository. I have never had this with my previous, pre-0.22 installs. Running on the 2.6.28-16 (I think) kernel.

If someone is still looking at this, I might be persuaded to go through the process with more logging on... But as 0.22 crashed so often in tv mode I have booted it to the old and stable 0.21 partition. ;-)

Regards, Børge

Børge (borgeh) wrote :

Oh, just a small note on the hardware: running the MSI Media Live, with an HVR-4000.
Both 'real' card and virtual cards have the same problem. And it all works after you find the strange solution, albeit only for a while. But that is because of other things.

-Børge

rasos (rasos) wrote :

I confirm this behaviour with very latest mythtv upgrade, when trying choose LNB:

Pressing <enter>, which would be following standard mythtv style, gets me stuck at "(Unconnected"). Only if you click with the (unvisible) mouse, then pressed <enter>, you are able to pick LNB etc.

Changed in mythtv (Ubuntu):
status: Incomplete → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers