[ubuntu karmic] mythtv frontend inactivates sound

Bug #436792 reported by ullix on 2009-09-25
26
This bug affects 4 people
Affects Status Importance Assigned to Milestone
MythTV
Fix Released
Unknown
Mythbuntu
Fix Released
High
Unassigned
mythtv (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: mythtv-frontend

running mythtv frontend on karmic, trying to access the mythtv backend running on an ubuntu intrepid computer , stops any sound currently playing e.g. by rhythmbox, and then shows a message that it can't access the backend (due to database being outdated) allowing only to exit mythtv frontend. but then sound remains dead, no sound from any program.

note: this is probably the reason behind Bug #436764

Related branches

MarcRandolph (mrand) wrote :

Howdy, and thank you for helping to improve Mythbuntu by filing this report. Could you clarify a few things that should help the maintainers narrow down possible causes?

1. What version of mythfrontend are you running on the Karmic system? (command is "apt-cache policy mythtv-frontend")
2. What version of mythbackend are you running on the Intrepid system? (command is "apt-cache policy mythtv-backend")
3. Was the Karmic system originally Intrepid (or earlier), or was it a new install as Karmic?
4. In Bug #436764, you say "today's updates". Was that just a daily update to the Karmic system? Not an OS upgrade, right?
5. When you say sound remains dead, do you mean even after reboots?
6. Not asking you to do it at this time, but just to cover all bases, is reinstalling Karmic an option?

Thank you!

Changed in mythtv (Ubuntu):
status: New → Incomplete
ullix (ullix) wrote :

Note that I could reproduce the bug on two different frontend systems: after cold boot sound is well. After start of mythtv-frontend, sound is off, not even crackling (and I have no idea if it can be recovered and how, any advice what to try?).

The backend is an intrepid install and is running well.
The two frontends are of same karmic update status. the hardware is:
a) netbook Acer Aspire One A110L
b) motherboard Intel D945GCLF2 (atom330)

answers to your questions in your number order :

1) on the netbook
sudo apt-cache policy mythtv-frontend
mythtv-frontend:
  Installed: 0.22.0~trunk21954-0ubuntu2
  Candidate: 0.22.0~trunk21954-0ubuntu2
  Version table:
 *** 0.22.0~trunk21954-0ubuntu2 0
        500 http://archive.ubuntu.com karmic/multiverse Packages
        100 /var/lib/dpkg/status

2) sudo apt-cache policy mythtv-backend
mythtv-backend:
  Installiert: 0.21.0+fixes18722-0ubuntu1
  Kandidat: 0.21.0+fixes18722-0ubuntu1
  Versions-Tabelle:
 *** 0.21.0+fixes18722-0ubuntu1 0
        500 http://archive.ubuntu.com intrepid/multiverse Packages
        100 /var/lib/dpkg/status

3) it was a new install of karmic on both frontends

4) yes, just a daily update of karmic on both (but may be irrelevant, see 5)

5) after a reboot all is fine and sound is well. but starting mythtv-frontend, and sound is off

6) karmic will eventually be reinstalled, but I'd say it is not needed now, see 5)

MarcRandolph (mrand) wrote :

Since you opened this ticket because of a sound problem, I assume that we can leave it open for now.

But be advised that all systems that are talking to each other must be at the same version level ... in this case, you have a mix of 0.22 and 0.21, so even if the sound issue can be resolved, you should not expect your current config to work.

Changed in mythtv (Ubuntu):
status: Incomplete → Confirmed
ullix (ullix) wrote :

Marc, I am not sure why a server and a clkient MUST be of same version. You will surely understand that I am not going to change a production server to karmic, solely for the wish of running mythtv, as everything else works mostly tomy satisfction. Why can't you not at least offer an intrepid upgrade of mythtv, even as ppa, so that one can continue to enjoy mythtv even on karmic ?

But to take that issue out of the equation I shut down my intrepid server and started mythtv-frontend on karmic. It then does of course not find any backends, but the same thing happens: mythtv-frontend takes over the sound on its start and does not let go. Even after exiting mythtv-frontend, and verified by ps -A that nothing is left running, sound output is dead.

MarcRandolph (mrand) wrote :

ullix: I certainly understand your desire to not upgrade a perfectly running server.
When 0.22 is finally released, I do not know if it will be made available Intrepid-backports, but in fact PPAs are available currently which allow you to upgrade to trunk (pre-0.22) on Intrepid, or install 0.21 on Karmic. It is covered here:

http://www.mythbuntu.org/auto-builds

WARNING: should decide to upgrade your backend to trunk (pre-0.22), be sure to backup your MySQL database prior to enabling trunk builds. Once a database is migrated to trunk, it can not be migrated back to a prior version (instead, you must restore the backed up database).

Once you have all systems running the same version, please report back here if that resolves your sound problem. If it does not, please attach a frontend log to this ticket.

Thank you!

Changed in mythtv (Ubuntu):
status: Confirmed → Incomplete
ullix (ullix) wrote :

Marc, thanks for the link to the options for alternative builds; I'll give it a try. For now , however, the issue is not about the (non-)compatibility of a .21 server and a .22 client, but the fact that frontend is killing the sound! Here the test again and the mythfrontend.log attached:

1) no computer on my network except the marmic netbook with the mythtv-frontend on it. I.e. there is no backend server for the frontend to find, therefore mythtv version of a non running server is irrelevant
2) a have a cacophonie of a simultaneous youtube video and a rhythmbox radio running
3) I start mythtv-frontend --> the sound goes off, complete silence, no crackling, nothing
4) mythtv displays language choice; 3x ESC to exit mythtv-frontend. verifiied by ps -A that it is not running any more
5) sound remains off. restarting rhythmbox does not bring the sound back; in fact it tells me that it is running, but nothing audible. likewise, no sound in skype
6) sound is back after rebooting

doesn't look like the log file has any useful iinformation. mythwelcome.log file is also created, but is empty

ullix (ullix) wrote :

update: to get the sound back it is sufficient to logout and login again. a reboot is not needed

MarcRandolph (mrand) wrote :

I wonder if this could be pulse audio related. Just thinking-aloud really...
If you go to System>Preferences>Sound, could you describe your settings there - and after recording them, perhaps trying some different ones (perhaps ALSA)?

I'm sorry to say that I'm not well versed on navigating the Linux sound maze... anyone else out there have any ideas?

Changed in mythtv (Ubuntu):
status: Incomplete → Confirmed
Thomas Mashos (tgm4883) wrote :

I've noticed that the front sound is muted and set to 0 when I boot my system. I'm not sure what is causing this, haven't really had the time to track it down. This is on my 9.10 system.

Also note, that there are 0.22 packages for 8.10 and 9.04, but no 0.21 packages for 9.10.

ullix (ullix) wrote :

Marc, I am inclined to say that you haven't looked at 9.10 lately? Or is my ubuntu-default-install computer (Acer Aspire One 110L netbook) completely different? 9.10 has changed quite a bit, in particular under sound, and very recently. Not really a good path into beta status. (Skype also has a sound regression see Bug #437192 )

Attached are two screenshots from System->Preferences->Sound.
*-hardware shows the Hardware tab selected. only options are : "Analog Stereo Duplex" (shown), "Analog Stereo Output", "Analog Stereo Input", and "Off". That's it, no Alsa or else!
*-output shows the output tab selected. there are no options in this tab.

Thomas, I am not talking boot time. I do have sound after boot. Sound vanishes only after starting mythtv-frontend.

ullix (ullix) wrote :
ullix (ullix) wrote :
ullix (ullix) wrote :

well, not much luck in installing the alternative mythbuntu repos: attached is a screenshot showing the error message i got

Wouldn't it be easier to just spell out what line I need for the repos?

> Marc, I am inclined to say that you haven't looked at 9.10 lately? Or is
> my ubuntu-default-install computer (Acer Aspire One 110L netbook)
> completely different? 9.10 has changed quite a bit, in particular under
> sound, and very recently. Not really a good path into beta status.
> (Skype  also has a sound regression see Bug #437192 )

Indeed, I commented without looking at my 9.10 machine. My apologies.
The challenge here is that quite a number of people are using 0.22 and
9.10 without the sound trouble that you are having.

The reason for the .deb file (which should definitely work - I used it
last weekend) is that it auto-magically handles the different releases
of Ubuntu, as well as asking if you want fixes-0.21 or trunk (which is
currently pre-0.22). I believe you are looking for:

deb http://ppa.launchpad.net/mythbuntu/trunk-0.22/ubuntu karmic main
deb-src http://ppa.launchpad.net/mythbuntu/trunk-0.22/ubuntu karmic main

If you need more info on that ppa, it is based here:
https://launchpad.net/~mythbuntu/+archive/trunk-0.22

MarcRandolph (mrand) wrote :

Bug #436792 hints at another report of the frontend killing sound.

MarcRandolph (mrand) wrote :

Ooops, I meant Bug #434899

MarcRandolph (mrand) wrote :

Pulseaudio is often at the root of sound related problems, especially since MythTV doesn't support it well yet.

To those of you having the killed sound, what window manager are you using?
Asked another way, did you install the myth packages as add-on's to an install that wasn't originally Mythbuntu?
Mythbuntu defaults to Xfce which isn't as ingrained with pulseaudio as something like GNOME. If you are using GNOME, it might explain why there have not been widespread reports of this.

ullix (ullix) wrote :

I have the default install of ubuntu karmic, i.e. the Gnome desktop. mythtv-frontend was added from repositories after default install was completed

MarcRandolph (mrand) wrote :

> I have the default install of ubuntu karmic, i.e. the Gnome desktop.
> mythtv-frontend was added from repositories after default install was
> completed

Thank you for reporting back. Anyone else having this problem using GNOME?

The following thread contains links to decent Pulseaudio discussions
(including how to permanently or temporarily disable it at login and
autospawn):
http://ubuntuforums.org/showthread.php?t=1254695

If someone can confirm that this is the issue, the maintainers can
hopefully figure out a way around it...

MarcRandolph (mrand) wrote :

Since it is known that upstream doesn't do pulse audio well, moving to the Mythbuntu bucket.
It would still be nice if someone could confirm that disabling pulse audio fixes the problem.

Changed in mythbuntu:
importance: Undecided → High
milestone: none → karmic-rc
status: New → Confirmed
Changed in mythtv (Ubuntu):
status: Confirmed → Invalid
ullix (ullix) wrote :

Looks like pulseaudio is the bad guy, here is waht I did and the result:

- all updates done for today (should have given karmic beta)
- in synaptic select pulseaudio for uninstall, and click ok to uninstall all dependencies
- restart
- start rhythmbox, and play radio music
- start mythtv-frontend while the backend-server on intrepid is running
-- frontend complains that database schema is 30 versions behind, BUT THE MUSIC KEEPS PLAYING
-- clicking ok to end the frontend, and no interruption in the playing music!

on another front, I can start skype and the sound from e.g. test calls overlay the background music, and the microphone works again.

I don't think it was such a good idea to have pulseaudio introduced as default system in the last alpha. Now we have a beta with major sound issues!

(if you now could offer a working downgrade of the karmic mythtv-frontend to 0.21 - because what you have does not work - I would be really pleased!)

ullix (ullix) wrote :

forgot to add: the skype microphone-not-working bug due to pulseaudio is Bug #437192

ullix (ullix) wrote :

now what: I added your repositories:
deb http://ppa.launchpad.net/mythbuntu/trunk-0.22/ubuntu karmic main
deb http://ppa.launchpad.net/mythbuntu/trunk-0.22/ubuntu intrepid main
on the intrepid (backend+frontend) and karmic (frontend only) computers and updated

Now I can watch TV and videos on the intrepid computer, but now it seems this one is ahead of karmic, as the karmic computer complains: "The server uses network protocol 50, but this client only understands version 49. Make sure you are running compatible versions on the backend and frontend."

Well, this is what I tried to run. Are there yet additional flavours of .22 versions??

MarcRandolph (mrand) wrote :

Please try updating again. The incompatible protocol problem should be resolved now - upstream had a bug (Bug #440807), but it was not known at the time that we'd done a nightly snapshot.

As for pulse audio, it was actually first introduced to Ubuntu in 8.04. Not many are happy with how the transition is going, but it appears to be the (much needed) future path of Linux audio.

Changed in mythtv:
status: Unknown → New
Mario Limonciello (superm1) wrote :

So this bug can be worked around by running mythfrontend like this until it's fixed upstream:

PULSE_INTERNAL=1 mythfrontend

Changed in mythtv (Ubuntu):
status: Invalid → Confirmed
Changed in mythtv:
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mythtv - 0.22.0~trunk22304-0ubuntu1

---------------
mythtv (0.22.0~trunk22304-0ubuntu1) karmic; urgency=low

  * New upstream checkout (r22304)
    - Fixes crash during image loading of mythfrontend (LP: #445173)
    - Disables pulseaudio harder, fixing sound playback when it's installed.
      (LP: #436792)
  * debian/mythtv_0.22.0.sql:
    - Set Internal as the default player across the board. Looks like some
      areas were previously missed. This only affects new installs.
      (LP: #445984)
  * debian/patches/10_mythfilldatabase_log.dpatch:
    - Update to actually log to a file not a directory.
  * debian/patches:
    - Drop any patches that weren't actually being applied.
  * Set default theme to Mythbuntu rather than Mythbuntu-9.10 since upstream
    accepted it without a version number applied.
  * debian/mythtv-database.{postinst,config}:
    - Use the debian system maintainer account to set things up if possible.
    - Drop broken logic for trying to detect when slow writes are needed.

 -- Mario Limonciello <email address hidden> Wed, 07 Oct 2009 23:24:05 -0500

Changed in mythtv (Ubuntu):
status: Confirmed → Fix Released
Changed in mythtv:
status: Confirmed → Fix Released
MarcRandolph (mrand) wrote :

Fix was pushed to official karmic package.

Changed in mythbuntu:
status: Confirmed → Fix Released
Sasa Jovic (sasa-jovic) wrote :

Hi,

this bug is not fixed.

How to reproduce?

1) Install Karmic Ubuntu, do all updates (not mythbuntu)
2) Sudo apt-get install mythtv (both frontend and backend), configure tv card and add channels
3) Start Totem and play divx video
4) Start Mythtv Frontend, Totem video stops at the moment when mythtv window shows
5) Select TV -> Watch TV, no sound
6) Leave Mythtv Frontend, totem continues playing

I even tried that with mythtv ppa listed above and same situation.

Sasa:

Are you sure that audio is being captured properly in the first place? Can
you try opening one of your recordings in another player? They're stored in
/var/lib/mythtv/recordings by default.

I just ran this scenario:

1) Up to date Karmic Ubuntu w/ mythfrontend installed
2) Play a random movie file in totem. Audio works
3) Open mythfrontend, totem pauses.
4) Open an existing recording from mythfrontend, have functional audio
5) Close mythfrontend
6) Audio resumes in totem

On Fri, Oct 16, 2009 at 11:14, Sasa Jovic <email address hidden> wrote:

> Hi,
>
> this bug is not fixed.
>
> How to reproduce?
>
> 1) Install Karmic Ubuntu, do all updates (not mythbuntu)
> 2) Sudo apt-get install mythtv (both frontend and backend), configure tv
> card and add channels
> 3) Start Totem and play divx video
> 4) Start Mythtv Frontend, Totem video stops at the moment when mythtv
> window shows
> 5) Select TV -> Watch TV, no sound
> 6) Leave Mythtv Frontend, totem continues playing
>
> I even tried that with mythtv ppa listed above and same situation.
>
>
>
> ** Attachment added: "mythfrontend.txt"
> http://launchpadlibrarian.net/33791855/mythfrontend.txt
>
> --
> [ubuntu karmic] mythtv frontend inactivates sound
> https://bugs.launchpad.net/bugs/436792
> You received this bug notification because you are a member of Mythbuntu
> Developers, which is subscribed to Mythbuntu.
>

--
Mario Limonciello
<email address hidden>
Sent from Austin, Texas, United States

Sasa Jovic (sasa-jovic) wrote :

I worked on this problem yesterday evening and figured out how to get audio playing in Mythtv, this is more of workaround than solution.

I tried first to add EXPERIMENTALLY_ALLOW_PULSE_AUDIO=1 in .bashrc and .profile, but that did not work.

So i added that in mythfrontend script and since then i live TV is having sound in MythTV.

FYI, i use generic ubuntu (with gnome) with installed mythtv on top.

Dirk (ubuntu-tobit) wrote :

I too have just upgraded from mythbuntu 0.21 to whatever I get in Karmic.

There is a clue if you start up mythfrontend in a bash window:-

2009-10-23 21:45:47.966 WARNING:
2009-10-23 21:45:47.966 WARNING: ***Pulse Audio is running!!!!***
2009-10-23 21:45:47.966 WARNING:
2009-10-23 21:45:47.966 WARNING: You have told MythTV to ignore it.
2009-10-23 21:45:47.966 WARNING:

Only, I can't see where I have asked MythTV to ignore it (no sign of pulseaudio in setup, any clues as to where to look?)

And the trick to getting it to work is, in .bashrc:-

export EXPERIMENTALLY_ALLOW_PULSE_AUDIO=1

you will need to logout and login again, or start another bash window and start mythfrontend in that.

MarcRandolph (mrand) wrote :

Sasa and Dirk, thank you for hunting down this ticket to add your useful info. Could one of you please open a new ticket since this one is closed? After doing that, please:

1. Post that bug number to this ticket so that it is easy for others to find
2. Dirk, please add to that ticket if you are running mythtv on top of normal ubuntu with gnome (as Sasa was)
3. the output of apt-cache policy mythtv-frontend (from both of you)

Thank you!

Suger (suger) wrote :

When you start mythfrontend without the export EXPERIMENTALLY_ALLOW_PULSE_AUDIO=1 quirk, the second line of the output is

AudioPulseUtil: Suspend Success

and when you quit, the one before last is

AudioPulseUtil: Resume Success

So, in fact, mythfrontend is (successfully) suspending pulseaudio, which might explain why we don't get any sound after. Just my 2 cents

Geoffrey Pursell (geoffp) wrote :

I noticed this problem initially because I use pulseaudio on my Myth machine to digitally route audio from my home computers to my living room speakers. (That's kind of a killer app, actually.) If Myth is allowed to suspend PA on startup, audio players elsewhere in the home hang when trying to play through the Myth box.

export EXPERIMENTALLY_ALLOW_PULSE_AUDIO=1 works beautifully for me so far. MythTV and emulators (mess,mame,zsnes,mednafen) all seem to work when set to use OSS. PA seems to pick up their audio without needing padsp.

MarcRandolph (mrand) wrote :

Howdy all, This bug has been closed closed. I have opened a new one to track continuing pulse related issues: https://bugs.launchpad.net/mythbuntu/+bug/460579

For anyone interested, please subscribe yourself to that bug. It would be helpful if one or more of you could add some information to that ticket:

1. the output of: apt-cache policy mythtv-frontend
2. If you are running mythtv with gnome (rather than xfce)

Thanks!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.