mythtv crashed with SIGSEGV in TV::DoEditSchedule()

Bug #416100 reported by Jussi Saarinen on 2009-08-19
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
MythTV
Fix Released
Unknown
mythtv (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: mythtv

lsb_release -rd
Description: Ubuntu karmic (development branch)
Release: 9.10

apt-cache policy mythtv
mythtv:
  Installed: (none)
  Candidate: 0.22.0~trunk21333-0ubuntu1
  Version table:
     0.22.0~trunk21333-0ubuntu1 0
        990 http://archive.ubuntu.com karmic/multiverse Packages

After upgrading jaunty -> karmic mythtv is unable to run. I have started it from menu (Applications->Sound & Video->Mythtv Frontend) and from command line with 'mythtv'. Frontend loads inter for a second or two but then it just disappears. Same problem for 'mythtv-setup'.

ProblemType: Crash
Architecture: i386
Date: Wed Aug 19 22:52:40 2009
Disassembly: 0x0:
DistroRelease: Ubuntu 9.10
ExecutablePath: /usr/bin/mythtv
NonfreeKernelModules: nvidia
Package: mythtv-frontend 0.22.0~trunk21333-0ubuntu1
ProcCmdline: mythtv
ProcEnviron:
 LANGUAGE=en_US.ISO-8859-15
 PATH=(custom, no user)
 SHELL=/bin/zsh
 LANG=en_US.ISO-8859-15
 LC_CTYPE=fi_FI@euro
ProcVersionSignature: Ubuntu 2.6.31-6.25-generic
SegvAnalysis:
 Segfault happened at: 0x0:
 PC (0x00000000) not located in a known VMA region (needed executable region)!
SegvReason: executing NULL VMA
Signal: 11
SourcePackage: mythtv
StacktraceTop:
 ?? ()
 TV::DoEditSchedule(int) () from /usr/lib/libmythtv-0.22.so.0
 TV::customEvent(QEvent*) () from /usr/lib/libmythtv-0.22.so.0
 TV::eventFilter(QObject*, QEvent*) () from /usr/lib/libmythtv-0.22.so.0
 QCoreApplicationPrivate::sendThroughObjectEventFilters(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
Title: mythtv crashed with SIGSEGV in TV::DoEditSchedule()
Uname: Linux 2.6.31-6-generic i686
UserGroups: adm admin audio cdrom dialout dip floppy fuse lpadmin mythtv plugdev sambashare scanner vboxusers video

Jussi Saarinen (jms) wrote :
visibility: private → public
Jussi Saarinen (jms) wrote :

Updated 'apt-cache policy mythtv'
mythtv:
  Installed: 0.22.0~trunk21333-0ubuntu1
  Candidate: 0.22.0~trunk21333-0ubuntu1
  Version table:
 *** 0.22.0~trunk21333-0ubuntu1 0
        990 http://archive.ubuntu.com karmic/multiverse Packages
        100 /var/lib/dpkg/status

Didn't have any affect to the problem

StacktraceTop:?? ()

tags: added: apport-failed-retrace
tags: removed: need-i386-retrace
MarcRandolph (mrand) wrote :

Seems complete, so marking as confirmed and created upstream ticket.

Changed in mythtv (Ubuntu):
status: New → Confirmed
Changed in mythtv:
status: Unknown → New
Jussi Saarinen (jms) wrote :

With latest version in karmic repository (0.22.0~trunk21742-0ubuntu1) command 'mythfrontend' launches frontend succesfully which was not the case with earlier version, mythtv-setup is functional also.

Command 'mythtv' still crashes like reported in first post, maybe it is not intended to run directly?

MarcRandolph (mrand) wrote :

> Command 'mythtv' still crashes like reported in first post, maybe it is not intended to run directly?

That is correct. It is an unfortunately named test application. mythtv-test would be an infinitely better name.
Even still, upstream has corrected the crashes of this app in http://svn.mythtv.org/trac/changeset/21893, which will be included in the next sync upstream.

Changed in mythtv (Ubuntu):
status: Confirmed → Fix Released
Changed in mythtv:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.