myth-backend wants to start in runlevel2 while mysql is not ready yet

Bug #368145 reported by tafkaz on 2009-04-27
4
Affects Status Importance Assigned to Milestone
mysql-dfsg-5.0 (Ubuntu)
Undecided
Unassigned
mythtv (Ubuntu)
Undecided
Unassigned

Bug Description

I have the problem that mythtv-backend wants to connect to mysql in runlevel 2 (jaunty standard) although mysql is not yet ready.
This causes myth-backend to start, but not reach the complete DB, while mysql starts perfectly without any errors.
The result in my case is, that mythtv's recording schedule cant be seen by mythtv-backend.
Restarting /etc/init.d/mythtv-backend (now that mysql is fully loaded) made everything work perfectly again.
I used sysv-rc-conf to remove the entries for mythtv-backend in runlevel2 (don't know what they're for anyway).
Now mysql has the time to start up before myth starts.

This can only be a workaround though i think...

Description: Ubuntu 9.04
Release: 9.04

mythtv-backend:
  Installiert: 0.21.0+fixes20455-0ubuntu0+mythbuntu3
  Kandidat: 0.21.0+fixes20455-0ubuntu0+mythbuntu3
  Versions-Tabelle:
 *** 0.21.0+fixes20455-0ubuntu0+mythbuntu3 0
        500 http://weeklybuilds.mythbuntu.org jaunty/main Packages
        100 /var/lib/dpkg/status
     0.21.0+fixes19961-0ubuntu8 0
        500 http://de.archive.ubuntu.com jaunty/multiverse Packages

Dustin Kirkland  (kirkland) wrote :

Which version of mysql are you running? This is probably a bug in the mysql init script.

Given, S20mysql S20mythtv-backend, the mythbackend script is 2nd (alphanumerically) and should be able to depend on all previous services being up and running. S20mysql should not exit 0 until mysql is actually available.

:-Dustin

Mario Limonciello (superm1) wrote :

It's sounding like this is probably a duplicate of bug 326768

tafkaz (zucca-web) wrote :

The Version of mysql:
mysql-server 5.1.30really5.0.75-0ubuntu10
and no, i don't think it's a duplicate of 326768.
mysql doesn't look like it is restarting but just seems to be unready when mythtv needs it.

Well it should be ready by the time that init script exits. The only reason
it wouldn't be ready is if it's getting restarted after the init script.

On Wed, Apr 29, 2009 at 16:12, tafkaz <email address hidden> wrote:

> The Version of mysql:
> mysql-server 5.1.30really5.0.75-0ubuntu10
> and no, i don't think it's a duplicate of 326768.
> mysql doesn't look like it is restarting but just seems to be unready when
> mythtv needs it.
>
> --
> myth-backend wants to start in runlevel2 while mysql is not ready yet
> https://bugs.launchpad.net/bugs/368145
> You received this bug notification because you are a member of MythTV
> Ubuntu Maintainers, which is subscribed to mythtv in ubuntu.
>

--
Mario Limonciello
<email address hidden>

Mathias Gug (mathiaz) wrote :

Does the latest version of mysql-server-5.0 (5.1.30really5.0.75-0ubuntu10.2) fix your problem?

Changed in mysql-dfsg-5.0 (Ubuntu):
status: New → Incomplete
Mario Limonciello (superm1) wrote :

This should have been fixed in web updates. I've confirmed it myself on an upgraded Jaunty system.

Changed in mysql-dfsg-5.0 (Ubuntu):
status: Incomplete → Invalid
Changed in mythtv (Ubuntu):
status: New → Invalid
Changed in mysql-dfsg-5.0 (Ubuntu):
status: Invalid → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers