GetFilesystemInfos, TotalKB: -1 should be handled by AutoExpirer

Bug #367645 reported by Nicholas J Kreucher on 2009-04-26
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
MythTV
Fix Released
Unknown
Nominated for Release-0-21-fixes by Nicholas J Kreucher
mythtv (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: mythtv

Description: Ubuntu 8.04.2
Release: 8.04

mythtv-backend:
  Installed: 0.21.0+fixes18207-0ubuntu4~hardy1
  Candidate: 0.21.0+fixes18207-0ubuntu4~hardy1
  Version table:
 *** 0.21.0+fixes18207-0ubuntu4~hardy1 0
        500 http://us.archive.ubuntu.com hardy-backports/multiverse Packages
        100 /var/lib/dpkg/status
     0.21.0+fixes16838-0ubuntu3 0
        500 http://us.archive.ubuntu.com hardy/multiverse Packages

Problems with GetFilesystemInfos will return -1 for TotalKB an UsedKB, which is obviously an error condition. However, the AutoExpirer will happily delete all your recordings, since FreeKB is also 0.

--- GetFilesystemInfos directory list start ---
Dir: pacifico:/var/lib/mythtv/recordings
     Location: Local
     Drive ID: 1
     TotalKB : -1
     UsedKB : -1
     FreeKB : 0

--- GetFilesystemInfos directory list end ---

Two issues:
1) Root cause of GetFilesystemInfos failing
2) AutoExpirer not handling this error case from GetFilesystemInfos correctly.

Linking in http://svn.mythtv.org/trac/ticket/6503, as a safety net fix has been committed (http://svn.mythtv.org/trac/changeset/20452) to fix issue #2. The root case is being investigated, follow http://svn.mythtv.org/trac/ticket/6503 for details.

Changed in mythtv:
status: Unknown → Confirmed
Changed in mythtv:
status: Confirmed → Fix Released
MarcRandolph (mrand) wrote :

Any builds after 26 Apr 09 (r20453) should contain this.

Changed in mythtv (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.