mythtv-backend init script lacks the 'status' action

Bug #251325 reported by Dustin Kirkland  on 2008-07-23
4
Affects Status Importance Assigned to Milestone
mythtv (Ubuntu)
Wishlist
Dustin Kirkland 

Bug Description

Binary package hint: mythtv

mythtv-backend init script lacks the 'status' action. It would be useful to be able to determine if a backend is running or not by querying:
 * /etc/init.d/mythtv-backend status

A concerted effort is being made to add status actions to many Ubuntu services' init scripts:
 * https://wiki.ubuntu.com/InitScriptStatusActions

:-Dustin

Related branches

Dustin Kirkland  (kirkland) wrote :

Patch attached.

Please review/sponsor/upload.

:-Dustin

Changed in mythtv:
assignee: nobody → kirkland
importance: Undecided → Wishlist
status: New → In Progress

Is lsb-base of this version present in earlier Ubuntu releases
(gutsy,hardy)? MythTV is one of those packages that is very commonly
backported alot. I'd hate to lose backportability if it's not. Otherwise,
looks good

On Wed, Jul 23, 2008 at 18:51, Dustin Kirkland <email address hidden>
wrote:

> Patch attached.
>
> Please review/sponsor/upload.
>
> :-Dustin
>
> ** Attachment added: "mythtv.251325.debdiff"
> http://launchpadlibrarian.net/16273272/mythtv.251325.debdiff
>
> --
> mythtv-backend init script lacks the 'status' action
> https://bugs.launchpad.net/bugs/251325
> You received this bug notification because you are a member of MythTV
> Ubuntu Maintainers, which is subscribed to mythtv in ubuntu.
>

--
Mario Limonciello
<email address hidden>

laga (laga) wrote :

Mario Limonciello wrote:
> Is lsb-base of this version present in earlier Ubuntu releases
> (gutsy,hardy)? MythTV is one of those packages that is very commonly
> backported alot. I'd hate to lose backportability if it's not. Otherwise,
> looks good
>

Weren't we going to use Upstart?

Changed in mythtv:
status: In Progress → Confirmed
Changed in mythtv:
status: Confirmed → Triaged
Dustin Kirkland  (kirkland) wrote :

Updated patch.

Since Intrepid's mythtv will likely be backported to Hardy, this updated patch does not use the status_of_proc() function, which is only found in Intrepid's (and beyond) LSB.

:-Dustin

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mythtv - 0.21.0+fixes18207-0ubuntu6

---------------
mythtv (0.21.0+fixes18207-0ubuntu6) intrepid; urgency=low

  * debian/mythtv-backend.init: Add the 'status' action (LP: #251325).

 -- Dustin Kirkland <email address hidden> Wed, 03 Sep 2008 10:16:21 -0500

Changed in mythtv:
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers