Ubuntu

PgUp and PgDown mismapped on MCE

Reported by MarcRandolph on 2008-07-19
2
Affects Status Importance Assigned to Milestone
Mythbuntu
Undecided
Unassigned
mythtv (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: mythbuntu-lirc-generator

I haven't been able to find that it has already been fixed, so if it has, feel free to close this.

I have what I believe to be a pretty typical remote:

http://www.mythtv.org/wiki/index.php/MCE_Remote

(specifically a version 2 that reports from SMK Manufacturing, Inc.)

Anyway, ChanUp and ChanDown buttons generate an Up/Down key config rather than PgUp/PgDown:

begin
    remote = mceusb
    prog = mythtv
    button = ChanDown
    config = Down
    repeat = 0
    delay = 0
end

when it should be:

begin
    remote = mceusb
    prog = mythtv
    button = ChanDown
    config = PgDown
    repeat = 0
    delay = 0
end

Same for ChanUp/PgUp.

This is by design. It allows for ChanUp/Down to work while in LiveTV. If you
prefer another configuration modify the config you posted to your
preference.

-Nick

On Sat, Jul 19, 2008 at 12:23 PM, MarcRandolph <email address hidden> wrote:

> Public bug reported:
>
> Binary package hint: mythbuntu-lirc-generator
>
> I haven't been able to find that it has already been fixed, so if it
> has, feel free to close this.
>
> I have what I believe to be a pretty typical remote:
>
> http://www.mythtv.org/wiki/index.php/MCE_Remote
>
> (specifically a version 2 that reports from SMK Manufacturing, Inc.)
>
> Anyway, ChanUp and ChanDown buttons generate an Up/Down key config
> rather than PgUp/PgDown:
>
> begin
> remote = mceusb
> prog = mythtv
> button = ChanDown
> config = Down
> repeat = 0
> delay = 0
> end
>
> when it should be:
>
> begin
> remote = mceusb
> prog = mythtv
> button = ChanDown
> config = PgDown
> repeat = 0
> delay = 0
> end
>
> Same for ChanUp/PgUp.
>
> ** Affects: mythbuntu-lirc-generator (Ubuntu)
> Importance: Undecided
> Status: New
>
> --
> PgUp and PgDown mismapped on MCE
> https://bugs.launchpad.net/bugs/250146
> You received this bug notification because you are a member of
> Mythbuntu, which is subscribed to mythbuntu-lirc-generator in ubuntu.
>

MarcRandolph (mrand) wrote :

Since there is already and up and down button which does that, I have to admit I don't quite understand the logic of having a second set of buttons do the exact same function.

Mario Limonciello (superm1) wrote :

I somewhat agree, and think the big is really in the fact that mythtv
should default to page up and down being Chan up and down.

On 07/19/2008, MarcRandolph <email address hidden> wrote:
> Since there is already and up and down button which does that, I have to
> admit I don't quite understand the logic of having a second set of
> buttons do the exact same function.
>
> --
> PgUp and PgDown mismapped on MCE
> https://bugs.launchpad.net/bugs/250146
> You received this bug notification because you are a member of
> Mythbuntu, which is subscribed to mythbuntu-lirc-generator in ubuntu.
>

--
Sent from Gmail for mobile | mobile.google.com

Mario Limonciello
<email address hidden>

Mario Limonciello (superm1) wrote :

So i'm setting this to the mythtv package instead. We need to forward this change upstream so that the defaults have pgup/pgdown mapped to ch+/ch-

affects: mythbuntu-lirc-generator (Ubuntu) → mythtv (Ubuntu)
Changed in mythtv (Ubuntu):
status: New → Confirmed
MarcRandolph (mrand) wrote :

Moving to correct bucket.

Changed in mythtv (Ubuntu):
status: Confirmed → Invalid
MarcRandolph (mrand) wrote :

Ooops, I somehow missed Mario's comment.

Changed in mythtv (Ubuntu):
status: Invalid → Confirmed
Nick Fox (nickj-fox) on 2009-08-31
Changed in mythbuntu:
status: New → Triaged
Thomas Mashos (tgm4883) wrote :

Marking incomplete as this release isn't supported anymore. Can anyone confirm that this issue is still present on a supported Mythbuntu/MythTV release?

Changed in mythbuntu:
status: Triaged → Incomplete
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers