memory leak in myth-backend on x64 when recording from DVB-C / qam256

Bug #237137 reported by ian dobson on 2008-06-03
2
Affects Status Importance Assigned to Milestone
MythTV
Fix Released
Unknown
mythtv (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: mythtv

When recording from a "Satelco EasyWatch DVB-C MK3" DVB-C card I see a memory leak in mythtv-backend.
The system seems to allocate about 0.2% of the 4Gb ram installed in the backend every minute until the memory usage rises to about 80% then the system starts swapping and becomes totally unusable.
When the recording is finished the memory is not released. The only way to release the memory is to stop/start the mythtv-backend process.

kernel 2.6.24-16-generic #1 SMP Thu Apr 10 12:47:45 UTC 2008 x86_64 GNU/Linux.

My cable provider sends DVB-C in QAM256.

The problem could be related to EIT and the option "Close DVB card when not it use".

mythbackend version: 0.21.20080304-1

I've run the backend under valgrind and have attached the log file.

Valgrind started with the following options:-
valgrind --leak-check=full --error-limit=no --show-reachable=yes --log-file=logfile -v -- /usr/bin/mythbackend
--daemon --logfile /var/log/mythtv/mythbackend.log --pidfile /var/run/mythtv/mythbackend.pid --noupnp | tee backend.log

Regards
Ian Dobson

ian dobson (i-dobson) wrote :
ian dobson (i-dobson) wrote :
ian dobson (i-dobson) wrote :
ian dobson (i-dobson) wrote :

I've done abit more testing and the leak only happens on some channels. At the moment I can say that the leak happens on channel ProSieben (Pro7). Note I can watch the programms recorded from ProSieben without any problems.

After abit of googling I've come across several comments about "encoding fixups for German networks"

Regards
Ian Dobson

laga (laga) wrote :

I've forwarded your bug report to upstream. Thanks!

Changed in mythtv:
importance: Undecided → Unknown
status: New → Unknown
Changed in mythtv:
status: Unknown → New
ian dobson (i-dobson) wrote :

Upgraded mythtv-backend to 0.21.0+fixes17453,
kernel to 2.6.24-18-generic leak still happening.

Regards
Ian Dobson

ian dobson (i-dobson) wrote :

Upgraded mythtv-backend to 0.21.0+fixes17490, tested with a "KNC One TV-Station " card and still seeing the leak.

laga (laga) wrote :

I seem to remember you commenting in the forums that this is fixed by a newer version of the weekly builds package. Can you confirm? (This was probably fixed by Janneg's charset fixup commit - although he doesn't believe that ;))

Changed in mythtv:
status: New → Incomplete

Hi,

Laga, you have a very good memory :)

It looks as if the memory leak problem is solved, going through my memory
usage log for mythtv-backend the last time I saw a memory utilisation of
more than about 80Mb was on "Mon Aug 25 22:32:01" so the update to the
weekly build from just after this date fixed it.

Regards
Ian Dobson

Home of the Atmel based UDP mobile web cam http://www.planet-ian.com
All mails scanned with av-filter.pl (F-Prot / perl)

----- Original Message -----
From: "laga" <email address hidden>
To: <email address hidden>
Sent: Sunday, September 21, 2008 6:19 PM
Subject: [Bug 237137] Re: memory leak in myth-backend on x64 when
recordingfrom DVB-C / qam256

I seem to remember you commenting in the forums that this is fixed by a
newer version of the weekly builds package. Can you confirm? (This was
probably fixed by Janneg's charset fixup commit - although he doesn't
believe that ;))

** Changed in: mythtv (Ubuntu)
       Status: New => Incomplete

--
memory leak in myth-backend on x64 when recording from DVB-C / qam256
https://bugs.launchpad.net/bugs/237137
You received this bug notification because you are a direct subscriber
of the bug.

Status in MythTV: New
Status in “mythtv” source package in Ubuntu: Incomplete

Bug description:
Binary package hint: mythtv

When recording from a "Satelco EasyWatch DVB-C MK3" DVB-C card I see a
memory leak in mythtv-backend.
The system seems to allocate about 0.2% of the 4Gb ram installed in the
backend every minute until the memory usage rises to about 80% then the
system starts swapping and becomes totally unusable.
When the recording is finished the memory is not released. The only way to
release the memory is to stop/start the mythtv-backend process.

kernel 2.6.24-16-generic #1 SMP Thu Apr 10 12:47:45 UTC 2008 x86_64
GNU/Linux.

My cable provider sends DVB-C in QAM256.

The problem could be related to EIT and the option "Close DVB card when not
it use".

mythbackend version: 0.21.20080304-1

I've run the backend under valgrind and have attached the log file.

Valgrind started with the following options:-
valgrind --leak-check=full --error-limit=no --show-reachable=yes --log-file=logfile
 -v -- /usr/bin/mythbackend
--daemon --logfile /var/log/mythtv/mythbackend.log --pidfile
/var/run/mythtv/mythbackend.pid --noupnp | tee backend.log

Regards
Ian Dobson

laga (laga) wrote :

Okay, then I'm closing this issue. The fix is also in Intrepid.

Changed in mythtv:
status: Incomplete → Fix Released
Changed in mythtv:
status: New → Confirmed
Changed in mythtv:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.